Bug 451014 - Can't drop draggable list item back into its original position after dragging it around
Summary: Can't drop draggable list item back into its original position after dragging...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Unclassified
Component: general (show other bugs)
Version: 5.92.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2022-03-01 21:34 UTC by Jack Hill
Modified: 2022-03-29 02:20 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.93


Attachments
Dragging around a playlist item (404.59 KB, video/webm)
2022-03-01 21:34 UTC, Jack Hill
Details
Moving a track in playlist (810.62 KB, video/webm)
2022-03-13 13:22 UTC, Jack Hill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jack Hill 2022-03-01 21:34:46 UTC
Created attachment 147228 [details]
Dragging around a playlist item

SUMMARY
Using git master

When I was taking the video for this I noticed that sometimes this occurs and sometimes it doesn't. No idea why

STEPS TO REPRODUCE
1. Click and hold a track in the playlist to move it
2. Move it around (don't let go!)
3. Try to put the track back in its original position

OBSERVED RESULT
The tracks above and below it are stuck together so I can't drop the track back in its original position

EXPECTED RESULT
Should be able to drop the track in its original position

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: openSUSE Tumbleweed 20220228
KDE Plasma Version: 5.24.2
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2022-03-08 18:21:45 UTC
Fixed in 22.04 with the playlist delegate rewrite.
Comment 2 Jack Hill 2022-03-08 23:08:59 UTC
This is an issue with the rewrite. Just checked it still occurs as of commit fac46139ade89f67d275bd8c11b5c92c0601acf4
Comment 3 Nate Graham 2022-03-10 19:06:20 UTC
It's working fine for me. Could you attach a screen recording that shows the issue?
Comment 4 Jack Hill 2022-03-13 13:22:25 UTC
Created attachment 147469 [details]
Moving a track in playlist

Here's another video.
Sometimes this bug happens, sometimes it doesn't 🤷‍♂️. No idea why.
Comment 5 Nate Graham 2022-03-14 16:48:14 UTC
Huh, that's weird. Still cannot reproduce it.
Comment 6 trmdi 2022-03-25 15:57:12 UTC
Confirm. I find that it's a bug of Kirigami's Drag handler component. It happens when you hold the drag handler button at its lowest points.
Comment 7 Nate Graham 2022-03-29 02:20:07 UTC
Git commit a507a48e979c5881f65faac973a5b82b925e8642 by Nate Graham, on behalf of Tranter Madi.
Committed on 29/03/2022 at 02:20.
Pushed by ngraham into branch 'master'.

ListItemDragHandle: Emit moveRequest when cursor enters a new index
FIXED-IN: 5.93

M  +1    -1    src/controls/ListItemDragHandle.qml

https://invent.kde.org/frameworks/kirigami/commit/a507a48e979c5881f65faac973a5b82b925e8642