Bug 450594 - Plasma crashes in PlasmaQuick::ContainmentViewPrivate::setContainment() at login
Summary: Plasma crashes in PlasmaQuick::ContainmentViewPrivate::setContainment() at login
Status: RESOLVED DUPLICATE of bug 449981
Alias: None
Product: plasmashell
Classification: Plasma
Component: Multi-screen support (show other bugs)
Version: 5.24.0
Platform: OpenSUSE Linux
: NOR crash
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-02-20 01:18 UTC by laurie jarden
Modified: 2022-09-23 15:19 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description laurie jarden 2022-02-20 01:18:49 UTC
Application: plasmashell (5.24.0)

Qt Version: 5.15.2
Frameworks Version: 5.90.0
Operating System: Linux 5.16.8-1-default x86_64
Windowing System: X11
Distribution: openSUSE Tumbleweed
DrKonqi: 5.24.0 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed: log in after locked session, also login after logout.
after login screen info on both monitors is not kept, ie
One screen over laps the other.
Application windows not opened in the same place nor on the correct screen.
Sound is not working properly - missing on some games.
Some games open then dissapear on first mouse click to game.
Immediate relogout/login mostly fixes things things until next lock screen or logout, even plasma still shows KDE crash handler.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = 0x0}
[KCrash Handler]
#6  0x00007f845d347cf1 in QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=0x99) at /usr/include/qt5/QtCore/qscopedpointer.h:118
#7  qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > const> (ptr=...) at /usr/include/qt5/QtCore/qglobal.h:1143
#8  QQuickWindow::d_func (this=0x91) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/quick/items/qquickwindow.h:79
#9  QQuickWindow::mouseGrabberItem (this=0x91) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/quick/items/qquickwindow.cpp:1732
#10 0x00007f845d34a49b in QQuickWindowPrivate::removeGrabber (this=0x56268d22dbb0, grabber=grabber@entry=0x56268afe5450, mouse=mouse@entry=true, touch=touch@entry=true) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/quick/items/qquickwindow.cpp:1001
#11 0x00007f845d32a002 in QQuickItemPrivate::setEffectiveVisibleRecur (this=0x56268afe2c10, newEffectiveVisible=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/quick/items/qquickitem.cpp:6067
#12 0x00007f845d32a037 in QQuickItemPrivate::setEffectiveVisibleRecur (this=this@entry=0x56268abc4a30, newEffectiveVisible=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/quick/items/qquickitem.cpp:6072
#13 0x00007f845d32a153 in QQuickItemPrivate::setVisible (this=0x56268abc4a30, visible=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/quick/items/qquickitem.cpp:5975
#14 0x00007f845d33759b in QQuickItem::qt_metacall (this=this@entry=0x56268abd1030, _c=_c@entry=QMetaObject::WriteProperty, _id=11, _a=_a@entry=0x7ffc7faa59c0) at .moc/moc_qquickitem.cpp:1048
#15 0x00007f845db1a8a6 in PlasmaQuick::AppletQuickItem::qt_metacall (this=this@entry=0x56268abd1030, _c=_c@entry=QMetaObject::WriteProperty, _id=<optimized out>, _a=_a@entry=0x7ffc7faa59c0) at /usr/src/debug/plasma-framework-5.90.0-1.1.x86_64/build/src/plasmaquick/KF5PlasmaQuick_autogen/include/moc_appletquickitem.cpp:364
#16 0x00007f844c27ac76 in AppletInterface::qt_metacall (this=0x56268abd1030, _c=QMetaObject::WriteProperty, _id=<optimized out>, _a=0x7ffc7faa59c0) at /usr/src/debug/plasma-framework-5.90.0-1.1.x86_64/build/src/scriptengines/qml/plasma_appletscript_declarative_autogen/include/moc_appletinterface.cpp:850
#17 0x00007f844c289226 in ContainmentInterface::qt_metacall (this=0x56268abd1030, _c=QMetaObject::WriteProperty, _id=<optimized out>, _a=0x7ffc7faa59c0) at /usr/src/debug/plasma-framework-5.90.0-1.1.x86_64/build/src/scriptengines/qml/plasma_appletscript_declarative_autogen/include/moc_containmentinterface.cpp:453
#18 0x00007f845ce05e1f in QQmlPropertyData::writeProperty (flags=..., value=<optimized out>, target=<optimized out>, this=<optimized out>) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../../src/qml/qml/qqmlpropertydata_p.h:379
#19 QQmlPropertyPrivate::write (object=object@entry=0x56268abd1030, property=..., value=..., context=<optimized out>, flags=..., flags@entry=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/qml/qqmlproperty.cpp:1292
#20 0x00007f845cd2c1f1 in QV4::QObjectWrapper::setProperty (engine=0x56268a953f90, object=0x56268abd1030, property=0x7f83f80a0668, value=...) at /usr/include/qt5/QtCore/qflags.h:120
#21 0x00007f845cd2ca62 in QV4::QObjectWrapper::setQmlProperty (value=..., revisionMode=QV4::QObjectWrapper::IgnoreRevision, name=<optimized out>, object=0x56268abd1030, qmlContext=<optimized out>, engine=0x56268a953f90) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:435
#22 QV4::QObjectWrapper::setQmlProperty (engine=0x56268a953f90, qmlContext=<optimized out>, object=0x56268abd1030, name=<optimized out>, revisionMode=QV4::QObjectWrapper::IgnoreRevision, value=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:418
#23 0x00007f845cd2cc05 in QV4::QObjectWrapper::virtualPut (m=0x7f844037d580, id=..., value=..., receiver=0x7f844037d580) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:722
#24 0x00007f845ccb53b3 in QV4::Object::put (receiver=0x7f844037d580, v=..., name=0x7f844037d588, this=0x7f844037d580) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../../src/qml/jsruntime/qv4string_p.h:280
#25 QV4::Lookup::setterFallback (l=<optimized out>, engine=0x56268a953f90, object=..., value=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/jsruntime/qv4lookup.cpp:497
#26 0x00007f845cd466b2 in QV4::Moth::VME::interpret (frame=0x7ffc7faa5e00, engine=0x56268a953f90, code=0x7f844c00394c ".':(\030\aVL\026.):*\030\b.+^\bL\n.,\030\t\b>-\tHM..:/\030\t.0:1>2\t.3:4\030\t.5:6>7\t.8:9\030\t.::;><\t.=:>\030\t.?:@>A\t.B:CL\n.D:E\030\t\n>F\t.G\030\t.H>I\t\026\006\002") at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:653
#27 0x00007f845cd4a917 in QV4::Moth::VME::exec (frame=frame@entry=0x7ffc7faa5e00, engine=engine@entry=0x56268a953f90) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:463
#28 0x00007f845ccddd3e in QV4::Function::call (this=this@entry=0x56268ab2a980, thisObject=<optimized out>, argv=argv@entry=0x7f844037d500, argc=<optimized out>, context=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/jsruntime/qv4function.cpp:69
#29 0x00007f845ce64b45 in QQmlJavaScriptExpression::evaluate (this=this@entry=0x56268c83f300, callData=callData@entry=0x7f844037d4d0, isUndefined=isUndefined@entry=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/qml/qqmljavascriptexpression.cpp:212
#30 0x00007f845ce168ab in QQmlBoundSignalExpression::evaluate (this=<optimized out>, a=<optimized out>) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../../src/qml/jsruntime/qv4jscall_p.h:95
#31 0x00007f845ce17a98 in QQmlBoundSignal_callback (e=0x56268d0a07b0, a=0x0) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../../src/qml/qml/qqmlboundsignalexpressionpointer_p.h:69
#32 0x00007f845ce49c75 in QQmlNotifier::emitNotify (endpoint=<optimized out>, a=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/qml/qqmlnotifier.cpp:104
#33 0x00007f845b847048 in doActivate<false> (sender=0x56268e8f9700, signal_index=30, argv=argv@entry=0x0) at kernel/qobject.cpp:3778
#34 0x00007f845b840bcd in QMetaObject::activate (sender=<optimized out>, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=argv@entry=0x0) at kernel/qobject.cpp:3959
#35 0x00007f845cdf0515 in QQmlVMEMetaObject::activate (this=this@entry=0x56268bd54370, object=<optimized out>, index=<optimized out>, args=args@entry=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:1312
#36 0x00007f845cdf2c1f in QQmlVMEMetaObject::metaCall (this=0x56268bd54370, o=<optimized out>, c=<optimized out>, _id=<optimized out>, a=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde43-1.1.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:880
#37 0x00007f845b81e7cc in QMetaProperty::write (this=this@entry=0x7ffc7faa7c40, object=object@entry=0x56268e8f9700, value=...) at kernel/qmetaobject.cpp:3258
#38 0x00007f845b8461c6 in QObject::setProperty (this=this@entry=0x56268e8f9700, name=name@entry=0x7f845db3c0c9 "containment", value=...) at kernel/qobject.cpp:4070
#39 0x00007f845db21dc0 in PlasmaQuick::ContainmentViewPrivate::setContainment (this=0x56268e370b50, cont=<optimized out>) at /usr/src/debug/plasma-framework-5.90.0-1.1.x86_64/src/plasmaquick/containmentview.cpp:124
#40 0x0000562689e27f6c in ?? ()
#41 0x00007f845b8474e3 in QtPrivate::QSlotObjectBase::call (a=0x7ffc7faa7ed0, r=0x56268a6ab430, this=0x56268b169460) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#42 doActivate<false> (sender=0x56268a699290, signal_index=3, argv=0x7ffc7faa7ed0) at kernel/qobject.cpp:3886
#43 0x0000562689e2361c in ?? ()
#44 0x0000562689e238f7 in ?? ()
#45 0x00007f845b83d48e in QObject::event (this=0x56268a699290, e=0x56268d1b9d00) at kernel/qobject.cpp:1314
#46 0x00007f845c5aea7f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x56268a699290, e=0x56268d1b9d00) at kernel/qapplication.cpp:3632
#47 0x00007f845b810e1a in QCoreApplication::notifyInternal2 (receiver=0x56268a699290, event=0x56268d1b9d00) at kernel/qcoreapplication.cpp:1064
#48 0x00007f845b813e57 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x56268a4d6cb0) at kernel/qcoreapplication.cpp:1821
#49 0x00007f845b868cd3 in postEventSourceDispatch (s=s@entry=0x56268a631dc0) at kernel/qeventdispatcher_glib.cpp:277
#50 0x00007f8459b77d5f in g_main_dispatch (context=0x7f8450005000) at ../glib/gmain.c:3381
#51 g_main_context_dispatch (context=0x7f8450005000) at ../glib/gmain.c:4099
#52 0x00007f8459b780e8 in g_main_context_iterate (context=context@entry=0x7f8450005000, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#53 0x00007f8459b7819f in g_main_context_iteration (context=0x7f8450005000, may_block=1) at ../glib/gmain.c:4240
#54 0x00007f845b868354 in QEventDispatcherGlib::processEvents (this=0x56268a636410, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#55 0x00007f845b80f81b in QEventLoop::exec (this=this@entry=0x7ffc7faa8300, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#56 0x00007f845b817af0 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#57 0x0000562689e0669a in ?? ()
#58 0x00007f845b12e5c0 in __libc_start_call_main () from /lib64/libc.so.6
#59 0x00007f845b12e67c in __libc_start_main_impl () from /lib64/libc.so.6
#60 0x0000562689e06a35 in ?? ()
[Inferior 1 (process 31201) detached]

The reporter indicates this bug may be a duplicate of or related to bug 450163.

Possible duplicates by query: bug 450163, bug 450124, bug 450113, bug 449981, bug 449856.

Reported using DrKonqi
Comment 1 Fushan Wen 2022-02-20 13:49:25 UTC
What panel opacity mode do you use?
Comment 2 Fushan Wen 2022-02-20 13:56:24 UTC
What applets do  you have on the panel?
Comment 3 laurie jarden 2022-02-20 14:03:51 UTC
The panel & global theme are default - breeze with no changes .
Comment 4 laurie jarden 2022-02-20 14:05:19 UTC
The applets in the panel are tumbleweed default with the addition of the trash app.
Comment 5 Fushan Wen 2022-02-20 14:57:49 UTC
Looks like there are errors in the panel configuration. If you can share your panel configuration ( ~/.config/plasma-org.kde.plasma.desktop-appletsrc ) so I can test it.
Comment 6 Fushan Wen 2022-02-20 14:58:52 UTC
If you rename ~/.config/plasma-org.kde.plasma.desktop-appletsrc to ~/.config/plasma-org.kde.plasma.desktop-appletsrc.bak and try to reproduce the bug, will the crash persist?
Comment 7 laurie jarden 2022-02-20 23:53:34 UTC
[ActionPlugins][0]
MiddleButton;NoModifier=org.kde.paste
RightButton;NoModifier=org.kde.contextmenu
wheel:Vertical;NoModifier=org.kde.contextmenu

[ActionPlugins][0][RightButton;NoModifier]
_add panel=true
_context=true
_lock_screen=true
_logout=true
_run_command=true
_sep1=true
_sep2=true
_sep3=true
_wallpaper=true
add widgets=true
configure=true
configure shortcuts=false
edit mode=true
manage activities=true
remove=true
run associated application=true

[ActionPlugins][0][wheel:Vertical;NoModifier]
_add panel=true
_context=true
_lock_screen=true
_logout=true
_run_command=true
_sep1=true
_sep2=true
_sep3=true
_wallpaper=true
add widgets=true
configure=true
configure shortcuts=false
edit mode=true
manage activities=true
remove=true
run associated application=true

[ActionPlugins][1]
RightButton;NoModifier=org.kde.contextmenu

[Containments][140]
activityId=
formfactor=2
immutability=1
lastScreen=3
location=4
plugin=org.kde.panel
wallpaperplugin=org.kde.image

[Containments][140][Applets][142]
immutability=1
plugin=org.kde.plasma.pager

[Containments][140][Applets][142][Configuration]
PreloadWeight=0

[Containments][140][Applets][144]
immutability=1
plugin=org.kde.plasma.marginsseparator

[Containments][140][Applets][144][Configuration]
PreloadWeight=0

[Containments][140][Applets][145]
immutability=1
plugin=org.kde.plasma.systemtray

[Containments][140][Applets][145][Configuration]
PreloadWeight=0
SystrayContainmentId=146

[Containments][140][Applets][157]
immutability=1
plugin=org.kde.plasma.digitalclock

[Containments][140][Applets][157][Configuration]
PreloadWeight=0

[Containments][140][Applets][158]
immutability=1
plugin=org.kde.plasma.showdesktop

[Containments][140][Applets][158][Configuration]
PreloadWeight=0

[Containments][140][Applets][161]
immutability=1
plugin=org.kde.plasma.taskmanager

[Containments][140][Applets][161][Configuration]
PreloadWeight=0

[Containments][140][Applets][161][Configuration][General]
launchers=

[Containments][140][Applets][163]
immutability=1
plugin=org.kde.plasma.kicker

[Containments][140][Applets][163][Configuration]
PreloadWeight=0

[Containments][140][Applets][163][Configuration][ConfigDialog]
DialogHeight=540
DialogWidth=720

[Containments][140][Applets][163][Configuration][General]
customButtonImage=SUSEgreeter
favoritesPortedToKAstats=true
useCustomButtonImage=true

[Containments][140][Applets][167]
immutability=1
plugin=org.kde.plasma.trash

[Containments][140][Applets][167][Configuration]
PreloadWeight=0

[Containments][140][ConfigDialog]
DialogHeight=84
DialogWidth=2560

[Containments][140][Configuration]
PreloadWeight=0

[Containments][140][General]
AppletOrder=163;142;161;144;145;157;167;158

[Containments][146]
activityId=
formfactor=2
immutability=1
lastScreen=3
location=4
plugin=org.kde.plasma.private.systemtray
wallpaperplugin=org.kde.image

[Containments][146][Applets][147]
immutability=1
plugin=org.kde.plasma.pkupdates

[Containments][146][Applets][147][Configuration]
PreloadWeight=0

[Containments][146][Applets][148]
immutability=1
plugin=org.kde.plasma.volume

[Containments][146][Applets][148][Configuration]
PreloadWeight=0

[Containments][146][Applets][149]
immutability=1
plugin=org.kde.plasma.printmanager

[Containments][146][Applets][149][Configuration]
PreloadWeight=0

[Containments][146][Applets][150]
immutability=1
plugin=org.kde.plasma.clipboard

[Containments][146][Applets][150][Configuration]
PreloadWeight=0

[Containments][146][Applets][151]
immutability=1
plugin=org.kde.plasma.devicenotifier

[Containments][146][Applets][151][Configuration]
PreloadWeight=0

[Containments][146][Applets][152]
immutability=1
plugin=org.kde.plasma.notifications

[Containments][146][Applets][152][Configuration]
PreloadWeight=0

[Containments][146][Applets][153]
immutability=1
plugin=org.kde.plasma.keyboardindicator

[Containments][146][Applets][153][Configuration]
PreloadWeight=0

[Containments][146][Applets][154]
immutability=1
plugin=org.kde.plasma.nightcolorcontrol

[Containments][146][Applets][154][Configuration]
PreloadWeight=0

[Containments][146][Applets][155]
immutability=1
plugin=org.kde.plasma.keyboardlayout

[Containments][146][Applets][155][Configuration]
PreloadWeight=0

[Containments][146][Applets][156]
immutability=1
plugin=org.kde.plasma.manage-inputmethod

[Containments][146][Applets][156][Configuration]
PreloadWeight=0

[Containments][146][Applets][159]
immutability=1
plugin=org.kde.plasma.battery

[Containments][146][Applets][159][Configuration]
PreloadWeight=0

[Containments][146][Applets][160]
immutability=1
plugin=org.kde.plasma.networkmanagement

[Containments][146][Applets][160][Configuration]
PreloadWeight=0

[Containments][146][Applets][164]
immutability=1
plugin=org.kde.plasma.mediacontroller

[Containments][146][Applets][164][Configuration]
PreloadWeight=0

[Containments][146][Configuration]
PreloadWeight=0

[Containments][146][General]
extraItems=org.kde.plasma.pkupdates,org.kde.plasma.volume,org.kde.plasma.networkmanagement,org.kde.plasma.printmanager,org.kde.plasma.bluetooth,org.kde.plasma.battery,org.kde.plasma.clipboard,org.kde.plasma.devicenotifier,org.kde.plasma.mediacontroller,org.kde.plasma.notifications,org.kde.plasma.keyboardindicator,org.kde.plasma.nightcolorcontrol,org.kde.plasma.keyboardlayout,org.kde.plasma.manage-inputmethod
iconSize=1
knownItems=org.kde.plasma.pkupdates,org.kde.plasma.volume,org.kde.plasma.networkmanagement,org.kde.plasma.printmanager,org.kde.plasma.bluetooth,org.kde.plasma.battery,org.kde.plasma.clipboard,org.kde.plasma.devicenotifier,org.kde.plasma.mediacontroller,org.kde.plasma.notifications,org.kde.plasma.keyboardindicator,org.kde.plasma.nightcolorcontrol,org.kde.plasma.keyboardlayout,org.kde.plasma.manage-inputmethod

[Containments][168]
activityId=
formfactor=2
immutability=1
lastScreen=0
location=4
plugin=org.kde.panel
wallpaperplugin=org.kde.image

[Containments][168][Applets][170]
immutability=1
plugin=org.kde.plasma.pager

[Containments][168][Applets][170][Configuration]
PreloadWeight=0

[Containments][168][Applets][172]
immutability=1
plugin=org.kde.plasma.marginsseparator

[Containments][168][Applets][172][Configuration]
PreloadWeight=0

[Containments][168][Applets][173]
immutability=1
plugin=org.kde.plasma.systemtray

[Containments][168][Applets][173][Configuration]
PreloadWeight=92
SystrayContainmentId=174

[Containments][168][Applets][185]
immutability=1
plugin=org.kde.plasma.digitalclock

[Containments][168][Applets][185][Configuration]
PreloadWeight=58

[Containments][168][Applets][192]
immutability=1
plugin=org.kde.plasma.trash

[Containments][168][Applets][192][Configuration]
PreloadWeight=0

[Containments][168][Applets][196]
immutability=1
plugin=org.kde.plasma.kicker

[Containments][168][Applets][196][Configuration]
PreloadWeight=100

[Containments][168][Applets][196][Configuration][ConfigDialog]
DialogHeight=624
DialogWidth=775

[Containments][168][Applets][196][Configuration][General]
appNameFormat=2
customButtonImage=SUSEgreeter
favoritesPortedToKAstats=true
useCustomButtonImage=true

[Containments][168][Applets][197]
immutability=1
plugin=org.kde.plasma.taskmanager

[Containments][168][Applets][197][Configuration]
PreloadWeight=0

[Containments][168][Applets][197][Configuration][ConfigDialog]
DialogHeight=782
DialogWidth=811

[Containments][168][Applets][197][Configuration][General]
launchers=

[Containments][168][ConfigDialog]
DialogHeight=84
DialogWidth=2560

[Containments][168][Configuration]
PreloadWeight=0

[Containments][168][General]
AppletOrder=196;170;197;172;192;173;185

[Containments][174]
activityId=
formfactor=2
immutability=1
lastScreen=0
location=4
plugin=org.kde.plasma.private.systemtray
wallpaperplugin=org.kde.image

[Containments][174][Applets][175]
immutability=1
plugin=org.kde.plasma.pkupdates

[Containments][174][Applets][175][Configuration]
PreloadWeight=33

[Containments][174][Applets][176]
immutability=1
plugin=org.kde.plasma.volume

[Containments][174][Applets][176][Configuration]
PreloadWeight=51

[Containments][174][Applets][177]
immutability=1
plugin=org.kde.plasma.printmanager

[Containments][174][Applets][177][Configuration]
PreloadWeight=0

[Containments][174][Applets][178]
immutability=1
plugin=org.kde.plasma.clipboard

[Containments][174][Applets][178][Configuration]
PreloadWeight=0

[Containments][174][Applets][179]
immutability=1
plugin=org.kde.plasma.devicenotifier

[Containments][174][Applets][179][Configuration]
PreloadWeight=16

[Containments][174][Applets][180]
immutability=1
plugin=org.kde.plasma.notifications

[Containments][174][Applets][180][Configuration]
PreloadWeight=80

[Containments][174][Applets][181]
immutability=1
plugin=org.kde.plasma.keyboardindicator

[Containments][174][Applets][181][Configuration]
PreloadWeight=0

[Containments][174][Applets][182]
immutability=1
plugin=org.kde.plasma.nightcolorcontrol

[Containments][174][Applets][182][Configuration]
PreloadWeight=0

[Containments][174][Applets][183]
immutability=1
plugin=org.kde.plasma.keyboardlayout

[Containments][174][Applets][183][Configuration]
PreloadWeight=0

[Containments][174][Applets][184]
immutability=1
plugin=org.kde.plasma.manage-inputmethod

[Containments][174][Applets][184][Configuration]
PreloadWeight=0

[Containments][174][Applets][187][Configuration]
PreloadWeight=42

[Containments][174][Applets][188][Configuration]
PreloadWeight=42

[Containments][174][Applets][198]
immutability=1
plugin=org.kde.plasma.mediacontroller

[Containments][174][Applets][198][Configuration]
PreloadWeight=0

[Containments][174][Applets][199]
immutability=1
plugin=org.kde.plasma.networkmanagement

[Containments][174][Applets][199][Configuration]
PreloadWeight=42

[Containments][174][ConfigDialog]
DialogHeight=808
DialogWidth=971

[Containments][174][Configuration]
PreloadWeight=0

[Containments][174][General]
extraItems=org.kde.plasma.pkupdates,org.kde.plasma.volume,org.kde.plasma.printmanager,org.kde.plasma.bluetooth,org.kde.plasma.clipboard,org.kde.plasma.devicenotifier,org.kde.plasma.mediacontroller,org.kde.plasma.notifications,org.kde.plasma.keyboardindicator,org.kde.plasma.nightcolorcontrol,org.kde.plasma.keyboardlayout,org.kde.plasma.manage-inputmethod,org.kde.plasma.networkmanagement
knownItems=org.kde.plasma.pkupdates,org.kde.plasma.volume,org.kde.plasma.networkmanagement,org.kde.plasma.printmanager,org.kde.plasma.bluetooth,org.kde.plasma.battery,org.kde.plasma.clipboard,org.kde.plasma.devicenotifier,org.kde.plasma.mediacontroller,org.kde.plasma.notifications,org.kde.plasma.keyboardindicator,org.kde.plasma.nightcolorcontrol,org.kde.plasma.keyboardlayout,org.kde.plasma.manage-inputmethod
shownItems=org.kde.plasma.volume,org.kde.plasma.clipboard

[Containments][23]
ItemGeometries-1680x1050=
ItemGeometries-2560x1440=Applet-193:2064,32,432,560,0;
ItemGeometriesHorizontal=Applet-193:2064,32,432,560,0;
activityId=8eb4ccb7-82f9-4e16-99b7-9ad4bdb45657
formfactor=0
immutability=1
lastScreen=0
location=0
plugin=org.kde.desktopcontainment
wallpaperplugin=org.kde.image

[Containments][23][Applets][193]
activityId=
formfactor=0
immutability=1
lastScreen=-1
location=0
plugin=org.kde.plasma.folder
wallpaperplugin=

[Containments][23][Applets][193][Configuration]
PreloadWeight=0
activityId=
formfactor=0
immutability=1
lastScreen=-1
location=0
plugin=org.kde.plasma.folder
wallpaperplugin=

[Containments][23][Applets][193][Configuration][ConfigDialog]
DialogHeight=540
DialogWidth=720

[Containments][23][Applets][193][Configuration][General]
iconSize=1
sortDirsFirst=false

[Containments][23][ConfigDialog]
DialogHeight=558
DialogWidth=720

[Containments][23][Configuration]
PreloadWeight=0

[Containments][23][General]
ToolBoxButtonState=topcenter
ToolBoxButtonX=879

[Containments][23][Wallpaper][org.kde.image][General]
Image=file:///home/laurie/background/dry aussie creek.jpg
SlidePaths=/usr/share/wallpapers

[Containments][23][Wallpaper][org.kde.slideshow][General]
Image=file:///home/laurie/wallpaper/Garden Path.jpg
SlideInterval=600
SlidePaths=/home/laurie/wallpaper

[Containments][44]
ItemGeometries-1680x1050=Applet-53:1168,0,416,384,0;
ItemGeometriesHorizontal=Applet-53:1168,0,416,384,0;
activityId=8eb4ccb7-82f9-4e16-99b7-9ad4bdb45657
formfactor=0
immutability=1
lastScreen=1
location=0
plugin=org.kde.desktopcontainment
wallpaperplugin=org.kde.slideshow

[Containments][44][ConfigDialog]
DialogHeight=814
DialogWidth=1005

[Containments][44][Configuration]
PreloadWeight=0

[Containments][44][General]
ToolBoxButtonState=topcenter
ToolBoxButtonX=456

[Containments][44][Wallpaper][org.kde.image][General]
Image=file:///usr/share/wallpapers/openSUSEdefault/contents/images/1920x1200.jpg
SlidePaths=/usr/share/wallpapers

[Containments][44][Wallpaper][org.kde.slideshow][General]
Image=file:///usr/share/wallpapers/laurie/grapevine.jpg
SlideInterval=300
SlidePaths=/usr/share/wallpapers/laurie

[Containments][55]
ItemGeometries-1680x1050=
ItemGeometriesHorizontal=
activityId=8eb4ccb7-82f9-4e16-99b7-9ad4bdb45657
formfactor=0
immutability=1
lastScreen=2
location=0
plugin=org.kde.desktopcontainment
wallpaperplugin=org.kde.slideshow

[Containments][55][ConfigDialog]
DialogHeight=558
DialogWidth=720

[Containments][55][Configuration]
PreloadWeight=0

[Containments][55][Wallpaper][org.kde.image][General]
Image=file:///usr/share/wallpapers/openSUSEdefault/contents/images/1920x1200.jpg
SlidePaths=/usr/share/wallpapers

[Containments][55][Wallpaper][org.kde.slideshow][General]
Image=file:///usr/share/wallpapers/laurie/Uluru,-NT.jpg
SlideInterval=600
SlidePaths=/usr/share/wallpapers/laurie

[Containments][57]
ItemGeometries-2560x1440=Applet-45:2064,16,464,576,0;
ItemGeometriesHorizontal=Applet-45:2064,16,464,576,0;
activityId=8eb4ccb7-82f9-4e16-99b7-9ad4bdb45657
formfactor=0
immutability=1
lastScreen=3
location=0
plugin=org.kde.desktopcontainment
wallpaperplugin=org.kde.image

[Containments][57][Applets][45][Configuration]
PreloadWeight=0
activityId=
formfactor=0
immutability=1
lastScreen=-1
location=0
plugin=org.kde.plasma.folder
wallpaperplugin=

[Containments][57][Applets][45][Configuration][ConfigDialog]
DialogHeight=647
DialogWidth=754

[Containments][57][Applets][45][Configuration][General]
iconSize=1
sortDirsFirst=false

[Containments][57][ConfigDialog]
DialogHeight=540
DialogWidth=720

[Containments][57][Configuration]
PreloadWeight=0

[Containments][57][General]
ToolBoxButtonState=topcenter
ToolBoxButtonX=896

[Containments][57][Wallpaper][org.kde.image][General]
Image=file:///home/laurie/background/dry aussie creek.jpg
SlidePaths=/usr/share/wallpapers

[ScreenMapping]
itemsOnDisabledScreens=
screenMapping=desktop:/trash.desktop,0,desktop:/Solar Array,3,desktop:/makemkv.desktop,3,desktop:/org.kde.falkon.desktop,3,desktop:/Net repeater,3,desktop:/Net Printer,3,desktop:/clipgrab.desktop,3,desktop:/Net Nas 2,3,desktop:/gimp.desktop,3,desktop:/Imagewriter.desktop,3,desktop:/audacity.desktop,3,desktop:/org.opensuse.YaST.desktop,3,desktop:/lshw.desktop,3,desktop:/org.kde.k3b.desktop,3,desktop:/xsane.desktop,3,desktop:/gpodder.desktop,3,desktop:/fr.handbrake.ghb.desktop,3,desktop:/thunderbird.desktop,3,desktop:/virtualbox.desktop,3,desktop:/filezilla.desktop,3,desktop:/Home.desktop,0,desktop:/org.kde.kcharselect.desktop,3,desktop:/startcenter.desktop,3,desktop:/org.kde.kinfocenter.desktop,3,desktop:/firefox.desktop,3,desktop:/vlc.desktop,3,desktop:/gramps.desktop,3,desktop:/Net Nas 1,3,desktop:/masterpdfeditor5.desktop,3,desktop:/Net modem,3
Comment 8 laurie jarden 2022-02-21 00:11:05 UTC
Hi Fushan Wen, I renamed the file as requested then logged out/logged in - locked screen/unlocked screen to log back in & plasma did not show crash handler.
Setup is now unsuitable for me in this configuration, also a pop-up message indicating virtual daemon not working and exiting may be a problem when drafting & 3d modelling are required - changing back to original config
Comment 9 Nate Graham 2022-02-23 20:15:17 UTC
*** Bug 450723 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2022-02-23 20:15:49 UTC
Very likely fixed with changed just committed for Plasma 5.24.3.
Comment 11 Nate Graham 2022-09-23 15:19:28 UTC

*** This bug has been marked as a duplicate of bug 449981 ***