Bug 450078 - Feature Request: New overview doesn't allow moving windows between screens
Summary: Feature Request: New overview doesn't allow moving windows between screens
Status: RESOLVED DUPLICATE of bug 448566
Alias: None
Product: kwin
Classification: Plasma
Component: effects-overview (show other bugs)
Version: 5.24.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-12 11:57 UTC by Firlaev-Hans
Modified: 2022-02-14 07:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Firlaev-Hans 2022-02-12 11:57:16 UTC
SUMMARY
I have two screens. In the overview effect, when I drag a window to a different monitor, it doesn't show up there at all and as soon as I let go of the mouse button it returns to where it was. In Parachute, it was possible to move windows to other screens directly, or even to other workspaces on those other screens.
Only tested on Wayland. Was going to include a screen capture but the overview doesn't show up on it, oddly enough.

STEPS TO REPRODUCE
1. Have at least two monitors, and open any window
2. Activate the new overview
3. Try to drag a window to a different monitor

OBSERVED RESULT
When dragging the window and moving the cursor to the other monitor, the window just disappears / isn't visible on the other monitor. When letting go, the window snaps back to the monitor it was previously on.

EXPECTED RESULT
The overview effect should allow dragging windows to other monitors.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.8-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Comment 1 galder 2022-02-12 17:21:37 UTC
tagging as feature request. I don't think drag-in applications between screens is supported at the moment.
Comment 2 Johannes 2022-02-13 12:39:10 UTC
This feature should be implemented indeed! The 'Desktop Grid' effect allows dragging windows between monitors, so I'm currently using that as a workaround. It would be nice though if the overview effect did it too.
Comment 3 Vlad Zahorodnii 2022-02-14 07:43:54 UTC

*** This bug has been marked as a duplicate of bug 448566 ***