Bug 450038 - No menubar at all in Wayland with GTK3 applications (neither global nor in app window)
Summary: No menubar at all in Wayland with GTK3 applications (neither global nor in ap...
Status: RESOLVED DUPLICATE of bug 424485
Alias: None
Product: plasmashell
Classification: Plasma
Component: Global Menu (show other bugs)
Version: 5.24.0
Platform: openSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-11 20:25 UTC by phrxmd
Modified: 2022-09-03 09:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of Inkscape, with no global menu, and no application menubar either (198.56 KB, image/png)
2022-02-11 20:25 UTC, phrxmd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description phrxmd 2022-02-11 20:25:06 UTC
Created attachment 146599 [details]
Screenshot of Inkscape, with no global menu, and no application menubar either

SUMMARY
I use the Global Menu applet and have appmenu-gtk2-module and appmenu-gtk3-module installed.
In Wayland, whenever I start a GTK3 application, it shows no menu at all: the menu does not get exported to the Global Menu, but the application window does not show a menu bar either - see attached screenshot.

I tested this with Inkscape, GLabels and Electron-based apps (signal-desktop in my case).

It looks as if the Global Menu does not detect the menu (bug 424485), but the application is expecting its menu to be drawn by somebody else anyway. 

It would be good if the apps could at least draw their own menu in their window. Currently for me the only workaround to access menu-based functionality is to launch the application in XWayland, with the associated problems regarding scaling etc.

STEPS TO REPRODUCE
1. With the global menu applet enabled, and appmenu-gtk-module installed, launch a GTK3 app (tested with Inkscape, GLabels and signal-desktop)

OBSERVED RESULT
The application's menu does not appear in the global menu, but the window contains no menu bar either. All menu functions are inaccessible. 

EXPECTED RESULT
The global menu should show the application's menu; or, barring that, at least the application's window should show a menu bar.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20220207
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.5-1-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620 

ADDITIONAL INFORMATION
Comment 1 David Edmundson 2022-02-14 23:24:39 UTC

*** This bug has been marked as a duplicate of bug 424485 ***
Comment 2 phrxmd 2022-08-26 10:43:10 UTC
(In reply to David Edmundson from comment #1)
> *** This bug has been marked as a duplicate of bug 424485 ***

Is this really the same bug?

Bug 424485 is about how GDBus-DBbusMenu-Proxy does not detect the menu exported by GTK3 apps, which is why the global menu shows nothing. 

This bug is about how in that case the app doesn't show an in-window local menu either.
Comment 3 phrxmd 2022-09-03 09:49:31 UTC
A somewhat crude workaround is to blacklist each app in the GTK appmenu plugin. 

E.g. to get a working menu back with Inkscape:
```
> gsettings get org.appmenu.gtk-module blacklist
['anjuta', 'freeciv', 'freeciv-gtk2', 'freeciv-gtk3', 'glade', 'gwyddion']
> gsettings set org.appmenu.gtk-module blacklist "['inkscape', 'anjuta', 'freeciv', 'freeciv-gtk2', 'freeciv-gtk3', 'glade', 'gwyddion']"
> gsettings get org.appmenu.gtk-module blacklist
['inkscape', 'anjuta', 'freeciv', 'freeciv-gtk2', 'freeciv-gtk3', 'glade', 'gwyddion'\]
```