Bug 449953 - Display configuaration crashes in KScreen::Config::clone() when configuring second monitor
Summary: Display configuaration crashes in KScreen::Config::clone() when configuring s...
Status: RESOLVED DUPLICATE of bug 447199
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_kscreen (show other bugs)
Version: 5.24.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kscreen-bugs-null@kde.org
URL:
Keywords: drkonqi, regression
Depends on:
Blocks:
 
Reported: 2022-02-10 17:04 UTC by stephen.wetzel
Modified: 2022-02-11 18:20 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stephen.wetzel 2022-02-10 17:04:53 UTC
Application: systemsettings (5.24.0)

Qt Version: 5.15.2
Frameworks Version: 5.90.0
Operating System: Linux 5.16.5-1-default x86_64
Windowing System: X11
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.24.0 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
Since upgrading to OpenSUSE Tumbleweed snapshot 20220207, I've had issues with my second monitor in KDE.  When I boot, it never detects the second monitor, and then when I open the display configuration it struggles to enable the other monitor.  The second monitor disapear and appears in the list rapidly.  This time when I enabled the second monitor the dialog crashed, and that's what this crash report is.

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Settings (systemsettings), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  QSharedPointer<KScreen::Screen>::data (this=<optimized out>) at /usr/include/qt5/QtCore/qsharedpointer_impl.h:301
#7  QSharedPointer<KScreen::Screen>::operator-> (this=<optimized out>) at /usr/include/qt5/QtCore/qsharedpointer_impl.h:307
#8  KScreen::Config::clone (this=0x0) at /usr/src/debug/libkscreen2-5.24.0-1.1.x86_64/src/config.cpp:205
#9  0x00007f35e56802af in ConfigHandler::updateInitialData (this=0x55c326273fb0) at /usr/src/debug/kscreen5-5.24.0-1.1.x86_64/kcm/config_handler.cpp:94
#10 0x00007f35e56803ef in operator() (__closure=0x55c3273d7d20) at /usr/src/debug/kscreen5-5.24.0-1.1.x86_64/kcm/kcm.cpp:173
#11 QtPrivate::FunctorCall<QtPrivate::IndexesList<>, QtPrivate::List<>, void, KCMKScreen::doSave(bool)::<lambda()> >::call (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:146
#12 QtPrivate::Functor<KCMKScreen::doSave(bool)::<lambda()>, 0>::call<QtPrivate::List<>, void> (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:256
#13 QtPrivate::QFunctorSlotObject<KCMKScreen::doSave(bool)::<lambda()>, 0, QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=0x55c3273d7d10, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:443
#14 0x00007f3660b83442 in QtPrivate::QSlotObjectBase::call (a=0x7ffc3bfa7b40, r=<optimized out>, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#15 QSingleShotTimer::timerEvent (this=0x55c326014730) at kernel/qtimer.cpp:320
#16 0x00007f3660b753bf in QObject::event (this=0x55c326014730, e=0x7ffc3bfa7cb0) at kernel/qobject.cpp:1336
#17 0x00007f36617fba7f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55c326014730, e=0x7ffc3bfa7cb0) at kernel/qapplication.cpp:3632
#18 0x00007f3660b48e2a in QCoreApplication::notifyInternal2 (receiver=0x55c326014730, event=0x7ffc3bfa7cb0) at kernel/qcoreapplication.cpp:1064
#19 0x00007f3660b9f70b in QTimerInfoList::activateTimers (this=0x55c3257fe2f0) at kernel/qtimerinfo_unix.cpp:643
#20 0x00007f3660b9ffdc in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:183
#21 idleTimerSourceDispatch (source=source@entry=0x55c3257f0080) at kernel/qeventdispatcher_glib.cpp:230
#22 0x00007f365e66ad5f in g_main_dispatch (context=0x7f3654005000) at ../glib/gmain.c:3381
#23 g_main_context_dispatch (context=0x7f3654005000) at ../glib/gmain.c:4099
#24 0x00007f365e66b0e8 in g_main_context_iterate (context=context@entry=0x7f3654005000, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#25 0x00007f365e66b19f in g_main_context_iteration (context=0x7f3654005000, may_block=1) at ../glib/gmain.c:4240
#26 0x00007f3660ba0364 in QEventDispatcherGlib::processEvents (this=0x55c3257fe340, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#27 0x00007f3660b4782b in QEventLoop::exec (this=this@entry=0x7ffc3bfa7ef0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#28 0x00007f3660b4fb00 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#29 0x00007f366109d25c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#30 0x00007f36617fb9f5 in QApplication::exec () at kernel/qapplication.cpp:2824
#31 0x000055c323d9feb0 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/systemsettings5-5.24.0-1.1.x86_64/app/main.cpp:183
[Inferior 1 (process 2241) detached]

The reporter indicates this bug may be a duplicate of or related to bug 449869.

Possible duplicates by query: bug 449931, bug 449869, bug 447199.

Reported using DrKonqi
Comment 1 stephen.wetzel 2022-02-10 17:13:00 UTC
I just confirmed rolling back to snapshot 20220205, which uses 5.23.5 fixes my issues.  Another piece of info that might be relevant is that I use a HDMI and a DP for my two monitors, and only the DP one was working properly in 5.24.0.
Comment 2 Nate Graham 2022-02-11 18:20:39 UTC

*** This bug has been marked as a duplicate of bug 447199 ***