Bug 449866 - Windows act like they could be dragged from one screen to another, but they actually won't
Summary: Windows act like they could be dragged from one screen to another, but they a...
Status: RESOLVED DUPLICATE of bug 448566
Alias: None
Product: kwin
Classification: Plasma
Component: effects-overview (show other bugs)
Version: 5.24.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-09 15:04 UTC by Vladimir Yerilov
Modified: 2022-02-09 15:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Yerilov 2022-02-09 15:04:59 UTC
SUMMARY
***
After invoking Overview, I can drag windows around even from one monitor to another. But in fact it does not happen.
***


STEPS TO REPRODUCE
1. Launch Plasma on a system with 2 or more monitors. Press Meta + W
2. Try to move window while in Overview from one screen to another
3. Release mouse button.

OBSERVED RESULT
Nothing happens, window moves back.

EXPECTED RESULT
I'd expect windows would be transferable from one screen to another.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
It should be either not allowed to drag windows on another screen while in Overview, or (better) implemented this way - that's cool.
Comment 1 Vlad Zahorodnii 2022-02-09 15:07:08 UTC

*** This bug has been marked as a duplicate of bug 448566 ***