Bug 449789 - Impossible to change the user avatar
Summary: Impossible to change the user avatar
Status: RESOLVED UPSTREAM
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_users (show other bugs)
Version: 5.24.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 449788 450938 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-02-08 14:49 UTC by Patrick Silva
Modified: 2022-03-02 12:45 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2022-02-08 14:49:47 UTC
STEPS TO REPRODUCE
1. open Users KCM
2. click on your current avatar
3. choose a different avatar from the gallery
4. click on 'Apply' button
5. type your password and click on 'OK' button

OBSERVED RESULT
the chosen avatar is not applied and Users KCM shows an inline error message saying 'There was an error while saving changes.'

EXPECTED RESULT
chosen avatar is applied without any error

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 1 Nate Graham 2022-02-08 17:22:32 UTC
Cannot reproduce on Fedora 35. Possible a regression in the new AccountsService version that Arch recently upgraded to?
Comment 2 Martin Riethmayer 2022-02-09 13:15:10 UTC
Can't reproduce 

KDE neon, fresh install, all up-to-date:
Plasma: 5.24
Frameworks: 5.90.0
QT: 5.15.3
Graphics Platform: X11 / Wayland (both tested)
Comment 3 Arsimael Inshan 2022-02-13 14:17:47 UTC
Can reproduce on 2 machines.

Arch Linux (Laptop and Desktop)
Plasma: 5.24
Frameworks: 5.90.0
QT: 5.15.2
Graphics Platform: X11 / Wayland (X11 on Desktop, Wayland on Laptop)

file:///usr/share/kpackage/kcms/kcm_users/contents/ui/UserDetailsPage.qml:242:9: QML SwipeView: Binding loop detected for property "implicitWidth"
file:///usr/lib/qt/qml/org/kde/kirigami.2/Avatar.qml:262:9: QML Image: Cannot open: file:///home/arsimael/.face
file:///usr/lib/qt/qml/org/kde/kirigami.2/Avatar.qml:262:9: QML Image: Cannot open: file:///home/arsimael/.face
file:///usr/lib/qt/qml/org/kde/kirigami.2/Avatar.qml:262:9: QML Image: Cannot open: file:///home/arsimael/.face
file:///usr/lib/qt/qml/org/kde/kirigami.2/templates/OverlaySheet.qml:387:13: QML QQuickItem*: Binding loop detected for property "width"
file:///usr/lib/qt/qml/org/kde/kirigami.2/templates/OverlaySheet.qml:387:13: QML QQuickItem*: Binding loop detected for property "width"
file:///usr/lib/qt/qml/org/kde/kirigami.2/templates/InlineMessage.qml:261:9: QML ActionToolBar: Binding loop detected for property "atBottom"
file:///usr/lib/qt/qml/org/kde/kirigami.2/templates/InlineMessage.qml:261:9: QML ActionToolBar: Binding loop detected for property "atBottom"
Both point size and pixel size set. Using pixel size.
[..]
Both point size and pixel size set. Using pixel size.
file:///usr/share/kpackage/genericqml/org.kde.systemsettings.sidebar/contents/ui/IntroIcon.qml:61:9: QML Label: Binding loop detected for property "verticalAlignment"
org.kde.kcm_users: "org.freedesktop.Accounts.Error.Failed" "file '/tmp/systemsettings.cQRual' is not a regular file"
file:///usr/lib/qt/qml/org/kde/kirigami.2/Avatar.qml:262:9: QML Image: Cannot open: file:///home/arsimael/.face
file:///usr/lib/qt/qml/org/kde/kirigami.2/templates/InlineMessage.qml:261:9: QML ActionToolBar: Binding loop detected for property "atBottom"
file:///usr/lib/qt/qml/org/kde/kirigami.2/templates/InlineMessage.qml:261:9: QML ActionToolBar: Binding loop detected for property "atBottom"
Comment 4 Antonio Rojas 2022-02-13 14:38:19 UTC
Not a KDE issue
https://gitlab.freedesktop.org/accountsservice/accountsservice/-/issues/98
Comment 5 Nate Graham 2022-02-15 16:07:08 UTC
*** Bug 449788 has been marked as a duplicate of this bug. ***
Comment 6 Nicolas Fella 2022-02-28 13:52:26 UTC
*** Bug 450938 has been marked as a duplicate of this bug. ***
Comment 7 medin 2022-03-02 12:45:51 UTC
Fixed on Manjaro with accountsservice v22.08.8