Bug 449770 - Mobile-specific Search UI does not go away when you leave Mobile mode
Summary: Mobile-specific Search UI does not go away when you leave Mobile mode
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: discover (show other bugs)
Version: unspecified
Platform: Neon Packages Linux
: HI normal
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-08 03:50 UTC by guimarcalsilva
Modified: 2022-05-15 22:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.6


Attachments
Two search fields (35.76 KB, image/png)
2022-02-08 03:50 UTC, guimarcalsilva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description guimarcalsilva 2022-02-08 03:50:31 UTC
Created attachment 146417 [details]
Two search fields

SUMMARY

It's possible to have two search fields when switching between mobile and desktop modes

STEPS TO REPRODUCE
1. Make the Discover window narrow to switch to mobile mode
2. Click on "Search" on the bottom bar
3. Maximize the window

OBSERVED RESULT

There are now two search fields. They are also misaligned in relation to one another.

EXPECTED RESULT

Maximizing the window should make the mobile search field disappear and also move the text that was written to it to the "normal" search field on the left.

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.3
Kernel Version: 5.13.0-28-generic (64-bit)
Graphics Platform: Wayland
Processors: 6 × Intel® Core™ i5-9400F CPU @ 2.90GHz
Memory: 7,6 GiB of RAM
Graphics Processor: Radeon RX 570 Series
Comment 1 Nate Graham 2022-02-08 17:31:30 UTC
Looks like the mobile-specific Search page does not go away when you leave Mobile mode, and it pollutes the toolbar forever.
Comment 2 Matej Starc 2022-05-07 11:11:15 UTC
Created an MR. I hope I find the right solution, and gets merged. 
https://invent.kde.org/plasma/discover/-/merge_requests/298
Comment 3 Nate Graham 2022-05-11 00:11:05 UTC
Thank you!
Comment 4 Matej Starc 2022-05-11 20:42:20 UTC
Git commit 3eb5730f5915fb91300e9a46345a1f8d229ad5e4 by Matej Starc.
Committed on 11/05/2022 at 14:07.
Pushed by ngraham into branch 'master'.

Hide the search field on the SearchPage on wide mode

This is a bugfix for mobile search field not disappearing after going back to widescreen mode.

M  +1    -0    discover/qml/SearchPage.qml

https://invent.kde.org/plasma/discover/commit/3eb5730f5915fb91300e9a46345a1f8d229ad5e4
Comment 5 Nate Graham 2022-05-11 20:43:20 UTC
Git commit 7226c29603f4cccf4d364f5e9472c3827a4440dd by Nate Graham, on behalf of Matej Starc.
Committed on 11/05/2022 at 20:43.
Pushed by ngraham into branch 'Plasma/5.24'.

Hide the search field on the SearchPage on wide mode

This is a bugfix for mobile search field not disappearing after going back to widescreen mode.


(cherry picked from commit 3eb5730f5915fb91300e9a46345a1f8d229ad5e4)

M  +1    -0    discover/qml/SearchPage.qml

https://invent.kde.org/plasma/discover/commit/7226c29603f4cccf4d364f5e9472c3827a4440dd
Comment 6 Matej Starc 2022-05-15 22:06:33 UTC
Git commit d87463a594fb5f00e92289b76e623808b804a5f2 by Matej Starc.
Committed on 15/05/2022 at 14:40.
Pushed by apol into branch 'master'.

unfocus text field on UI mode change

In last commit of fixing mobile search field, I didn't change focus on UI mode change.

M  +1    -1    discover/qml/SearchPage.qml

https://invent.kde.org/plasma/discover/commit/d87463a594fb5f00e92289b76e623808b804a5f2