Bug 449576 - Plasmashell crashes on startup
Summary: Plasmashell crashes on startup
Status: RESOLVED DUPLICATE of bug 449505
Alias: None
Product: plasmashell
Classification: Plasma
Component: generic-crash (show other bugs)
Version: 5.23.5
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-03 21:53 UTC by Lyubomir
Modified: 2022-02-03 23:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lyubomir 2022-02-03 21:53:40 UTC
SUMMARY
Plasmashell's clock freezes frequently so i kill plasmashell and start it again via either KRunner. This time however KRunner didn't show up on Alt + F2 so i opened the terminal Ctrl + Atl + T and run `plasmashell &`.
Plasmashell started and immediately crashed, and it started a constant loop of starting & crashing. I have something like 20 plasmashell crashes listed before i managed to logout via the terminal. Focus was lost constantly and typing into text fields was constantly interrupted. On top of this each time plasmashell started KRunner would appear and catch/capture the text that was being typed into some other app. Like it was trying to compensate for not starting during the time when plasmashell was killed by me. However i have not pressed Alt + F2 so many times as KRunner has appeared...


STEPS TO REPRODUCE
1. Send plasmashell a SIGTERM or SIGKILL
2. Open terminal
3. Run `plasmashell &`

OBSERVED RESULT
#0  0x00007f1ca9e01d22 in raise () from /usr/lib/libc.so.6
[Current thread is 1 (Thread 0x7f1ca56dba80 (LWP 239472))]
(gdb) bt
#0  0x00007f1ca9e01d22 in raise () at /usr/lib/libc.so.6
#1  0x00007f1cac107384 in KCrash::defaultCrashHandler(int) () at /usr/lib/libKF5Crash.so.5
#2  0x00007f1ca9e01da0 in <signal handler called> () at /usr/lib/libc.so.6
#3  0x00007f1cac356d81 in QOpenGLFunctions::glGetString(unsigned int) (name=7936, this=0x7ffc808feaa8)
    at /usr/include/qt/QtGui/qopenglfunctions.h:870
#4  KUserFeedback::OpenGLInfoSource::data() (this=<optimized out>) at /usr/src/debug/kuserfeedback-1.0.0/src/provider/core/openglinfosource.cpp:59
#5  0x00007f1cac358d63 in KUserFeedback::ProviderPrivate::jsonData(KUserFeedback::Provider::TelemetryMode) const
    (this=<optimized out>, mode=<optimized out>) at /usr/src/debug/kuserfeedback-1.0.0/src/provider/core/provider.cpp:232
#6  0x00007f1cac35dac3 in KUserFeedback::ProviderPrivate::submit(QUrl const&) (this=this@entry=0x560a34f08650, url=...)
    at /usr/src/debug/kuserfeedback-1.0.0/src/provider/core/provider.cpp:670
#7  0x00007f1cac35de1f in KUserFeedback::ProviderPrivate::submitProbeFinished(QNetworkReply*) (reply=0x560a354d1800, this=0x560a34f08650)
    at /usr/src/debug/kuserfeedback-1.0.0/src/provider/core/provider.cpp:701
#8  operator() (__closure=<optimized out>) at /usr/src/debug/kuserfeedback-1.0.0/src/provider/core/provider.cpp:679
#9  QtPrivate::FunctorCall<QtPrivate::IndexesList<>, QtPrivate::List<>, void, KUserFeedback::ProviderPrivate::submitProbe(const QUrl&)::<lambda()> >::call (arg=<optimized out>, f=<optimized out>) at /usr/include/qt/QtCore/qobjectdefs_impl.h:146
#10 QtPrivate::Functor<KUserFeedback::ProviderPrivate::submitProbe(const QUrl&)::<lambda()>, 0>::call<QtPrivate::List<>, void>
    (arg=<optimized out>, f=<optimized out>) at /usr/include/qt/QtCore/qobjectdefs_impl.h:256
#11 QtPrivate::QFunctorSlotObject<KUserFeedback::ProviderPrivate::submitProbe(const QUrl&)::<lambda()>, 0, QtPrivate::List<>, void>::impl
    (which=<optimized out>, r=<optimized out>, a=<optimized out>, ret=<optimized out>, this_=<optimized out>)
    at /usr/include/qt/QtCore/qobjectdefs_impl.h:443
#12 QtPrivate::QFunctorSlotObject<KUserFeedback::ProviderPrivate::submitProbe(const QUrl&)::<lambda()>, 0, QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *)
    (which=<optimized out>, this_=<optimized out>, r=<optimized out>, a=<optimized out>, ret=<optimized out>)
    at /usr/include/qt/QtCore/qobjectdefs_impl.h:436
#13 0x00007f1caa465d93 in QtPrivate::QSlotObjectBase::call(QObject*, void**)
    (a=0x7ffc808fee10, r=<optimized out>, this=0x560a357ab680, this=<optimized out>, r=<optimized out>, a=<optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#14 doActivate<false>(QObject*, int, void**) (sender=0x560a354d1800, signal_index=10, argv=0x7ffc808fee10) at kernel/qobject.cpp:3886
#15 0x00007f1ca9c94f88 in QNetworkReplyHttpImplPrivate::finished() (this=0x560a356da210) at access/qnetworkreplyhttpimpl.cpp:2280
#16 0x00007f1caa458e76 in QObject::event(QEvent*) (this=<optimized out>, e=0x7f1c5403d390) at kernel/qobject.cpp:1314
#17 0x00007f1cab0801a6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x560a354d1800, e=0x7f1c5403d390)
    at kernel/qapplication.cpp:3632
#18 0x00007f1caa43516a in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x560a354d1800, event=0x7f1c5403d390)
    at kernel/qcoreapplication.cpp:1064
--Type <RET> for more, q to quit, c to continue without paging--c
#19 0x00007f1caa435c69 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=0x0, event_type=0, data=0x560a34cd6670) at kernel/qcoreapplication.cpp:1821
#20 0x00007f1caa47c548 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x560a34cfe310) at kernel/qeventdispatcher_glib.cpp:277
#21 0x00007f1ca880cf13 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#22 0x00007f1ca88630d9 in  () at /usr/lib/libglib-2.0.so.0
#23 0x00007f1ca880a485 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#24 0x00007f1caa48044a in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x560a34cb1b20, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#25 0x00007f1caa42d44b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7ffc808ff330, flags=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#26 0x00007f1caa438b97 in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#27 0x0000560a32ea751a in  ()
#28 0x00007f1ca9decb25 in __libc_start_main () at /usr/lib/libc.so.6

EXPECTED RESULT
No crash

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.4-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 7,6 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Comment 1 David Edmundson 2022-02-03 23:00:54 UTC

*** This bug has been marked as a duplicate of bug 449505 ***