Bug 449502 - Discover crashes on startup
Summary: Discover crashes on startup
Status: RESOLVED DUPLICATE of bug 449505
Alias: None
Product: Discover
Classification: Applications
Component: fwupd Backend (show other bugs)
Version: 5.23.5
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Abhijeet Sharma
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-02 13:47 UTC by Bugs Bunny
Modified: 2022-02-02 23:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bugs Bunny 2022-02-02 13:47:47 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. start the application

OBSERVED RESULT
it crashes

EXPECTED RESULT
a normal start

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.23.5
(available in About System)
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION

****output on start of app***
Icon theme "gnome" not found.
Icon theme "ubuntu-mono-dark" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.
Icon theme "gnome" not found.

** (process:1882): WARNING **: 14:21:25.238: Not changing AppStream cache location: No longer supported.
QDir::mkpath: Empty or null file name
adding empty sources model QStandardItemModel(0x55b48fd66d30)
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
org.kde.plasma.libdiscover: Couldn't find a category for  "fwupd-backend"
file:///usr/lib/qt/qml/org/kde/kirigami.2/private/PrivateActionToolButton.qml:74:5: QML Binding: Binding loop detected for property "value"

(process:1882): Fwupd-CRITICAL **: 14:21:25.749: fwupd_client_download_bytes_async: assertion 'url != NULL' failed
kf.newstuff.core: "Error transferring https://distribute.kde.org/khotnewstuff/fonts-providers.xml - server replied: Not Found"
KNS error in "Fonts" : KNSCore::ProviderError "Loading of providers from file: https://distribute.kde.org/khotnewstuff/fonts-providers.xml failed" QVariant(QString, "https://distribute.kde.org/khotnewstuff/fonts-providers.xml")
invalid kns backend! "/usr/share/knsrcfiles/kfontinst.knsrc" because: "Invalid Fonts backend, contact your distributor."
org.kde.plasma.libdiscover: Discarding invalid backend "kfontinst.knsrc"
kns error "/usr/share/knsrcfiles/kfontinst.knsrc" "Invalid Fonts backend, contact your distributor."
org.kde.plasma.libdiscover: Couldn't find a category for  "fwupd-backend"
QOpenGLFunctions created with non-current context
29 -- exe=/usr/bin/plasma-discover
17 -- platform=wayland
24 -- appname=plasma-discover
17 -- apppath=/usr/bin
10 -- signal=11
9 -- pid=1882
18 -- appversion=5.23.5
21 -- programname=Discover
63 -- bugaddress=https://bugs.kde.org/enter_bug.cgi?product=Discover
30 -- productname=discover/discover
12 -- startupid=0
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = plasma-discover path = /usr/bin pid = 1882
KCrash: Arguments: /usr/bin/plasma-discover 
The Wayland connection experienced a fatal error: Bad file descriptor
kf.kio.slaves.file: readData() returned -1

**** GDB ****
(gdb) run
Starting program: /usr/bin/plasma-discover 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7ffff04dd640 (LWP 3310)]
[New Thread 0x7fffefcdc640 (LWP 3311)]
[New Thread 0x7fffef4db640 (LWP 3312)]
Icon theme "gnome" not found.
Icon theme "ubuntu-mono-dark" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.
Icon theme "gnome" not found.
[New Thread 0x7fffecea5640 (LWP 3314)]
[New Thread 0x7fffdffff640 (LWP 3315)]

** (process:3306): WARNING **: 14:41:20.231: Not changing AppStream cache location: No longer supported.
QDir::mkpath: Empty or null file name
[New Thread 0x7fffde5ab640 (LWP 3316)]
[New Thread 0x7fffddcfc640 (LWP 3317)]
[New Thread 0x7fffdd4fb640 (LWP 3318)]
[New Thread 0x7fffdccac640 (LWP 3319)]
[Detaching after vfork from child process 3320]
[Detaching after vfork from child process 3322]
[New Thread 0x7fffd1ffe640 (LWP 3324)]
adding empty sources model QStandardItemModel(0x555555cd86c0)
[New Thread 0x7fffd17fd640 (LWP 3325)]
[New Thread 0x7fffc9ffc640 (LWP 3326)]
[New Thread 0x7fffc97fb640 (LWP 3327)]
[New Thread 0x7fffc8ffa640 (LWP 3328)]
[New Thread 0x7fffc193d640 (LWP 3329)]
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
kf.newstuff.core: The CustomName property is deprecated and will be removed in KF6
[New Thread 0x7fffc113c640 (LWP 3330)]
[Detaching after fork from child process 3331]
org.kde.plasma.libdiscover: Couldn't find a category for  "fwupd-backend"
file:///usr/lib/qt/qml/org/kde/kirigami.2/private/PrivateActionToolButton.qml:74:5: QML Binding: Binding loop detected for property "value"
[Detaching after fork from child process 3335]
[New Thread 0x7fffcbfff640 (LWP 3337)]
[New Thread 0x7fffcab99640 (LWP 3338)]

(process:3306): Fwupd-CRITICAL **: 14:41:21.026: fwupd_client_download_bytes_async: assertion 'url != NULL' failed
[New Thread 0x7fffc3fff640 (LWP 3340)]
[Detaching after vfork from child process 3341]
[New Thread 0x7fffc37fe640 (LWP 3343)]
[Thread 0x7fffc37fe640 (LWP 3343) exited]
[Detaching after fork from child process 3344]
QOpenGLFunctions created with non-current context

Thread 1 "plasma-discover" received signal SIGSEGV, Segmentation fault.
0x00007fffdec5c278 in KUserFeedback::OpenGLInfoSource::data() () from /usr/lib/libKUserFeedbackCore.so.1
(gdb) backtrace
#0  0x00007fffdec5c278 in KUserFeedback::OpenGLInfoSource::data() () at /usr/lib/libKUserFeedbackCore.so.1
#1  0x00007fffdec6bea6 in  () at /usr/lib/libKUserFeedbackCore.so.1
#2  0x00007fffdec6dc92 in  () at /usr/lib/libKUserFeedbackCore.so.1
#3  0x00007fffdec6ded7 in  () at /usr/lib/libKUserFeedbackCore.so.1
#4  0x00007ffff6223d93 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007ffff59f0f88 in  () at /usr/lib/libQt5Network.so.5
#6  0x00007ffff6216e76 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#7  0x00007ffff72631a6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#8  0x00007ffff61f316a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#9  0x00007ffff61f3c69 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#10 0x00007ffff623a548 in  () at /usr/lib/libQt5Core.so.5
#11 0x00007ffff4a8ff13 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#12 0x00007ffff4ae60d9 in  () at /usr/lib/libglib-2.0.so.0
#13 0x00007ffff4a8d485 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#14 0x00007ffff623e44a in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#15 0x00007ffff61eb44b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#16 0x00007ffff61f6b97 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#17 0x0000555555568950 in  ()
Comment 1 Aleix Pol 2022-02-02 19:48:50 UTC

*** This bug has been marked as a duplicate of bug 449505 ***
Comment 2 Aleix Pol 2022-02-02 23:51:59 UTC
*** Bug 438348 has been marked as a duplicate of this bug. ***