Bug 449481 - Battery icon has smaller size than keyboard icons on the other side of a footer
Summary: Battery icon has smaller size than keyboard icons on the other side of a footer
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Theme - Breeze (show other bugs)
Version: 5.24.0
Platform: Other Linux
: NOR minor
Target Milestone: 1.0
Assignee: visual-design
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-01 23:39 UTC by ratijas
Modified: 2022-05-18 00:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ratijas 2022-02-01 23:39:19 UTC
SUMMARY

As noted in this[1] thread, the battery icon is only 10-11px vs whooping 15-16px height keyboard toolbar buttons' icons on the left. There is something wrong about this Battery.qml component: it has a `property int fontSize` but it is a Row -- not a Control, so when not binding the font externally explicitly, it is using the default value of `PlasmaCore.Theme.defaultFont.pointSize`. Other than that, it doesn't seem like a good idea to bind icon's height to the text Label's height: Label is a Control potentially with a padding and whatnot. Looks like ToolBar button calculates its icon size in a different way.

[1]: https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1422#note_390119

STEPS TO REPRODUCE
1. Have a battery (power supply) installed
2. Lock the screen or log out to SDDM with breeze theme

OBSERVED RESULT

Battery icon is small.

EXPECTED RESULT

Battery and Keyboard icons should have the same size.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.16.2-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 970M/PCIe/SSE2
Comment 1 Nate Graham 2022-02-03 18:55:59 UTC
Yeah we should use a standard icon size here, rather than matching a font pixel size.
Comment 2 Nate Graham 2022-05-18 00:23:41 UTC
Git commit 6a71c119ef5153631d60b4b276b2a8efbfb68f17 by Nate Graham, on behalf of ivan tkachenko.
Committed on 18/05/2022 at 00:23.
Pushed by ngraham into branch 'master'.

lookandfeel: fix battery icon on lock/login screens being too small

Now it does not attempt to fix into the height of a line.
FIXED-IN: 5.25

M  +6    -3    lookandfeel/contents/components/Battery.qml

https://invent.kde.org/plasma/plasma-workspace/commit/6a71c119ef5153631d60b4b276b2a8efbfb68f17