Bug 449431 - PlasmaUserFeedback crashes/freezes whole desktop
Summary: PlasmaUserFeedback crashes/freezes whole desktop
Status: RESOLVED DUPLICATE of bug 449505
Alias: None
Product: plasmashell
Classification: Plasma
Component: generic-crash (show other bugs)
Version: 5.23.5
Platform: Archlinux Linux
: NOR crash
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-31 20:20 UTC by wokim
Modified: 2022-02-04 14:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wokim 2022-01-31 20:20:17 UTC
SUMMARY
When I started my PC today, I was greeted by an empty wallpaper (and then later only a black screen) after KDE started. No panels loaded and right-clicking the desktop didn't do anything. I could open a terminal with alt+space (krunner) and I executed plasmashell, but it crashed every time.
So then I moved my .config folder to .config.bak, after which KDE started fine. I kept moving files around until I finally found the culprit: .config/PlasmaUserFeedback. After deleting that file but keeping all other files, KDE started and worked without issue.
I also made a new test user, created a home directory for the test user, and put PlasmaUserFeedback in /home/test/.config/. And this produced the same crash/freeze as well.

STEPS TO REPRODUCE
1. Have .config/PlasmaUserFeedback with content "[Global]\nFeedbackLevel=64"
2. Execute startplasma-wayland
3. Notice how plasmashell can't load and that it crashes if you try to start it manually

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.4-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 6 × AMD Phenom(tm) II X6 1090T Processor
Memory: 15.6 GiB of RAM
Graphics Processor: AMD Radeon RX 470 Graphics
Comment 1 Philipp A. 2022-02-01 10:40:43 UTC
Same for me
Comment 2 Philipp A. 2022-02-01 11:01:11 UTC
There’s also more things to fix debugging here. (I’m on Arch Linux in a Wayland session too)

1. Dr. Konqui doesn’t come up for me at all on Arch Linux. IDK if this has to do with the newly introduced support for debugging symbols or is an attribute of this specific bug.
2. There‘s an extremely annoying interaction between KRunner, Plasma, and window focus here. I constantly lost focus trying to type in a terminal, and had to kill Plasma using the kill cursor from Ctrl+Alt+Esc before being able to do anything.
Comment 3 Nate Graham 2022-02-01 23:29:27 UTC
Cannot reproduce with that setting. Can you attach a backtrace of the crash? If DrKonqi isn't helpful, you can use `coredumpctl`. See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports#Retrieving_a_backtrace_using_coredumpctl
Comment 4 Philipp A. 2022-02-04 11:49:43 UTC
Probably not a useful one, Arch doesn’t have debug symbols for KUserFeedback yet (The Plasma 5.24 release next week will have them) Anyway:

                #0  0x00007f2b2c34cd22 raise (libc.so.6 + 0x3cd22)
                #1  0x00007f2b2e652384 _ZN6KCrash19defaultCrashHandlerEi (libKF5Crash.so.5 + 0x7384)
                #2  0x00007f2b2c34cda0 __restore_rt (libc.so.6 + 0x3cda0)
                #3  0x00007f2b2e8a9278 _ZN13KUserFeedback16OpenGLInfoSource4dataEv (libKUserFeedbackCore.so.1 + 0x21278)
                #4  0x00007f2b2e8b8ea6 n/a (libKUserFeedbackCore.so.1 + 0x30ea6)
                #5  0x00007f2b2e8bac92 n/a (libKUserFeedbackCore.so.1 + 0x32c92)
                #6  0x00007f2b2e8baed7 n/a (libKUserFeedbackCore.so.1 + 0x32ed7)
                #7  0x00007f2b2c9b0d93 n/a (libQt5Core.so.5 + 0x2bcd93)
                #8  0x00007f2b2c1dff88 n/a (libQt5Network.so.5 + 0xa2f88)
                #9  0x00007f2b2c9a3e76 _ZN7QObject5eventEP6QEvent (libQt5Core.so.5 + 0x2afe76)
                #10 0x00007f2b2d5cb1a6 _ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent (libQt5Widgets.so.5 + 0x1791a6)
                #11 0x00007f2b2c98016a _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5 + 0x28c16a)
                #12 0x00007f2b2c980c69 _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5 + 0x28cc69)
                #13 0x00007f2b2c9c7548 n/a (libQt5Core.so.5 + 0x2d3548)
                #14 0x00007f2b2ad5bf13 g_main_context_dispatch (libglib-2.0.so.0 + 0x54f13)
                #15 0x00007f2b2adb20d9 n/a (libglib-2.0.so.0 + 0xab0d9)
                #16 0x00007f2b2ad59485 g_main_context_iteration (libglib-2.0.so.0 + 0x52485)
                #17 0x00007f2b2c9cb44a _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2d744a)
                #18 0x00007f2b2c97844b _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x28444b)
                #19 0x00007f2b2c983b97 _ZN16QCoreApplication4execEv (libQt5Core.so.5 + 0x28fb97)
                #20 0x000055a7f482f51a n/a (plasmashell + 0x2051a)
                #21 0x00007f2b2c337b25 __libc_start_main (libc.so.6 + 0x27b25)
                #22 0x000055a7f482f8de n/a (plasmashell + 0x208de)
Comment 5 Nate Graham 2022-02-04 14:41:53 UTC

*** This bug has been marked as a duplicate of bug 449505 ***