Bug 449384 - Desktop has no widgets, black wallpaper, no context menu
Summary: Desktop has no widgets, black wallpaper, no context menu
Status: RESOLVED DUPLICATE of bug 449505
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.23.5
Platform: Archlinux Linux
: NOR major
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-30 19:04 UTC by Loïc Droz
Modified: 2022-02-03 00:39 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
journalctl output grepped with 'plasma' keyword (92.84 KB, text/plain)
2022-01-30 19:04 UTC, Loïc Droz
Details
Complete stack strace (not grepped with 'plasma' keyword) (91.21 KB, text/x-log)
2022-02-01 20:15 UTC, Loïc Droz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Loïc Droz 2022-01-30 19:04:44 UTC
Created attachment 146081 [details]
journalctl output grepped with 'plasma' keyword

SUMMARY
When I log into my Plasma session, there is no wallpaper (black background), widgets are frozen, and no context menu appears when right-clicking on the background. After a little while, the frozen widgets disappear. Everything else seems to work fine (krunner, desktop effects, apps, notifications, etc.)

STEPS TO REPRODUCE
1. Log into Plasma Wayland session.
2. Observe the bugs immediately.

OBSERVED RESULT

No wallpaper, frozen widget at session startup, no context menu on desktop background.
After a while, the frozen widgets disappear.

EXPECTED RESULT

The wallpaper appears, the widgets work, a context menu appears when right-clicking the desktop background, widgets do not disappear after a while

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: EndeavourOS (Arch Linux) / KDE Plasma 5.23.5
KDE Plasma Version: KDE Plasma 5.23.5
KDE Frameworks Version: 5.90.0-1
Qt Version: 5.15.2+kde+r296-1

ADDITIONAL INFORMATION
I have attached the output of the command `sudo journalctl -b | grep --line-buffered plasma`. You will see core dumps by the process plasmashell. I suspect this is linked to this issue.

I have tried on the Wayland session, but not the X11 session, as logging into it after modifying things from the Wayland tends to fuck up all the widget arrangement, multi-screen arrangement etc.

I am using two screens. Unplugging one does not solve the problem.
Comment 1 Christophe KINNE 2022-01-31 12:38:13 UTC
I have the same problem on Neon stable, all packages up to date
Comment 2 Christophe KINNE 2022-02-01 02:06:53 UTC
I have the following segfaults returned by dmesg :

[20582.527806] klauncher[65260]: segfault at 28 ip 00007ff7ec3030b8 sp 00007ffe4bff39a0 error 4 in libQt5WaylandClient.so.5.15.3[7ff7ec2eb000+c4000]
[20582.527815] Code: 00 00 00 e8 8a c9 fe ff 0f b6 43 34 48 8d 6b 34 84 c0 75 66 48 8b 73 28 48 8b 7b 20 48 85 f6 74 21 e8 4c de fe ff 85 c0 74 21 <48> 8b 73 28 48 8b 7b 20 48 85 f6 75 bb e8 c6 f3 fe ff eb b9 0f 1f
[20582.759896] kded5[65282]: segfault at 28 ip 00007f62a57e10b8 sp 00007ffc804e0c50 error 4 in libQt5WaylandClient.so.5.15.3[7f62a57c9000+c4000]
[20582.759906] Code: 00 00 00 e8 8a c9 fe ff 0f b6 43 34 48 8d 6b 34 84 c0 75 66 48 8b 73 28 48 8b 7b 20 48 85 f6 74 21 e8 4c de fe ff 85 c0 74 21 <48> 8b 73 28 48 8b 7b 20 48 85 f6 75 bb e8 c6 f3 fe ff eb b9 0f 1f
[29779.293685] audit: type=1400 audit(1643583601.866:33): apparmor="DENIED" operation="capable" profile="/usr/sbin/cups-browsed" 
[127054.903376] klauncher[412382]: segfault at 28 ip 00007fec9e1940b8 sp 00007ffe72892990 error 4 in libQt5WaylandClient.so.5.15.3[7fec9e17c000+c4000]
[127054.903391] Code: 00 00 00 e8 8a c9 fe ff 0f b6 43 34 48 8d 6b 34 84 c0 75 66 48 8b 73 28 48 8b 7b 20 48 85 f6 74 21 e8 4c de fe ff 85 c0 74 21 <48> 8b 73 28 48 8b 7b 20 48 85 f6 75 bb e8 c6 f3 fe ff eb b9 0f 1f
[127055.141818] kded5[412400]: segfault at 28 ip 00007fb1bafd30b8 sp 00007ffc7d5ba990 error 4 in libQt5WaylandClient.so.5.15.3[7fb1bafbb000+c4000]
[127055.141827] Code: 00 00 00 e8 8a c9 fe ff 0f b6 43 34 48 8d 6b 34 84 c0 75 66 48 8b 73 28 48 8b 7b 20 48 85 f6 74 21 e8 4c de fe ff 85 c0 74 21 <48> 8b 73 28 48 8b 7b 20 48 85 f6 75 bb e8 c6 f3 fe ff eb b9 0f 1f
Comment 3 Loïc Droz 2022-02-01 09:42:26 UTC
Here is my segfault in dmesg:

[   19.698772] plasmashell[2174]: segfault at d0 ip 00007fa94b4a1278 sp 00007ffe72af0940 error 4 in libKUserFeedbackCore.so.1.0.0[7fa94b491000+43000]
[   19.698781] Code: 00 48 8d b4 24 90 00 00 00 4c 89 ef ff 15 70 05 04 00 48 8d 7c 24 38 4c 89 ee ff 15 32 05 04 00 48 8b 44 24 38 bf 00 1f 00 00 <ff> 90 d0 00 00 00 ba ff ff ff ff 49 89 c4 48 85 c0 74 0b 48 89 c7
Comment 4 Loïc Droz 2022-02-01 20:14:20 UTC
UPDATE: I have found a workaround that works for me. I had the user feedback level turned up to max (5/5) turning it down to 3/5 or simply disabling it completely fixes the bug. Re-enabling it to 4/5 or 5/5 makes the bug reappear.

I found this by taking a closer look at the complete stack trace (not the grepped one I attached). It goes through libKUserFeedbackCore.so.1
I will add a new attachment with the complete stack trace.
Comment 5 Loïc Droz 2022-02-01 20:15:10 UTC
Created attachment 146152 [details]
Complete stack strace (not grepped with 'plasma' keyword)
Comment 6 Nate Graham 2022-02-01 23:11:11 UTC
1. Does this issue affect both monitors, or only one?
2. If KRunner works (with Alt+Space), can you type `plasmashell` into it to make thing work again?
3. Did you log into a Wayland session after logging out of an X11 session?
Comment 7 Loïc Droz 2022-02-02 07:21:15 UTC
(In reply to Nate Graham from comment #6)
> 1. Does this issue affect both monitors, or only one?
> 2. If KRunner works (with Alt+Space), can you type `plasmashell` into it to
> make thing work again?
> 3. Did you log into a Wayland session after logging out of an X11 session?

1. Both
2. I haven't tried with KRunner (KRunner works though), but I've launched plasmashell from the terminal with `kstart5 plasmashell`, it crashed again after a short time.
3. No
Comment 8 Christophe KINNE 2022-02-02 13:40:01 UTC
(In reply to Nate Graham from comment #6)
> 1. Does this issue affect both monitors, or only one?
> 2. If KRunner works (with Alt+Space), can you type `plasmashell` into it to
> make thing work again?
> 3. Did you log into a Wayland session after logging out of an X11 session?

On my side I dont have any extended log feature enabled as far as I know.

1. Both monitors.
2. Krunner doesn't work.
3. No.
Comment 9 Loïc Droz 2022-02-02 16:36:02 UTC
UPDATE: Upgrading package kuserfeedback from 1.0.0-1 to 1.0.0-2 appears to have fixed the bug for me.
Comment 10 Nate Graham 2022-02-02 20:30:32 UTC

*** This bug has been marked as a duplicate of bug 438348 ***
Comment 11 Loïc Droz 2022-02-02 21:09:07 UTC
(In reply to Nate Graham from comment #10)
> 
> *** This bug has been marked as a duplicate of bug 438348 ***

Sorry I forgot to mention, but I'm running an AMD GPU with open-source drivers. Therefore I am not sure if this bug really is a duplicate of the above bug. Or the above bug report should be modified to omit "With proprietary Nvidia drivers".
Comment 12 Nate Graham 2022-02-02 23:04:02 UTC
The issue is probably compounded by https://bugzilla.kernel.org/show_bug.cgi?id=206387, which we will have to work around.
Comment 13 Nate Graham 2022-02-03 00:39:20 UTC

*** This bug has been marked as a duplicate of bug 449505 ***