Bug 449318 - (SEGV) Systemsettings crashed in KScreen::Config::clone on Wayland when closing configuration window
Summary: (SEGV) Systemsettings crashed in KScreen::Config::clone on Wayland when closi...
Status: RESOLVED DUPLICATE of bug 447199
Alias: None
Product: KScreen
Classification: Unclassified
Component: common (show other bugs)
Version: 5.23.90
Platform: Neon Packages Linux
: NOR crash
Target Milestone: ---
Assignee: kscreen-bugs-null@kde.org
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2022-01-29 14:06 UTC by postix
Modified: 2022-02-15 21:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Stacktrace from Dr. Konqui (28.60 KB, text/vnd.kde.kcrash-report)
2022-01-29 14:06 UTC, postix
Details
KWin Support Information (5.06 KB, text/plain)
2022-01-29 14:06 UTC, postix
Details
Stacktrace: openSUSE TW Plasma 5.24.0 (63.26 KB, text/plain)
2022-02-15 21:08 UTC, postix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2022-01-29 14:06:21 UTC
Created attachment 146040 [details]
Stacktrace from Dr. Konqui

STEPS TO REPRODUCE
1. Open KScreen
2. Opened the combobox with the resolution once, but did not change anything
3. Closed the window

OBSERVED RESULT

```
#4  QSharedPointer<KScreen::Screen>::operator-> (this=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qsharedpointer_impl.h:307
#5  KScreen::Config::clone (this=0x0) at ./src/config.cpp:205
#6  0x00007f91e5c8dbbc in ConfigHandler::revertConfig (this=0x5564bd618290) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qsharedpointer_impl.h:307
#7  KCMKScreen::revertSettings (this=0x5564bde42010) at ./kcm/kcm.cpp:93
#8  0x00007f91e5c7dddc in KCMKScreen::qt_static_metacall (_o=_o@entry=0x5564bde42010, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=22, _a=_a@entry=0x7fffd82f6710) at ./obj-x86_64-linux-gnu/kcm/kcm_kscreen_autogen/EWIEGA46WW/moc_kcm.cpp:231
#9  0x00007f91e5c7eb63 in KCMKScreen::qt_metacall (this=0x5564bde42010, _c=QMetaObject::InvokeMetaMethod, _id=22, _a=0x7fffd82f6710) at ./obj-x86_64-linux-gnu/kcm/kcm_kscreen_autogen/EWIEGA46WW/moc_kcm.cpp:435
#10 0x00007f925948ebe5 in QQmlObjectOrGadget::metacall (this=this@entry=0x7fffd82f6a00, type=type@entry=QMetaObject::InvokeMetaMethod, index=<optimized out>, index@entry=55, argv=argv@entry=0x7fffd82f6710) at ../../include/QtQml/5.15.3/QtQml/private/../../../../../src/qml/qml/ftw/qflagpointer_p.h:351
#11 0x00007f9259357b24 in CallMethod (object=..., index=55, returnType=returnType@entry=43, argCount=argCount@entry=0, argTypes=argTypes@entry=0x0, engine=engine@entry=0x5564bde50840, callArgs=0x7f91d9fc25a0, callType=QMetaObject::InvokeMetaMethod) at jsruntime/qv4qobjectwrapper.cpp:1319
#12 0x00007f9259359794 in CallPrecise (object=..., data=..., engine=engine@entry=0x5564bde50840, callArgs=callArgs@entry=0x7f91d9fc25a0, callType=callType@entry=QMetaObject::InvokeMetaMethod) at ../../include/QtQml/5.15.3/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:285
#13 0x00007f925935a74a in QV4::QObjectMethod::callInternal (this=<optimized out>, thisObject=<optimized out>, argv=<optimized out>, argc=0) at jsruntime/qv4qobjectwrapper.cpp:2131
#14 0x00007f925937a1d1 in QV4::FunctionObject::call (argc=<optimized out>, argv=<optimized out>, thisObject=<optimized out>, this=<optimized out>) at ../../include/QtQml/5.15.3/QtQml/private/../../../../../src/qml/jsruntime/qv4functionobject_p.h:172
#15 QV4::Moth::VME::interpret (frame=0x7fffd82f6cf0, engine=0x5564bde50840, code=0x7f91d9fc2550 "\240\340\243\331\221\177") at jsruntime/qv4vme_moth.cpp:754
#16 0x00007f925937c10f in QV4::Moth::VME::exec (frame=frame@entry=0x7fffd82f6cf0, engine=engine@entry=0x5564bde50840) at jsruntime/qv4vme_moth.cpp:463
#17 0x00007f92593092ed in QV4::Function::call (this=this@entry=0x5564bde7b500, thisObject=<optimized out>, argv=argv@entry=0x7f91d9fc2508, argc=<optimized out>, context=<optimized out>) at jsruntime/qv4function.cpp:69
#18 0x00007f92594aefa7 in QQmlJavaScriptExpression::evaluate (this=this@entry=0x5564bdfccac0, callData=callData@entry=0x7f91d9fc24d8, isUndefined=isUndefined@entry=0x0) at ../../include/QtQml/5.15.3/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:343
#19 0x00007f92594528ae in QQmlBoundSignalExpression::evaluate (this=<optimized out>, a=<optimized out>) at ../../include/QtQml/5.15.3/QtQml/private/../../../../../src/qml/jsruntime/qv4jscall_p.h:95
#20 0x00007f9259453948 in QQmlBoundSignal_callback (e=0x5564bdfcbfc0, a=0x7fffd82f8a00) at ../../include/QtQml/5.15.3/QtQml/private/../../../../../src/qml/qml/qqmlboundsignalexpressionpointer_p.h:69
#21 0x00007f925948e64d in QQmlNotifier::emitNotify (endpoint=<optimized out>, a=a@entry=0x7fffd82f8a00) at qml/qqmlnotifier.cpp:104
#22 0x00007f9259430fbf in QQmlData::signalEmitted (object=0x5564bdfccca0, index=11, a=0x7fffd82f8a00) at qml/qqmlengine.cpp:834
#23 0x00007f925aac3d25 in doActivate<false> (sender=0x5564bdfccca0, signal_index=11, argv=0x7fffd82f8a00) at kernel/qobject_p.h:110
#24 0x00007f925aabd567 in QMetaObject::activate (sender=sender@entry=0x5564bdfccca0, m=m@entry=0x7f9255077280 <QQuickAction::staticMetaObject>, local_signal_index=local_signal_index@entry=8, argv=argv@entry=0x7fffd82f8a00) at kernel/qobject.cpp:3946
#25 0x00007f9254f8bd76 in QQuickAction::triggered (this=this@entry=0x5564bdfccca0, _t1=<optimized out>, _t1@entry=0x5564bdfccca0) at .moc/moc_qquickaction_p.cpp:363
#26 0x00007f9254f8ca86 in QQuickActionPrivate::trigger (this=0x5564bdfccd50, source=0x5564bdfccca0, doToggle=<optimized out>) at qquickaction.cpp:558
#27 0x00007f9254f8cb42 in QQuickAction::trigger (this=<optimized out>, source=<optimized out>) at qquickaction.cpp:539
#28 0x00007f9254f8d075 in QQuickActionPrivate::handleShortcutEvent (this=0x5564bdfccd50, object=0x5564bdfccca0, event=0x7fffd82f8d70) at qquickaction.cpp:305
#29 0x00007f925b6a5dc3 in QApplicationPrivate::notify_helper (this=this@entry=0x5564bd0f7920, receiver=receiver@entry=0x5564bdfccca0, e=e@entry=0x7fffd82f8d70) at kernel/qapplication.cpp:3632
#30 0x00007f925b6aebb8 in QApplication::notify (this=0x7fffd82f9300, receiver=0x5564bdfccca0, e=0x7fffd82f8d70) at kernel/qapplication.cpp:3156
#31 0x00007f925aa8d17a in QCoreApplication::notifyInternal2 (receiver=0x5564bdfccca0, event=0x7fffd82f8d70) at ../../include/QtCore/5.15.3/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:332
#32 0x00007f925afdce43 in QShortcutMap::dispatchEvent (this=this@entry=0x5564bd0f79e8, e=e@entry=0x7fffd82f8e30) at kernel/qshortcutmap.cpp:675
#33 0x00007f925afdd7e3 in QShortcutMap::tryShortcut (this=this@entry=0x5564bd0f79e8, e=e@entry=0x7fffd82f8e30) at kernel/qshortcutmap.cpp:343
#34 0x00007f925af8ac72 in QWindowSystemInterface::handleShortcutEvent (window=<optimized out>, window@entry=0x5564bd439ab0, timestamp=2184059, keyCode=16777216, modifiers=..., nativeScanCode=9, nativeVirtualKey=65307, nativeModifiers=0, text=..., autorepeat=false, count=1) at kernel/qwindowsysteminterface.cpp:477
#35 0x00007f925afaa871 in QGuiApplicationPrivate::processKeyEvent (e=e@entry=0x5564c1939ea0) at kernel/qguiapplication.cpp:2395
#36 0x00007f925afafb2b in QGuiApplicationPrivate::processWindowSystemEvent (e=0x5564c1939ea0) at kernel/qguiapplication.cpp:2008
#37 0x00007f925af877ac in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:1169
#38 0x00007f92580b4d24 in userEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib/x86_64-linux-gnu/libQt5WaylandClient.so.5
#39 0x00007f925856117d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f9258561400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f92585614a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f925aae79d2 in QEventDispatcherGlib::processEvents (this=0x5564bd118c80, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#43 0x00007f925aa8bc7b in QEventLoop::exec (this=this@entry=0x7fffd82f91e0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#44 0x00007f925aa93e24 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#45 0x00005564bc478ef9 in main (argc=<optimized out>, argv=<optimized out>) at ./app/main.cpp:183
```


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE Neon Testing
KDE Plasma Version: 5.23.90
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Virtualbox VM
Comment 1 postix 2022-01-29 14:06:32 UTC
Created attachment 146041 [details]
KWin Support Information
Comment 2 postix 2022-02-15 21:08:12 UTC
Created attachment 146793 [details]
Stacktrace: openSUSE TW Plasma 5.24.0

Another crash, this time on openSUSE TW with Plasma 5.24.0 on Wayland, when de-attaching an HDMI monitor.
Comment 3 postix 2022-02-15 21:09:42 UTC

*** This bug has been marked as a duplicate of bug 447199 ***