Bug 449292 - Plasma does not correct start-up after upgrade to 5.23.5
Summary: Plasma does not correct start-up after upgrade to 5.23.5
Status: RESOLVED DUPLICATE of bug 353975
Alias: None
Product: plasmashell
Classification: Plasma
Component: generic-multiscreen (show other bugs)
Version: 5.23.5
Platform: Manjaro Linux
: NOR major
Target Milestone: 1.0
Assignee: Aleix Pol
Depends on:
Reported: 2022-01-28 14:27 UTC by hasezoey
Modified: 2022-01-30 12:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description hasezoey 2022-01-28 14:27:07 UTC
After upgrading to 5.23.5, plasma does not correctly start-up, symptoms:
- login overlay times-out (the one showing "manjaro" plus a loading screen)
- after the login overlay is gone, dekstop backgrounds are black (unset) and the taskbar is not there
- workaround to start plasma with "kstart5 plasmashell" does not work anymore in 5.23.5 (but did in 5.23.4)

i dont know how to actually reproduce this. this just keeps happening to me
1. upgrade from 5.23.4 to 5.23.5
2. reboot
3. login
4. see that the taskbar is on the wrong screen
5. use workaround of: logout
6. log back in (worked in 5.23.4)
7. observe the "login overlay" timing-out and plasma desktop not starting up

Plasma does not correctly start-up after logging in

Plasma to start-up normally with everything working

Linux/KDE Plasma: 5.23.5 (from 5.23.4)
(available in About System)
Operating System: Manjaro Linux
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.2-1-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-7700K CPU @ 4.20GHz
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX Vega

shortcuts / hotkey still work (like META+E to open dolphin, ALT+F2 to open krunner, CTRL+ALT+DEL to open logout options), windows also still work

also, this happened in 5.23.4 (and 5.23.x in general), but way less often and the workaround of "kstart5 plasmashell" just worked

Note: i currently dont have logs, because i dont know which to provide, and "journalctl -b" does not list anything other than what it did in 5.23.4 (no errors, warnings, only display output)

PS: i dont know if i have set the correct component
Comment 1 hasezoey 2022-01-28 14:35:50 UTC
i forgot to add:
since upgrading to 5.23.5, some windows like VSCode (AUR) start-up on the left-most display, always, but in 5.23.4, it started where it last closed, which is in middle of the 3 displays
Comment 2 Nate Graham 2022-01-28 19:56:46 UTC
> Graphics Processor: AMD Radeon RX Vega

Very likely hitting https://bugzilla.kernel.org/show_bug.cgi?id=206387.

*** This bug has been marked as a duplicate of bug 353975 ***
Comment 3 hasezoey 2022-01-29 05:50:27 UTC
> Very likely hitting https://bugzilla.kernel.org/show_bug.cgi?id=206387.

i dont think that i am hitting *that* issue, because the display configuration is still there and mostly all windows start where they should (expected the mentioned ones like VSCode since 5.23.5)

so the blackscreen and missing wallpaper is only that plasmashell (or whatever) does not correctly start-up

also from what i can tell, my configuration of displays is correctly picked-up (kde is loading the display configuration correctly, but is missing the setting for "Primary Display", which should come with 5.24)

here is my configuration:
- Graphics card: AMD Vega 64, 2 HDMI ports, 2 Display Ports, 1 DVI (i think)
- Display on the most left: HDMI connected Samsung 1080p monitor
- Display in the middle: Displayport connected HP Omen 1440p monitor
- Display on the most right: Displayport connected DELL 1080p monitor

the only place where the displays are not correctly set-up is in SDDM, because i dont know where to change that (but that does not matter)

> *** This bug has been marked as a duplicate of bug 353975 ***

i also dont quite think this issue is exactly my issue, because yes it happened in 5.23.x before, but since 5.23.5 it happens *consistently*, i can reproduce it at each reboot since 5.23.5

my reproduction steps on 5.23.5:
- boot-up
- login for the first time on boot
- logout (like i mentioned, because of the issue of the taskbar being on the wrong display, 5.24 should fix this with "Primary Display" like on X11)
- log back in and the issue is there now
- logging back out and back in again also bring up the issue, also rebooting again and doing the same steps it always happens in 5.23.5

from what i can tell, in 5.23.5, it so always chooses the left-most screen for the task-bar on first login (unlike in 5.23.4 and 5.23.x, where it only ~30% of the time chose the left most screen instead off the middle screen)

also, like i mentioned, the workaround of using "kstart5 plasmashell" to resolve the issue of plasmashell (again, i dont know if this is the right component) starting up, in 5.23.x it always worked and started-up back right away after executing the command, but in 5.23.5 it somehow does not and also requires a extra argument to be added

PS: because of this issue, 5.23.5 is not really usable for me and have to stay reverted to 5.23.4 for now
Comment 4 hasezoey 2022-01-30 12:52:30 UTC
Update for my case today:

i booted up to the 5.23.5 install, and somehow it works today without issue
what i did since upgrading:
- upgrade from 5.23.4 (only time, just included for timeline) (on btrfs, root (not a snapshot) read-write, home (not a snapshot) read-write)
- rebooted
- noticed that it does not start-up correctly
- rebooted and re-tried again (for 2 more times)
- gave up and reverted to a snapshot before the upgrade (btrfs, snapshot for root was read-only, home (not a snapshot) was mounted read-write)
- booted the mentioned snapshot for at least 2 times
- tried latest install again, and everything works fine (btrfs, read-write root (not a snapshot) and read-write home (not a snapshot))

so i dont know what was the problem or how it happened, but it seems fixed for now (i mean the issue that it is reliably not starting, the occasional non-start comes still)