Bug 449084 - Issue with idling on lock-screen when auto-sleep mode is disabled on wayland KDE. Freeze on return
Summary: Issue with idling on lock-screen when auto-sleep mode is disabled on wayland ...
Status: RESOLVED DUPLICATE of bug 442846
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.23.5
Platform: Archlinux Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-24 17:03 UTC by Isaac Milarsky
Modified: 2022-04-19 13:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
imilarsky: Wayland+


Attachments
GDB traceback as asked for (3.08 KB, text/plain)
2022-01-26 15:06 UTC, Isaac Milarsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Isaac Milarsky 2022-01-24 17:03:22 UTC
SUMMARY
There is a minor issue with KDE where when auto-sleep mode is disabled and the computer is left idling. The screen auto locks as intended but if left alone will freeze upon unlocking the session and a couple seconds of mouse movement. When the session freezes all input is ignored including the standard Ctrl+Alt+F5 to try to get to a login shell. Sometimes it breaks out of the freeze on its own but other times the only cure is to hard restart the computer. I have found turning auto-sleep mode back on avoids this issue thankfully. 

STEPS TO REPRODUCE
1. Start a wayland KDE session from sddm
2. Set the power save mode to only lock the screen upon idle instead of going to sleep mode
3. Wait until the screen locks itself from idling or a little longer
4. Unlock the screen and attempt to use the computer

OBSERVED RESULT
Screen is frozen and all inputs are ignored. Either it unfreezes on its own or a hard reboot is needed. If it decides to unfreeze the results of the previously ignored inputs are then shown. Audio seems to work when it is frozen as it still plays youtube videos in the background when it is frozen like this.

EXPECTED RESULT
Successful unlocking of the KDE session followed by standard use of the desktop environment.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.2-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Comment 1 Vlad Zahorodnii 2022-01-25 07:42:24 UTC
Can you get the backtrace of kwin when the screen is frozen? You would need to ssh from another computer and attach a debugger to kwin_wayland process, e.g. "gdb -p `pidof kwin_wayland`" then type "bt" in gdb
Comment 2 Vlad Zahorodnii 2022-01-25 07:43:04 UTC
"sudo gdb -p `pidof kwin_wayland`"
Comment 3 Isaac Milarsky 2022-01-26 15:06:11 UTC
Created attachment 145958 [details]
GDB traceback as asked for

Here is the traceback for kwin when it freezes
Comment 4 Isaac Milarsky 2022-01-26 15:06:48 UTC
(In reply to Vlad Zahorodnii from comment #1)
> Can you get the backtrace of kwin when the screen is frozen? You would need
> to ssh from another computer and attach a debugger to kwin_wayland process,
> e.g. "gdb -p `pidof kwin_wayland`" then type "bt" in gdb

Just lmk if I should provide anything else
Comment 5 Vlad Zahorodnii 2022-01-26 15:07:32 UTC
Thanks!

*** This bug has been marked as a duplicate of bug 442846 ***
Comment 6 Andrejs Kuidins 2022-02-04 10:14:53 UTC
Identical bug here:

Operating System: Kubuntu 21.10
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.13.0-28-generic (64-bit)
Graphics Platform: X11
Comment 7 Marco Martin 2022-04-19 13:51:40 UTC
#0  0x00007fd9f47a5b2f in poll () at /usr/lib/libc.so.6
#1  0x00007fd9f585863b in  () at /usr/lib/libxcb.so.1
#2  0x00007fd9f585a08f in  () at /usr/lib/libxcb.so.1
#3  0x00007fd9f585a1a2 in xcb_wait_for_reply () at /usr/lib/libxcb.so.1
#4  0x00007fd9f66ca48a in KWin::Workspace::updateXStackingOrder() () at /usr/lib/libkwin.so.5
#5  0x00007fd9f66ca569 in KWin::Workspace::xStackingOrder() const () at /usr/lib/libkwin.so.5
#6  0x00007fd9f665a443 in KWin::Compositor::windowsToRender() const () at /usr/lib/libkwin.so.5
#7  0x00007fd9f665a8c9 in KWin::Compositor::composite(KWin::RenderLoop*) () at /usr/lib/libkwin.so.5
#8  0x00007fd9f4f83da3 in  () at /usr/lib/libQt5Core.so.5
#9  0x00007fd9f6615437 in KWin::RenderLoop::frameRequested(KWin::RenderLoop*) () at /usr/lib/libkwin.so.5
#10 0x00007fd9f66ec248 in KWin::RenderLoopPrivate::dispatch() () at /usr/lib/libkwin.so.5
#11 0x00007fd9f4f83da3 in  () at /usr/lib/libQt5Core.so.5
#12 0x00007fd9f4f8610f in QTimer::timeout(QTimer::QPrivateSignal) () at /usr/lib/libQt5Core.so.5
#13 0x00007fd9f4f76e16 in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#14 0x00007fd9f5b6f1a6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#15 0x00007fd9f4f5317a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#16 0x00007fd9f4f9dcb5 in QTimerInfoList::activateTimers() () at /usr/lib/libQt5Core.so.5
#17 0x00007fd9f4f9e152 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#18 0x0000555ae452a932 in  ()
#19 0x00007fd9f4f4b45b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#20 0x00007fd9f4f56ba7 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#21 0x0000555ae44cb9c6 in  ()
#22 0x00007fd9f46d9b25 in __libc_start_main () at /usr/lib/libc.so.6