Bug 448917 - NVIDIA/Wayland - Breeze Theme Has No Blur And Random Shapes Appear
Summary: NVIDIA/Wayland - Breeze Theme Has No Blur And Random Shapes Appear
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: wayland-generic (show other bugs)
Version: 5.23.90
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 448931 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-21 18:39 UTC by pengnu
Modified: 2022-05-09 15:52 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments
plasmashell output (16.82 KB, text/plain)
2022-01-21 18:39 UTC, pengnu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pengnu 2022-01-21 18:39:54 UTC
Created attachment 145726 [details]
plasmashell output

SUMMARY
Breeze Light/Dark theme has no blur, panel widgets don't behave properly on opening and closing. After a while, random shapes appear like flickering. 

STEPS TO REPRODUCE
1. Login to a Plasma Wayland session with NVIDIA GPU.
2. Look at the panel. Breeze theme is problematic. 
3. Install another theme. For example when i switch to Layan theme and then log out and log in again there is blur in the panel and everything works correctly. 

OBSERVED RESULT
Breeze theme is not presented correctly. 

EXPECTED RESULT
Breeze theme is presented correctly. There is blur and the transition effects are smooth. Random shapes like flickering do not appear. 

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.23.90
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
NVIDIA GTX 960 4GB - Proprietary Driver 510.39.01
Comment 1 pengnu 2022-01-21 19:00:37 UTC
Showcase with 5.23.90 : https://imgur.com/a/AHNYfpX
Comment 2 pengnu 2022-01-21 19:23:24 UTC
(In reply to pengnu from comment #1)
> Showcase with 5.23.90 : https://imgur.com/a/AHNYfpX

Another showcase with 5.23.2 : https://imgur.com/a/WA9qLFz
Comment 3 Nate Graham 2022-01-23 19:19:23 UTC
Sounds like graphical glitches at a level below Plasma. Moving to KWin.
Comment 4 Nate Graham 2022-01-23 19:22:16 UTC
*** Bug 448931 has been marked as a duplicate of this bug. ***
Comment 5 Alessandro Astone 2022-01-23 19:37:28 UTC
I just want to add that:
* Some other "Plasma Style" themes work correctly, even with translucency/blur.
* Translucent/blurred "Window Decorations" are properly rendered.

With the EGLStreams backend instead of gbm, the effect was the exact opposite. Plasmashell would be correctly rendered, while qt apps wouldn't.
Comment 6 Vlad Zahorodnii 2022-01-24 10:22:16 UTC
It looks like a driver issue, the contents of buffers become invalid after closing a window. Can you report this issue to nvidia developers please?
Comment 7 Erik Kurzinger 2022-05-08 19:34:03 UTC
This should be fixed by https://invent.kde.org/plasma/kwin/-/merge_requests/2358
Comment 8 Nate Graham 2022-05-09 15:52:33 UTC
That was merged, marking as RESOLVED FIXED. Thanks Erik!