Bug 448797 - Inappropriate "Low battery level" icon when only batteries come from external wireless devices
Summary: Inappropriate "Low battery level" icon when only batteries come from external...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Battery Monitor (show other bugs)
Version: master
Platform: Compiled Sources Linux
: NOR minor
Target Milestone: 1.0
Assignee: ratijas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-19 21:43 UTC by Viorel-Cătălin Răpițeanu
Modified: 2022-01-31 15:59 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments
The Power Management indicator (268.39 KB, image/png)
2022-01-19 21:44 UTC, Viorel-Cătălin Răpițeanu
Details
Expanded Power Management applet (233.41 KB, image/png)
2022-01-19 21:45 UTC, Viorel-Cătălin Răpițeanu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Viorel-Cătălin Răpițeanu 2022-01-19 21:43:18 UTC
SUMMARY
***
When you have a wireless mouse connected, but no other method of changing the monitor brightness, the 'low battery' icon is shown for the Power Management applet.
***


STEPS TO REPRODUCE
1. Connect a wireless mouse to a desktop PC.

OBSERVED RESULT
The Power Management applet correctly identifies the wireless mouse, but the icon displayed for this applet is the 'low battery' one. The current battery charge is not taken into any consideration.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Plasma master
KDE Plasma Version: 5.23.90 master
KDE Frameworks Version: 5.91 master
Qt Version: 5.15.2
Comment 1 Viorel-Cătălin Răpițeanu 2022-01-19 21:44:42 UTC
Created attachment 145652 [details]
The Power Management indicator

It contains a single wireless device (see the other battery-indicator-with-battery attachment)
Comment 2 Viorel-Cătălin Răpițeanu 2022-01-19 21:45:12 UTC
Created attachment 145653 [details]
Expanded Power Management applet

A single device is available.
Comment 3 Nate Graham 2022-01-31 15:56:26 UTC
Git commit 7a40d72fcf0110c18053fb6872471ac5e801c0da by Nate Graham, on behalf of Aleix Pol Gonzalez.
Committed on 31/01/2022 at 15:56.
Pushed by ngraham into branch 'master'.

applets/batterymonitor: Use the same property to define hasBatteries

Otherwise it looks weird when it gets out of sync because Has
Cumulative.
FIXED-IN: 5.24

M  +1    -1    applets/batterymonitor/package/contents/ui/CompactRepresentation.qml
M  +1    -0    applets/batterymonitor/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-workspace/commit/7a40d72fcf0110c18053fb6872471ac5e801c0da