Bug 448640 - App search in kickoff menu shows no results; works in KRunner
Summary: App search in kickoff menu shows no results; works in KRunner
Status: RESOLVED DUPLICATE of bug 443131
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.23.4
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
: 448639 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-17 03:12 UTC by Ashley
Modified: 2022-01-25 17:06 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Successful Search for discord in krunner. (411.54 KB, image/png)
2022-01-17 03:15 UTC, Ashley
Details
Failed Search for discord in kickoff menu. (697.65 KB, image/png)
2022-01-17 03:20 UTC, Ashley
Details
Successful Search for dolphin in krunner. (440.94 KB, image/png)
2022-01-17 03:22 UTC, Ashley
Details
Failed Search for dolphin in kickoff menu. (771.40 KB, image/png)
2022-01-17 03:25 UTC, Ashley
Details
Menu otherwise working fine (527.45 KB, image/png)
2022-01-17 03:26 UTC, Ashley
Details
aste the output of `grep -A 50 > org.kde.plasma.kickoff ~/.config/plasma-org.kde.plasma.desktop-appletsrc (3.87 KB, text/plain)
2022-01-23 00:41 UTC, Ashley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ashley 2022-01-17 03:12:21 UTC
SUMMARY

App search in kickoff menu shows no results.
krunner search does still show expect results.
Kickoff menu works normally outside of failed searches.


SOFTWARE/OS VERSIONS

Operating System: Fedora Linux 35
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.14-200.fc35.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-4210U CPU @ 1.70GHz
Memory: 7.7 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 4400

ADDITIONAL INFORMATION
below are screenshots of two separate searches done in both krunner search and kickoff search, and a screenshot of menu working properly otherwise.
Comment 1 Ashley 2022-01-17 03:15:50 UTC
Created attachment 145569 [details]
Successful Search for discord in krunner.
Comment 2 Ashley 2022-01-17 03:20:37 UTC
Created attachment 145570 [details]
Failed Search for discord in kickoff menu.
Comment 3 Ashley 2022-01-17 03:22:31 UTC
Created attachment 145571 [details]
Successful Search for dolphin in krunner.
Comment 4 Ashley 2022-01-17 03:25:29 UTC
Created attachment 145572 [details]
Failed Search for dolphin in kickoff menu.
Comment 5 Ashley 2022-01-17 03:26:04 UTC
Created attachment 145573 [details]
Menu otherwise working fine
Comment 6 popov895 2022-01-17 09:07:32 UTC
*** Bug 448639 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Lohnau 2022-01-20 14:21:49 UTC
Are there any error messages when you run plasmashell?
Comment 8 Nate Graham 2022-01-20 23:17:52 UTC
Cannot reproduce. Can you paste the output of `grep -A 50 org.kde.plasma.kickoff ~/.config/plasma-org.kde.plasma.desktop-appletsrc` from a terminal window?
Comment 9 Ashley 2022-01-23 00:41:22 UTC
Created attachment 145782 [details]
aste the output of `grep -A 50 > org.kde.plasma.kickoff ~/.config/plasma-org.kde.plasma.desktop-appletsrc

(In reply to Nate Graham from comment #8)
> Cannot reproduce. Can you paste the output of `grep -A 50
> org.kde.plasma.kickoff ~/.config/plasma-org.kde.plasma.desktop-appletsrc`
> from a terminal window?

Hey Nate,
I attached the output of the command you requested. Let me know if you need anything else thanks!
Comment 10 Nate Graham 2022-01-24 16:52:26 UTC
Hmm, I was looking for a hardcoded list of runners in that file, but I don't see it. No idea what the issue is then, sorry. :(
Comment 11 Alexander Lohnau 2022-01-24 17:08:42 UTC
Does the issue persist when you restart plasmashell?

>kquitapp5 plasmashell; plasmashell


It might be worth trying to launch the applet standalone (to get more useful logs) 
>QT_LOGGING_RULES="kf.runner=true" plasmoidviewer -a org.kde.plasma.kickoff
Comment 12 Ashley 2022-01-24 21:51:41 UTC
(In reply to Nate Graham from comment #10)
> Hmm, I was looking for a hardcoded list of runners in that file, but I don't
> see it. No idea what the issue is then, sorry. :(

How to reproduce:

I had the default panel on 2 monitors. when I removed the kickoff menu from the second panel, The first kickoff menu started preforming normally.

I added the menu back to the panel on the 2nd monitor and the bug came back. 

I removed the menu on the 2nd screen once more and kickoff is working as it should again.
Comment 13 Nate Graham 2022-01-25 17:06:21 UTC
Ohh! The fact that you have multiple monitors is relevant. That makes this a duplicate of Bug 443131, which is already fixed in Plasma 5.23.5

*** This bug has been marked as a duplicate of bug 443131 ***