Bug 448619 - Kickoff shows double entry "Get $application" when searching for uninstalled app if there is more than one source
Summary: Kickoff shows double entry "Get $application" when searching for uninstalled ...
Status: RESOLVED FIXED
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: 5.23.5
Platform: Other Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Alexander Lohnau
URL:
Keywords:
: 448661 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-16 20:01 UTC by postix
Modified: 2022-02-10 19:15 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.1


Attachments
Screenshot (55.85 KB, image/png)
2022-01-16 20:01 UTC, postix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2022-01-16 20:01:28 UTC
Created attachment 145557 [details]
Screenshot

SUMMARY

If you search in Kickoff for an app, which isn't installed currently, Kickoff will search the databases to check whether the app can be installed from any source.
For each source it will show an individual entry "Get $application ..." without any additional information.

If you click on any of the entries, depending on your system, Discover will open, where you can choose the installation source (repo, flatpak, etc.) again.

Therefore it would be convenient to either display the source right away in the Kickoff search OR to hide the duplicates.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20220114
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Comment 1 Patrick Silva 2022-01-17 19:29:18 UTC
*** Bug 448661 has been marked as a duplicate of this bug. ***
Comment 2 Alexander Lohnau 2022-01-20 13:32:14 UTC
This should be solvable by manually de-duplicating the entries or utilizing the KRunner de-duplication logic I have added a while back.
Comment 3 Nate Graham 2022-01-20 23:12:27 UTC
Seems like an issue with the AppStream runner.

Cannot reproduce with current git master, FWIW.
Comment 4 Alexander Lohnau 2022-01-21 11:32:29 UTC
This is still an issue, it might depend on the appstream data that the distros provide.
Comment 5 Bug Janitor Service 2022-02-05 15:45:01 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1439
Comment 6 Nate Graham 2022-02-10 19:14:09 UTC
Git commit d2f948ec20b3ed03a60f95ee2bcd5228c3593cef by Nate Graham, on behalf of Alexander Lohnau.
Committed on 10/02/2022 at 19:14.
Pushed by ngraham into branch 'master'.

appstream runner: De-duplicate results from multiple sources
FIXED-IN: 5.24.1

M  +7    -0    runners/appstream/appstreamrunner.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/d2f948ec20b3ed03a60f95ee2bcd5228c3593cef
Comment 7 Nate Graham 2022-02-10 19:15:53 UTC
Git commit a9926cae23244c97c5066cf37372c7420b285099 by Nate Graham, on behalf of Alexander Lohnau.
Committed on 10/02/2022 at 19:15.
Pushed by ngraham into branch 'Plasma/5.24'.

appstream runner: De-duplicate results from multiple sources
FIXED-IN: 5.24.1


(cherry picked from commit d2f948ec20b3ed03a60f95ee2bcd5228c3593cef)

M  +7    -0    runners/appstream/appstreamrunner.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/a9926cae23244c97c5066cf37372c7420b285099