Bug 448608 - Dolphin crash when trying to create a file on SFTP server that times out
Summary: Dolphin crash when trying to create a file on SFTP server that times out
Status: RESOLVED DUPLICATE of bug 433347
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
Keywords: drkonqi
Depends on:
Reported: 2022-01-16 16:53 UTC by Oded Arbel
Modified: 2022-01-17 12:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Oded Arbel 2022-01-16 16:53:27 UTC
Application: dolphin (22.03.70)

Qt Version: 5.15.3
Frameworks Version: 5.91.0
Operating System: Linux 5.13.0-25-generic x86_64
Windowing System: X11
Distribution: Ubuntu 21.10
DrKonqi: 5.24.80 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
Tried to create a file on a remote file server using the SFTP protocol. At the time the server was under highload and was refusing SSH access. After restarting Dolphin, it could not connect to the remote file system and shows "Timeout connecting to <server>" messages. A new SSH session could also not be started at the same time (SSH client showed "Connection timed out during banner exchange") though an existing SSH connection did continue to work though very very slowly.

I tried to create an HTML file using Dolphin's RMB menu - "Create File" -> "HTML File" and after I reconnected to the server I can see that the file did indeed get created successfully and looks to be complete but had the file name "index.html.part" instead of the intended "index.html".

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f82301168b1 in QLineEdit::text (this=0x558f26b22d50) at widgets/qlineedit.cpp:312
#5  0x00007f82315ebccc in KNewFileMenuPrivate::_k_slotStatResult (this=0x558f25f848c0, job=0x558f26b427f0) at ./src/filewidgets/knewfilemenu.cpp:1233
#6  0x00007f822f52400e in QtPrivate::QSlotObjectBase::call (a=0x7ffea431ed60, r=0x558f26005e70, this=0x558f26beeea0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#7  doActivate<false> (sender=0x558f26b427f0, signal_index=6, argv=0x7ffea431ed60) at kernel/qobject.cpp:3886
#8  0x00007f8230757980 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#9  0x00007f8230758dfb in KJob::finishJob(bool) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#10 0x00007f823109ec08 in KIO::SimpleJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#11 0x00007f82310a463e in KIO::StatJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#12 0x00007f823109ce90 in KIO::SimpleJob::slotError(int, QString const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#13 0x00007f822f52400e in QtPrivate::QSlotObjectBase::call (a=0x7ffea431f000, r=0x558f26b427f0, this=0x558f26005ee0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#14 doActivate<false> (sender=0x558f26972c50, signal_index=5, argv=0x7ffea431f000) at kernel/qobject.cpp:3886
#15 0x00007f823106a35a in KIO::SlaveInterface::error(int, QString const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#16 0x00007f823106ce76 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#17 0x00007f823106ab1f in KIO::SlaveInterface::dispatch() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#18 0x00007f8231073812 in KIO::Slave::gotInput() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#19 0x00007f822f52400e in QtPrivate::QSlotObjectBase::call (a=0x7ffea431f250, r=0x558f26972c50, this=0x558f26c9f9a0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#20 doActivate<false> (sender=0x558f26275910, signal_index=3, argv=0x7ffea431f250) at kernel/qobject.cpp:3886
#21 0x00007f822f51ab89 in QObject::event (this=0x558f26275910, e=0x558f26920f00) at kernel/qobject.cpp:1314
#22 0x00007f822ffc9dc3 in QApplicationPrivate::notify_helper (this=this@entry=0x558f25989850, receiver=receiver@entry=0x558f26275910, e=e@entry=0x558f26920f00) at kernel/qapplication.cpp:3632
#23 0x00007f822ffd2bb8 in QApplication::notify (this=0x7ffea431f8f0, receiver=0x558f26275910, e=0x558f26920f00) at kernel/qapplication.cpp:3156
#24 0x00007f822f4ecfea in QCoreApplication::notifyInternal2 (receiver=0x558f26275910, event=0x558f26920f00) at kernel/qcoreapplication.cpp:1064
#25 0x00007f822f4ef8f1 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x558f25963ec0) at kernel/qcoreapplication.cpp:1821
#26 0x00007f822f5481e7 in postEventSourceDispatch (s=0x558f25abdb70) at kernel/qeventdispatcher_glib.cpp:277
#27 0x00007f822d0788bb in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f822d0cbf08 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f822d076003 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f822f547842 in QEventDispatcherGlib::processEvents (this=0x558f25ac4150, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#31 0x00007f822f4ebaeb in QEventLoop::exec (this=this@entry=0x7ffea431f800, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#32 0x00007f822f4f3c94 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#33 0x0000558f25467353 in ?? ()
#34 0x00007f822ee24fd0 in __libc_start_call_main (main=main@entry=0x558f25466200, argc=argc@entry=3, argv=argv@entry=0x7ffea431fac8) at ../sysdeps/nptl/libc_start_call_main.h:58
#35 0x00007f822ee2507d in __libc_start_main_impl (main=0x558f25466200, argc=3, argv=0x7ffea431fac8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffea431fab8) at ../csu/libc-start.c:409
#36 0x0000558f2546771e in ?? ()
[Inferior 1 (process 419300) detached]

Possible duplicates by query: bug 448534, bug 448047, bug 447907, bug 447799, bug 447746.

Reported using DrKonqi
Comment 1 Nicolas Fella 2022-01-17 12:38:41 UTC

*** This bug has been marked as a duplicate of bug 433347 ***