Bug 448437 - "MM" initials overflowing in "Change Avatar" view
Summary: "MM" initials overflowing in "Change Avatar" view
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_users (show other bugs)
Version: 5.23.5
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-14 04:01 UTC by Michael Alexsander
Modified: 2022-01-14 20:59 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments
Bug in action. (4.00 KB, image/png)
2022-01-14 04:01 UTC, Michael Alexsander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Alexsander 2022-01-14 04:01:17 UTC
Created attachment 145443 [details]
Bug in action.

SUMMARY
If the name used in your user has initials that are large in width, they will overflow their square in the "Change Avatar" view.


STEPS TO REPRODUCE
1. Change your name to start with large initials
2. Go to the "Change Avatar" view.


SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Comment 1 Nate Graham 2022-01-14 20:41:24 UTC
Hah can confirm. The M character is the widest one in the Latin alphabet, and it looks like two of them together overflow.

We'll need to increase the size of the button surrounding the letters, or else make the letters smaller here, or else make the size dynamic.
Comment 2 Nate Graham 2022-01-14 20:49:55 UTC
Oh it's already trying to make them fit, but there's a bug.
Comment 3 Nate Graham 2022-01-14 20:58:44 UTC
Git commit a1902c4292c3c2688e47a750c0290c4d253b61fb by Nate Graham.
Committed on 14/01/2022 at 20:58.
Pushed by ngraham into branch 'master'.

kcm/users: make initials text fit and scale properly
FIXED-IN: 5.24

M  +5    -1    kcms/users/package/contents/ui/UserDetailsPage.qml

https://invent.kde.org/plasma/plasma-workspace/commit/a1902c4292c3c2688e47a750c0290c4d253b61fb
Comment 4 Nate Graham 2022-01-14 20:59:11 UTC
Git commit d439eb0fa870e4a7b70a88573f944a0165727277 by Nate Graham.
Committed on 14/01/2022 at 20:59.
Pushed by ngraham into branch 'Plasma/5.24'.

kcm/users: make initials text fit and scale properly
FIXED-IN: 5.24
(cherry picked from commit a1902c4292c3c2688e47a750c0290c4d253b61fb)

M  +5    -1    kcms/users/package/contents/ui/UserDetailsPage.qml

https://invent.kde.org/plasma/plasma-workspace/commit/d439eb0fa870e4a7b70a88573f944a0165727277