Bug 448383 - Notifications popup opens very small
Summary: Notifications popup opens very small
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Notifications (show other bugs)
Version: 5.23.90
Platform: Archlinux Linux
: HI normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-13 18:52 UTC by Nico
Modified: 2022-02-14 17:28 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.1


Attachments
Screenshot of the popup (46.96 KB, image/png)
2022-01-13 18:52 UTC, Nico
Details
Screenshot after applying the patch (70.00 KB, image/png)
2022-01-26 17:09 UTC, Nico
Details
Notifications are still broken in Plasma 5.24 (39.05 KB, image/png)
2022-02-10 10:42 UTC, Riccardo Robecchi
Details
Notifications applet with the correct size (40.74 KB, image/png)
2022-02-10 10:44 UTC, Riccardo Robecchi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nico 2022-01-13 18:52:21 UTC
Created attachment 145423 [details]
Screenshot of the popup

SUMMARY
Notifications popup opens very small

STEPS TO REPRODUCE

Not sure on which occasions this happens, but I'm going to describe my Panel setup

1. Create a top panel containing Applets: Kickoff, Window Title, Global Menu, Flexible spacer, System Tray, KDE Connect, Networks, Volume, Digital Clock, Notifications
2. Configure System Tray > Entries > Notifications > Disabled
3. (Maybe restart Plasma)
4. Click on the notifications plasmoid

OBSERVED RESULT
Opens up very small (see screenshot)
(Can be resized with Meta+Right click drag)

EXPECTED RESULT
Open with a normal size, like before

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
KDE Plasma Version: 5.23.90
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.12

ADDITIONAL INFORMATION
Comment 1 Nico 2022-01-13 18:53:18 UTC
Let me know if you need any additional information regarding my setup
Comment 2 Nico 2022-01-13 19:11:42 UTC
I also noticed that it happens after resizing it, then receiving a notification, removing it from the history and opening it again after waiting some time. I think this is a consequential error though as it somehow resets the size to the original one and that one is wrong.
Comment 3 Nate Graham 2022-01-13 22:08:34 UTC
Can reproduce. Seems fixable.
Comment 4 Bug Janitor Service 2022-01-13 22:18:07 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1362
Comment 5 Nico 2022-01-14 06:17:23 UTC
Nice, thank you I will try the patch later today. Quick note what just came to my mind: Would it be possible to add an option to set the size when using notifications as a panel applet? This would make it possible to configure it like the notification sidebar in Windows 10.
Comment 6 Nate Graham 2022-01-17 05:07:58 UTC
Git commit 9a6b190046a2db46523112da1af61be64c60d047 by Nate Graham.
Committed on 17/01/2022 at 05:07.
Pushed by ngraham into branch 'master'.

applets/notifications: set implicit size

Without this, the FullRepresentation opens to an unusably small size
when it's a Panel applet.
FIXED-IN: 5.24

M  +4    -0    applets/notifications/package/contents/ui/FullRepresentation.qml

https://invent.kde.org/plasma/plasma-workspace/commit/9a6b190046a2db46523112da1af61be64c60d047
Comment 7 Nate Graham 2022-01-17 05:08:25 UTC
Git commit 97d003374fbbc21f8e93b468aa96269637f6073b by Nate Graham.
Committed on 17/01/2022 at 05:08.
Pushed by ngraham into branch 'Plasma/5.24'.

applets/notifications: set implicit size

Without this, the FullRepresentation opens to an unusably small size
when it's a Panel applet.
FIXED-IN: 5.24


(cherry picked from commit 9a6b190046a2db46523112da1af61be64c60d047)

M  +4    -0    applets/notifications/package/contents/ui/FullRepresentation.qml

https://invent.kde.org/plasma/plasma-workspace/commit/97d003374fbbc21f8e93b468aa96269637f6073b
Comment 8 Kai Uwe Broulik 2022-01-17 07:42:53 UTC
How did that regress? In the original implementation I made sure that it worked fine as a standalone panel applet.
Comment 9 Nico 2022-01-26 17:09:10 UTC
Created attachment 145963 [details]
Screenshot after applying the patch
Comment 10 Nico 2022-01-26 17:10:55 UTC
Hm, I just looked, and I think it's still quite small. I liked the way it was in the old Plasma version. I still think an option to configure it would be  best
Comment 11 Riccardo Robecchi 2022-02-10 10:42:48 UTC
Created attachment 146526 [details]
Notifications are still broken in Plasma 5.24

The size currently set, 16 x 16, is still way too small and, in any case, much smaller than the applet was before. This makes notifications too dense and the messages scrollable; in other words, the applet is nigh unusable right now. Through some trial and error, and doing a comparison to another install that still has 5.23, I reconstructed that the previous size was 18 x 24.
Comment 12 Riccardo Robecchi 2022-02-10 10:44:28 UTC
Created attachment 146527 [details]
Notifications applet with the correct size
Comment 13 Nico 2022-02-10 11:29:17 UTC
As already mentioned I agree with what Riccardo said.
Comment 14 Nate Graham 2022-02-10 18:39:29 UTC
Perhaps I failed to understand the original issue but I don't see the problem in those screenshots. Can you clarify what exactly the issue is?
Comment 15 Nico 2022-02-10 18:41:56 UTC
The old size that the plasmoid, when it was open had, was much more reasonable.
Comment 16 Nate Graham 2022-02-10 23:36:14 UTC
What was the old size, though?

Maybe you can find a size that works for you by changing the implicitWidth and implicitHeight values in /usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/FullRepresentation.qml

See if you can find the value that makes it the size it used to be.
Comment 17 Riccardo Robecchi 2022-02-12 14:33:53 UTC
(In reply to Nate Graham from comment #16)
> What was the old size, though?
> 
> Maybe you can find a size that works for you by changing the implicitWidth
> and implicitHeight values in
> /usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/
> FullRepresentation.qml
> 
> See if you can find the value that makes it the size it used to be.

As I wrote in my previous message, I reconstructed the size to be 18 x 24.
Comment 18 Nico 2022-02-12 14:37:49 UTC
I manually edited `/usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/FullRepresentation.qml` to use 18 x 24, and I think it's much more reasonable. Would it make sense to add an option for it in the plasmoid settings? Seems like it does not already have settings.
Comment 19 Nate Graham 2022-02-14 17:28:31 UTC
Git commit 928a2edbcb21c45170969ae2f4c9b14c167e8f31 by Nate Graham.
Committed on 14/02/2022 at 17:27.
Pushed by ngraham into branch 'master'.

applets/notifications: Increase implicit size of standalone popup
FIXED-IN: 5.24.1

M  +2    -2    applets/notifications/package/contents/ui/FullRepresentation.qml

https://invent.kde.org/plasma/plasma-workspace/commit/928a2edbcb21c45170969ae2f4c9b14c167e8f31
Comment 20 Nate Graham 2022-02-14 17:28:55 UTC
Git commit 843c5ae6df074dd0eb27fa773c3221b49555b4ff by Nate Graham.
Committed on 14/02/2022 at 17:28.
Pushed by ngraham into branch 'Plasma/5.24'.

applets/notifications: Increase implicit size of standalone popup
FIXED-IN: 5.24.1
(cherry picked from commit 928a2edbcb21c45170969ae2f4c9b14c167e8f31)

M  +2    -2    applets/notifications/package/contents/ui/FullRepresentation.qml

https://invent.kde.org/plasma/plasma-workspace/commit/843c5ae6df074dd0eb27fa773c3221b49555b4ff