Bug 448345 - crash when unmounting external USB drive
Summary: crash when unmounting external USB drive
Status: RESOLVED DUPLICATE of bug 427945
Alias: None
Product: plasmashell
Classification: Unclassified
Component: generic-crash (show other bugs)
Version: 5.23.5
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-13 04:53 UTC by Mariusz Libera
Modified: 2022-01-13 07:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mariusz Libera 2022-01-13 04:53:22 UTC
Right clicked on my external USB drive in dolphin and 'Safely Remove'. Plasma crashed.

sty 13 04:34:43 plasmashell[1177]: file:///usr/share/plasma/plasmoids/org.kde.plasma.devicenotifier/contents/ui/DeviceItem.qml:158:5: Unable to assign [undefined] to QString
sty 13 04:34:43 plasmashell[1177]: 25 -- exe=/usr/bin/plasmashell
sty 13 04:34:43 plasmashell[1177]: 13 -- platform=xcb
sty 13 04:34:43 plasmashell[1177]: 11 -- display=:0
sty 13 04:34:43 plasmashell[1177]: 20 -- appname=plasmashell
sty 13 04:34:43 plasmashell[1177]: 17 -- apppath=/usr/bin
sty 13 04:34:43 plasmashell[1177]: 10 -- signal=11
sty 13 04:34:43 plasmashell[1177]: 9 -- pid=1177
sty 13 04:34:43 plasmashell[1177]: 18 -- appversion=5.23.5
sty 13 04:34:43 plasmashell[1177]: 19 -- programname=Plasma
sty 13 04:34:43 plasmashell[1177]: 31 -- bugaddress=submit@bugs.kde.org
sty 13 04:34:43 plasmashell[1177]: 12 -- startupid=0
sty 13 04:34:43 plasmashell[1177]: KCrash: crashing... crashRecursionCounter = 2
sty 13 04:34:43 plasmashell[1177]: KCrash: Application Name = plasmashell path = /usr/bin pid = 1177
sty 13 04:34:43 plasmashell[1177]: KCrash: Arguments: /usr/bin/plasmashell --no-respawn
sty 13 04:34:43 plasmashell[1177]: XXX: resource creation failed
sty 13 04:34:43 plasmashell[1177]: Unable to start Dr. Konqi
sty 13 04:34:43 plasmashell[1177]: Re-raising signal for core dump handling.
sty 13 04:34:43 kded5[1094]: Service  "org.kde.StatusNotifierHost-1177" unregistered
sty 13 04:34:43 kwin_x11[1095]: QMetaProperty::read: Unable to handle unregistered datatype 'KWin::SessionState' for property 'KWin::EffectsHandlerImplX11::sessionState'
sty 13 04:34:43 kwin_x11[1095]: QMetaProperty::read: Unable to handle unregistered datatype 'KWin::SessionState' for property 'KWin::EffectsHandlerImplX11::sessionState'
sty 13 04:34:43 kwin_x11[1095]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 53812, resource id: 23068759, major code: 15 (QueryTree), minor code: 0
sty 13 04:34:43 kwin_x11[1095]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 53914, resource id: 23068697, major code: 15 (QueryTree), minor code: 0
sty 13 04:34:43 kwin_x11[1095]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54003, resource id: 23068703, major code: 15 (QueryTree), minor code: 0
sty 13 04:34:43 kwin_x11[1095]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54091, resource id: 23068784, major code: 15 (QueryTree), minor code: 0
sty 13 04:34:43 kwin_x11[1095]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54178, resource id: 23068735, major code: 15 (QueryTree), minor code: 0
sty 13 04:34:57 kwin_x11[1095]: kwin_core: Failed to focus 0x2c00007 (error 8)
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: State 'stop-sigterm' timed out. Killing.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1177 (plasmashell) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1181 (QXcbEventQueue) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1182 (QDBusConnection) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1186 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1187 (plasmashel:sh0) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1188 (plasmashel:sh1) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1189 (plasmashel:sh2) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1190 (plasmashel:sh3) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1191 (plasmashel:sh4) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1192 (plasmashel:sh5) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1234 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1255 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1256 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1257 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1258 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1259 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1371 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1412 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1413 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1419 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1423 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1424 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1427 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 1428 (QSGRenderThread) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 2457 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 2458 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 3016 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 3017 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4122 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4123 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4124 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4125 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4126 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4127 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4128 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4131 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4132 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4133 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4134 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4135 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4136 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4790 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4796 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Killing process 4797 (n/a) with signal SIGKILL.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Main process exited, code=killed, status=11/SEGV
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Failed with result 'timeout'.
sty 13 04:35:23 systemd[1051]: plasma-plasmashell.service: Consumed 33.579s CPU time.
sty 13 04:35:24 systemd[1051]: plasma-plasmashell.service: Scheduled restart job, restart counter is at 1.
sty 13 04:35:24 systemd[1051]: Stopped KDE Plasma Workspace.
sty 13 04:35:24 systemd[1051]: plasma-plasmashell.service: Consumed 33.579s CPU time.
sty 13 04:35:24 systemd[1051]: Starting KDE Plasma Workspace...
sty 13 04:35:24 systemd[1051]: Started KDE Plasma Workspace.


SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.0-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 19.3 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Comment 1 Fushan Wen 2022-01-13 07:52:28 UTC
Should be fixed in 5.24.

*** This bug has been marked as a duplicate of bug 427945 ***