Bug 448296 - Krita crashes when opening "Layer Style..."
Summary: Krita crashes when opening "Layer Style..."
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: layer styles (show other bugs)
Version: 5.0.2
Platform: Microsoft Windows Microsoft Windows
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-12 05:59 UTC by oktopuse
Modified: 2022-02-28 14:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kritacrash.log snippet of the latest crash (31.11 KB, text/plain)
2022-01-12 05:59 UTC, oktopuse
Details
krita.log from 5.1.0-prealpha attempt (1.04 KB, text/plain)
2022-02-19 21:24 UTC, oktopuse
Details
kritacrash.log from 5.1.0-prealpha attempt (31.08 KB, text/plain)
2022-02-19 21:24 UTC, oktopuse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description oktopuse 2022-01-12 05:59:57 UTC
Created attachment 145351 [details]
kritacrash.log snippet of the latest crash

SUMMARY
Krita crashes when opening "Layer Style..."

STEPS TO REPRODUCE
1. File -> New
2. Custom Document -> Predefined = A4 (300 ppi) -> Create
3. Add Paint Layer
4. Right click Paint Layer 1 -> "Layer Style..."

OBSERVED RESULT
Krita crashes.

EXPECTED RESULT
Krita allows me to enable a layer style like inner glow.

SOFTWARE/OS VERSIONS
Krita

 Version: 5.0.2
 Languages: en_US, en
 Hidpi: true

Qt

  Version (compiled): 5.12.12
  Version (loaded): 5.12.12

OS Information

  Build ABI: x86_64-little_endian-llp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: winnt
  Kernel Version: 10.0.19043
  Pretty Productname: Windows 10 (10.0)
  Product Type: windows
  Product Version: 10

OpenGL Info
 
  Vendor:  "ATI Technologies Inc." 
  Renderer:  "Radeon RX 580 Series" 
  Version:  "3.0.14742 Compatibility Profile Context 21.8.2 27.20.22025.1006" 
  Shading language:  "4.60" 
  Requested format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::CompatibilityProfile) 
  Current format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 1, colorSpace QSurfaceFormat::sRGBColorSpace, profile  QSurfaceFormat::NoProfile) 
     Version: 3.0
     Supports deprecated functions true 
     is OpenGL ES: false 
  supportsBufferMapping: true 
  supportsBufferInvalidation: true 
  Extensions: 
     "GL_AMD_gpu_shader_int64" 
     "GL_EXT_stencil_wrap" 
     "GL_ARB_multisample" 
     "GL_ARB_instanced_arrays" 
     "GL_NV_shader_atomic_int64" 
     "GL_ARB_texture_cube_map" 
     "GL_ARB_arrays_of_arrays" 
     "GL_ARB_derivative_control" 
     "GL_NV_depth_buffer_float" 
     "GL_ARB_multi_draw_indirect" 
     "GL_ARB_ES2_compatibility" 
     "GL_ARB_geometry_shader4" 
     "GL_ARB_explicit_attrib_location" 
     "GL_ARB_seamless_cube_map" 
     "GL_IBM_texture_mirrored_repeat" 
     "GL_ARB_texture_barrier" 
     "GL_ARB_provoking_vertex" 
     "GL_KHR_context_flush_control" 
     "GL_ARB_compatibility" 
     "GL_SGIS_texture_edge_clamp" 
     "GL_EXT_texture_filter_anisotropic" 
     "GL_ARB_texture_cube_map_array" 
     "GL_ARB_shader_precision" 
     "GL_EXT_fog_coord" 
     "GL_EXT_point_parameters" 
     "GL_AMD_stencil_operation_extended" 
     "GL_ARB_shader_image_size" 
     "GL_ATI_texture_env_combine3" 
     "GL_ARB_gpu_shader5" 
     "GL_EXT_texture_integer" 
     "GL_ARB_vertex_program" 
     "GL_ARB_shader_texture_image_samples" 
     "GL_ARB_sparse_texture" 
     "GL_AMD_framebuffer_sample_positions" 
     "GL_ARB_transform_feedback2" 
     "GL_EXT_texture_env_combine" 
     "GL_ARB_shader_storage_buffer_object" 
     "GL_AMD_blend_minmax_factor" 
     "GL_ATI_draw_buffers" 
     "GL_EXT_texture_lod_bias" 
     "GL_EXT_texture_object" 
     "GL_ARB_internalformat_query" 
     "GL_ARB_polygon_offset_clamp" 
     "GL_AMD_transform_feedback3_lines_triangles" 
     "GL_ARB_ES3_1_compatibility" 
     "GL_ARB_texture_mirror_clamp_to_edge" 
     "GL_AMD_texture_texture4" 
     "GL_EXT_blend_minmax" 
     "GL_NV_explicit_multisample" 
     "GL_ARB_vertex_shader" 
     "GL_AMD_sparse_texture_pool" 
     "GL_EXT_texture_lod" 
     "GL_EXT_texture_env_add" 
     "GL_EXT_framebuffer_sRGB" 
     "GL_ARB_texture_non_power_of_two" 
     "GL_ARB_compute_shader" 
     "GL_ARB_texture_storage_multisample" 
     "GL_ATI_separate_stencil" 
     "GL_AMD_name_gen_delete" 
     "GL_ARB_multi_bind" 
     "GL_ARB_fragment_program" 
     "GL_EXT_texture_snorm" 
     "GL_EXT_gpu_shader4" 
     "GL_ARB_gl_spirv" 
     "GL_OES_EGL_image" 
     "GL_EXT_provoking_vertex" 
     "GL_ARB_half_float_vertex" 
     "GL_ARB_texture_float" 
     "GL_NV_texgen_reflection" 
     "GL_EXT_copy_buffer" 
     "GL_ARB_sync" 
     "GL_EXT_shadow_funcs" 
     "GL_AMD_shader_atomic_counter_ops" 
     "GL_ARB_vertex_array_object" 
     "GL_ARB_window_pos" 
     "GL_AMD_occlusion_query_event" 
     "GL_ARB_invalidate_subdata" 
     "GL_ARB_base_instance" 
     "GL_AMD_debug_output" 
     "GL_ARB_texture_compression" 
     "GL_ARB_texture_storage" 
     "GL_ARB_point_sprite" 
     "GL_ARB_spirv_extensions" 
     "GL_ARB_occlusion_query2" 
     "GL_ARB_bindless_texture" 
     "GL_SUN_multi_draw_arrays" 
     "GL_KHR_debug" 
     "WGL_EXT_swap_control" 
     "GL_ARB_texture_query_levels" 
     "GL_ARB_clear_texture" 
     "GL_EXT_texture_storage" 
     "GL_ARB_robust_buffer_access_behavior" 
     "GL_ARB_texture_view" 
     "GL_ARB_separate_shader_objects" 
     "GL_EXT_draw_buffers2" 
     "GL_ARB_texture_multisample" 
     "GL_ARB_texture_stencil8" 
     "GL_EXT_texture_sRGB" 
     "GL_AMD_sparse_texture" 
     "GL_ARB_transform_feedback3" 
     "GL_EXT_polygon_offset_clamp" 
     "GL_EXT_blend_subtract" 
     "GL_ARB_pipeline_statistics_query" 
     "GL_ARB_draw_indirect" 
     "GL_NV_alpha_to_coverage_dither_control" 
     "GL_ARB_shader_draw_parameters" 
     "GL_ARB_debug_output" 
     "GL_ARB_get_texture_sub_image" 
     "GL_ARB_indirect_parameters" 
     "GL_ARB_texture_env_crossbar" 
     "GL_EXT_draw_instanced" 
     "GL_ARB_blend_func_extended" 
     "GL_EXT_texture_buffer_object" 
     "GL_EXT_abgr" 
     "GL_AMD_vertex_shader_viewport_index" 
     "GL_ATI_texture_float" 
     "GL_ARB_shader_bit_encoding" 
     "GL_NV_primitive_restart" 
     "GL_ARB_draw_buffers" 
     "GL_EXT_texture_compression_s3tc" 
     "GL_EXT_gpu_program_parameters" 
     "GL_ARB_shader_subroutine" 
     "GL_EXT_depth_bounds_test" 
     "GL_ATI_texture_compression_3dc" 
     "GL_EXT_texture_sRGB_R8" 
     "GL_ARB_color_buffer_float" 
     "GL_ARB_texture_env_dot3" 
     "GL_EXT_blend_color" 
     "GL_AMD_shader_trinary_minmax" 
     "GL_KHR_robustness" 
     "GL_ARB_shader_stencil_export" 
     "GL_EXT_vertex_array_bgra" 
     "GL_EXT_framebuffer_multisample" 
     "GL_ARB_map_buffer_range" 
     "GL_ARB_sparse_buffer" 
     "GL_EXT_texture_sRGB_RG8" 
     "GL_ARB_vertex_type_10f_11f_11f_rev" 
     "GL_ARB_direct_state_access" 
     "GL_ARB_shader_texture_lod" 
     "GL_ARB_texture_mirrored_repeat" 
     "GL_ARB_texture_rgb10_a2ui" 
     "GL_ARB_shading_language_100" 
     "GL_SGIS_texture_lod" 
     "GL_ARB_shader_image_load_store" 
     "GL_ARB_enhanced_layouts" 
     "GL_ARB_viewport_array" 
     "GL_EXT_blend_equation_separate" 
     "GL_AMD_draw_buffers_blend" 
     "GL_AMD_performance_monitor" 
     "GL_ARB_compressed_texture_pixel_storage" 
     "GL_ARB_fragment_program_shadow" 
     "GL_EXT_texture_edge_clamp" 
     "GL_AMD_texture_cube_map_array" 
     "GL_EXT_semaphore_win32" 
     "GL_EXT_geometry_shader4" 
     "GL_ARB_uniform_buffer_object" 
     "GL_EXT_memory_object" 
     "GL_ARB_internalformat_query2" 
     "GL_ARB_vertex_attrib_binding" 
     "GL_ARB_cull_distance" 
     "GL_ARB_timer_query" 
     "GL_ARB_conditional_render_inverted" 
     "GL_ARB_sample_shading" 
     "GL_NV_copy_depth_to_color" 
     "GL_NV_half_float" 
     "GL_ARB_map_buffer_alignment" 
     "GL_ARB_fragment_shader" 
     "GL_EXT_texture_shared_exponent" 
     "GL_AMD_multi_draw_indirect" 
     "GL_AMD_query_buffer_object" 
     "GL_ARB_buffer_storage" 
     "GL_NV_texture_barrier" 
     "GL_ARB_vertex_type_2_10_10_10_rev" 
     "GL_EXT_histogram" 
     "GL_ARB_pixel_buffer_object" 
     "GL_ARB_clear_buffer_object" 
     "GL_AMD_transform_feedback4" 
     "GL_ARB_framebuffer_no_attachments" 
     "GL_ARB_texture_buffer_object_rgb32" 
     "GL_ARB_texture_gather" 
     "GL_ARB_texture_rectangle" 
     "GL_ARB_imaging" 
     "GL_ARB_transform_feedback_overflow_query" 
     "GL_KHR_parallel_shader_compile" 
     "GL_WIN_swap_hint" 
     "GL_EXT_draw_range_elements" 
     "GL_ARB_depth_texture" 
     "GL_EXT_texture_compression_latc" 
     "GL_ARB_tessellation_shader" 
     "GL_ARB_copy_image" 
     "GL_EXT_texture_rectangle" 
     "GL_ARB_ES3_compatibility" 
     "GL_AMD_pinned_memory" 
     "GL_EXT_texture_sRGB_decode" 
     "GL_ARB_shader_atomic_counters" 
     "GL_AMD_shader_trace" 
     "GL_EXT_framebuffer_object" 
     "GL_ARB_copy_buffer" 
     "GL_SGIS_generate_mipmap" 
     "GL_ARB_shading_language_include" 
     "GL_ARB_multitexture" 
     "GL_ARB_gpu_shader_fp64" 
     "GL_ARB_stencil_texturing" 
     "GL_ATI_envmap_bumpmap" 
     "GL_EXT_blend_func_separate" 
     "GL_ARB_texture_compression_bptc" 
     "GL_ARB_half_float_pixel" 
     "GL_EXT_texture_env_dot3" 
     "GL_ARB_framebuffer_object" 
     "GL_ARB_occlusion_query" 
     "GL_EXT_texture_array" 
     "GL_ARB_texture_buffer_range" 
     "GL_EXT_multi_draw_arrays" 
     "GL_AMD_seamless_cubemap_per_texture" 
     "GL_ARB_texture_query_lod" 
     "GL_ARB_framebuffer_sRGB" 
     "GL_AMD_shader_stencil_export" 
     "GL_ARB_shadow" 
     "GL_ARB_get_program_binary" 
     "GL_EXT_direct_state_access" 
     "GL_ARB_query_buffer_object" 
     "GL_ARB_shading_language_packing" 
     "GL_EXT_texture_compression_bptc" 
     "GL_AMD_gpu_shader_half_float" 
     "GL_EXT_compiled_vertex_array" 
     "GL_EXT_subtexture" 
     "GL_ARB_transform_feedback_instanced" 
     "GL_EXT_transform_feedback" 
     "GL_ARB_conservative_depth" 
     "GL_KHR_robust_buffer_access_behavior" 
     "GL_EXT_packed_float" 
     "GL_EXT_texture_compression_rgtc" 
     "GL_AMD_gcn_shader" 
     "GL_EXT_secondary_color" 
     "GL_AMD_interleaved_elements" 
     "GL_AMD_sample_positions" 
     "GL_AMD_depth_clamp_separate" 
     "GL_ARB_vertex_array_bgra" 
     "GL_EXT_separate_specular_color" 
     "GL_EXT_bindable_uniform" 
     "GL_EXT_texture3D" 
     "GL_EXT_pixel_buffer_object" 
     "GL_EXT_packed_pixels" 
     "GL_AMD_conservative_depth" 
     "GL_AMD_vertex_shader_layer" 
     "GL_EXT_shader_image_load_store" 
     "GL_ARB_seamless_cubemap_per_texture" 
     "GL_NV_conditional_render" 
     "GL_ARB_point_parameters" 
     "GL_ARB_shading_language_420pack" 
     "GL_ARB_draw_elements_base_vertex" 
     "GL_ARB_texture_env_combine" 
     "GL_KHR_no_error" 
     "GL_EXT_packed_depth_stencil" 
     "GL_ATI_texture_mirror_once" 
     "GL_ARB_fragment_coord_conventions" 
     "GL_ARB_depth_buffer_float" 
     "GL_KTX_buffer_region" 
     "GL_EXT_rescale_normal" 
     "GL_ARB_vertex_attrib_64bit" 
     "GL_EXT_vertex_attrib_64bit" 
     "GL_ARB_depth_clamp" 
     "GL_NV_blend_square" 
     "GL_EXT_texgen_reflection" 
     "GL_ATI_fragment_shader" 
     "GL_ARB_texture_env_add" 
     "GL_EXT_memory_object_win32" 
     "GL_EXT_shader_integer_mix" 
     "GL_ARB_texture_rg" 
     "GL_ARB_shader_group_vote" 
     "GL_ARB_explicit_uniform_location" 
     "GL_ARB_shader_objects" 
     "GL_ARB_parallel_shader_compile" 
     "GL_EXT_bgra" 
     "GL_EXT_framebuffer_blit" 
     "GL_ARB_draw_instanced" 
     "GL_AMD_shader_stencil_value_export" 
     "GL_ARB_texture_compression_rgtc" 
     "GL_ARB_shadow_ambient" 
     "GL_ARB_shader_ballot" 
     "GL_AMD_gpu_shader_int16" 
     "GL_EXT_texture_mirror_clamp" 
     "GL_NV_float_buffer" 
     "GL_ARB_texture_swizzle" 
     "GL_ARB_transpose_matrix" 
     "GL_ARB_texture_border_clamp" 
     "GL_EXT_copy_texture" 
     "GL_EXT_vertex_array" 
     "GL_ARB_texture_snorm" 
     "GL_EXT_semaphore" 
     "GL_ARB_program_interface_query" 
     "GL_AMDX_debug_output" 
     "GL_ARB_texture_buffer_object" 
     "GL_EXT_texture_cube_map" 
     "GL_EXT_timer_query" 
     "GL_ARB_shader_atomic_counter_ops" 
     "GL_ARB_sampler_objects" 
     "GL_ARB_vertex_buffer_object" 
     "GL_ARB_shader_viewport_layer_array" 
     "GL_ARB_clip_control" 
     "GL_EXT_texture_swizzle" 
     "GL_ARB_draw_buffers_blend" 
     "GL_ARB_fragment_layer_viewport" 
     "GL_NV_copy_image" 

QPA OpenGL Detection Info 
  supportsDesktopGL: true 
  supportsAngleD3D11: true 
  isQtPreferAngle: true 

useBufferInvalidation (config option): false


Hardware Information

  GPU Acceleration: desktop
  Memory: 16334 Mb
  Number of Cores: 12
  Swap Location: C:/Users/USERNAME/AppData/Local/Temp

Current Settings

  Current Swap Location: C:/Users/USERNAME/AppData/Local/Temp
  Current Swap Location writable: true
  Undo Enabled: true
  Undo Stack Limit: 200
  Use OpenGL: true
  Use OpenGL Texture Buffer: true
  Disable Vector Optimizations: false
  Disable AVX Optimizations: false
  Canvas State: OPENGL_SUCCESS
  Autosave Interval: 600
  Use Backup Files: true
  Number of Backups Kept: 1
  Backup File Suffix: ~
  Backup Location: Same Folder as the File
  Backup Location writable: false
  Use Win8 Pointer Input: false
  Use RightMiddleTabletButton Workaround: false
  Levels of Detail Enabled: false
  Use Zip64: false


Display Information
Number of screens: 2
	Screen: 0
		Name: \\.\DISPLAY2
		Depth: 32
		Scale: 1
		Resolution in pixels: 2560x1440
		Manufacturer: 
		Model: 
		Refresh Rate: 144
	Screen: 1
		Name: \\.\DISPLAY1
		Depth: 32
		Scale: 1
		Resolution in pixels: 1080x1920
		Manufacturer: 
		Model: 
		Refresh Rate: 60

ADDITIONAL INFORMATION
I've run into this in several different permutations of the workflow, like sometimes it lets me select a layer style and then it crashes on closing the popup and sometimes it crashes on the click down of one of the layer styles. It seems to be if I wait long enough with the popup open is what causes the crash, and it happens every time.

Snippet output from the Krita Usage Log for this case:
SESSION: 11 Jan 2022 21:40:26 -0800. Executing C:\Program Files\Krita (x64)\bin\krita.exe

Krita Version: 5.0.2, Qt version compiled: 5.12.12, loaded: 5.12.12. Process ID: 24100
-- -- -- -- -- -- -- --
11 Jan 2022 21:40:26 -0800: Style: fusion. Available styles: windowsvista, Windows, Fusion
11 Jan 2022 21:40:28 -0800: Database is up to date. Version: 0.0.15, created by Krita 5.0.0, at Thu Dec 23 14:11:36 2021
11 Jan 2022 21:40:33 -0800: Could not load resourcepatterns/krita_Vv2404.pat
11 Jan 2022 21:40:33 -0800: Could not load resourcepatterns/krita_qh2404.pat
11 Jan 2022 21:40:33 -0800: Could not load resourcepatterns/krita_tm2404.pat
11 Jan 2022 21:40:33 -0800: Could not load resourcepatterns/krita_yD2404.pat
11 Jan 2022 21:40:33 -0800: Could not retrieve md5 for resourcepalettes/Pastel5x2.kpl
11 Jan 2022 21:40:35 -0800: Non-store package - creating updater
11 Jan 2022 21:41:30 -0800: Importing application/x-krita to application/x-krita. Location: C:/Users/USERNAME/AppData/Local/Temp/.krita-19828-document_0-autosave.kra. Real location: C:/Users/USERNAME/AppData/Local/Temp/.krita-19828-document_0-autosave.kra. Batchmode: 0
11 Jan 2022 21:41:31 -0800: Loaded image from application/x-krita. Size: 1765 * 1080 pixels, 4.16667 dpi. Color model: 8-bit integer/channel RGB/Alpha (sRGB built-in). Layers: 5
11 Jan 2022 21:42:34 -0800: Saving Document C:/Users/USERNAME/OneDrive/Pictures/document_0.kra as C:/Users/USERNAME/OneDrive/Pictures/document_0.kra (mime: application/x-krita). 1765 * 1080 pixels, 5 layers.  101 frames, 24 framerate. Export configuration: No configuration
11 Jan 2022 21:42:34 -0800: Converting from application/x-krita to application/x-krita. Location: C:/Users/USERNAME/OneDrive/Pictures/document_0.kra. Real location: C:/Users/USERNAME/OneDrive/Pictures/document_0.kra. Batchmode: 0. Configuration: none
11 Jan 2022 21:42:35 -0800: Completed saving C:/Users/USERNAME/OneDrive/Pictures/document_0.kra (mime: application/x-krita). Result: OK. Warning: . Size: 3065610
11 Jan 2022 21:42:35 -0800: Saving Completed
11 Jan 2022 21:42:48 -0800: Created image "Unnamed", 2480 * 3508 pixels, 300 dpi. Color model: 8-bit integer/channel RGB/Alpha (sRGB built-in). Layers: 1
Comment 1 Dmitry Kazakov 2022-02-18 06:37:57 UTC
Hi, Octopuse!

Could you please test this nightly build of Krita? I guess I have fixed this issue in the patch that was too late for 5.0.2...

https://binary-factory.kde.org/job/Krita_Nightly_Windows_Build/
Comment 2 oktopuse 2022-02-19 21:23:50 UTC
(In reply to Dmitry Kazakov from comment #1)
> Hi, Octopuse!
> 
> Could you please test this nightly build of Krita? I guess I have fixed this
> issue in the patch that was too late for 5.0.2...
> 
> https://binary-factory.kde.org/job/Krita_Nightly_Windows_Build/

Hello!

I just downloaded the latest stable nightly installer (krita-nightly-x64-5.1.0-prealpha-93323dee55-setup.exe) and tried again but still got the crash when opening up Layer Style and waiting a few seconds. I will add the parts of the krita.log / kritacrash.log as attachments for this latest attempt.
Comment 3 oktopuse 2022-02-19 21:24:35 UTC
Created attachment 146948 [details]
krita.log from 5.1.0-prealpha attempt
Comment 4 oktopuse 2022-02-19 21:24:59 UTC
Created attachment 146949 [details]
kritacrash.log from 5.1.0-prealpha attempt
Comment 5 Bug Janitor Service 2022-02-20 04:37:01 UTC
Thanks for your comment!

Automatically switching the status of this bug to REPORTED so that the KDE team
knows that the bug is ready to get confirmed.

In the future you may also do this yourself when providing needed information.
Comment 6 Dmitry Kazakov 2022-02-28 13:50:33 UTC
This bug will be fixed in 5.0.3 release :)

*** This bug has been marked as a duplicate of bug 445922 ***
Comment 7 Dmitry Kazakov 2022-02-28 13:51:49 UTC
Damn... I think I have closed the bug prematurely :(
Comment 8 Dmitry Kazakov 2022-02-28 14:15:40 UTC
Git commit b0dc7adc0789afe951b4f62d9fab4db7d6e17135 by Dmitry Kazakov.
Committed on 28/02/2022 at 14:11.
Pushed by dkazakov into branch 'krita/5.0'.

Fix a crash when the selected gradient is filtered in LS dialog

M  +12   -4    libs/ui/dialogs/kis_dlg_layer_style.cpp
M  +2    -2    libs/ui/widgets/gradient/KisGradientChooser.cpp
M  +1    -1    libs/ui/widgets/gradient/KisGradientChooser.h
M  +2    -2    libs/ui/widgets/kis_cmb_gradient.cpp
M  +1    -1    libs/ui/widgets/kis_cmb_gradient.h

https://invent.kde.org/graphics/krita/commit/b0dc7adc0789afe951b4f62d9fab4db7d6e17135
Comment 9 Dmitry Kazakov 2022-02-28 14:15:55 UTC
Git commit 9ec4d99db0c6cf26c90ca9358c6b5e02bbd6c23b by Dmitry Kazakov.
Committed on 28/02/2022 at 14:11.
Pushed by dkazakov into branch 'master'.

Fix a crash when the selected gradient is filtered in LS dialog

M  +12   -4    libs/ui/dialogs/kis_dlg_layer_style.cpp
M  +2    -2    libs/ui/widgets/gradient/KisGradientChooser.cpp
M  +1    -1    libs/ui/widgets/gradient/KisGradientChooser.h
M  +2    -2    libs/ui/widgets/kis_cmb_gradient.cpp
M  +1    -1    libs/ui/widgets/kis_cmb_gradient.h

https://invent.kde.org/graphics/krita/commit/9ec4d99db0c6cf26c90ca9358c6b5e02bbd6c23b