Bug 448154 - Cannot use accented chars in keyboard shortcuts
Summary: Cannot use accented chars in keyboard shortcuts
Status: RESOLVED DUPLICATE of bug 434949
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.23.2
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-09 08:54 UTC by Johannes
Modified: 2022-01-13 03:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Keyboard shortcuts in ksettings. (55.87 KB, image/png)
2022-01-09 08:54 UTC, Johannes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes 2022-01-09 08:54:49 UTC
Created attachment 145257 [details]
Keyboard shortcuts in ksettings.

SUMMARY
I am unable to use accented chars for keyboard shortcuts. 

Example: I have four virtual desktops, and I would like to set a keyboard shortcuts to send a window to virtual desktops number 4, which I would like to do by hitting Alt+Shift+4. On my Swiss keyboard layout, the combination Shift+4 yields the character ç, which is used in French, so Alt+Shift+4 actually renders Alt+Shift+ç. Setting this keyboard short wouldn't work.

STEPS TO REPRODUCE
1. Enable a keyboard layout with accented chars (I use the Swiss layout).
2. Open ksettings > Keyboard shortcuts > kwin > Move window to virtual desktop 4 > set something with accented char.
3. Apply and try. 
You may want to try another keyboard shortcut without accented char, for comparison.

OBSERVED RESULT
I have done some trials, and it appears that only accented chars wouldn't work (ç, à, é, ö, ...). For instance, setting it to Alt+Shift+V, or even with special chars would work, such as Alt+Shift+". Shift if not the cause as Alt+é would fail too.

EXPECTED RESULT
Keyboard shortcuts with accented chars shall work.

ADDITIONAL NOTE
I used the shortcut Alt+Shift+ç for years on GNOME under Xorg, and I recently set it up on Linux Mint Cinnamon, so I believe that it is not a Xorg thing. 
I am not sure it has something to do kwin; I'm an end-user and I know little in that field. Please move my bug report if necessary. 

SOFTWARE/OS VERSIONS
Linux kernel: 5.13.0-23-generic (64 bits) 
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Using X11

ADDITIONAL INFORMATION
You may want to see the attached screenshot.
Comment 1 Nate Graham 2022-01-13 03:39:29 UTC

*** This bug has been marked as a duplicate of bug 434949 ***