Bug 448107 - Pointer for the Edit Shapes tool is a small rectangle of broken lines
Summary: Pointer for the Edit Shapes tool is a small rectangle of broken lines
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Tools/Vector (show other bugs)
Version: 5.0.2
Platform: Microsoft Windows Microsoft Windows
: NOR wishlist
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on: 441232
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-08 11:22 UTC by Chris
Modified: 2022-04-06 16:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2022-01-08 11:22:40 UTC
SUMMARY

When the Edit Shapes tool is selected, its pointer becomes a small rectangle of broken lines.  This is the problem.
When the mouse is moved over a line segment, the pointer becomes a hand with pointed finger which is OK.


STEPS TO REPRODUCE
1. In a vector layer, create a vector object such as a rectangle or bezier curved object.
2. Select the object and then select the Edit Shapes tool.
3. The pointer shape displayed when the mouse is on the canvas is a small rectangle of broken lines.

OBSERVED RESULT
Pointer shape displayed when the mouse is on the canvas is a small rectangle of broken lines.

EXPECTED RESULT
Pointer shape should be some proper shape instead of a pseudo-random bitmap.

SOFTWARE/OS VERSIONS
Windows: 10
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION

Note, this bug was also present in recent 4.4.X versions of Krita.


WARNING: The system information file doesn't exist.File name and location: C:/Users/chris/AppData/Local/krita-sysinfo.log
------------------------------------

Krita
  Version: 5.0.2

Qt
  Version (compiled): 5.12.12
  Version (loaded): 5.12.12

OS Information
  Build ABI: x86_64-little_endian-llp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: winnt
  Kernel Version: 10.0.19044
  Pretty Productname: Windows 10 (10.0)
  Product Type: windows
  Product Version: 10


OpenGL Info
 
  Vendor:  "Google Inc." 
  Renderer:  "ANGLE (NVIDIA GeForce MX250 Direct3D11 vs_5_0 ps_5_0)" 
  Version:  "OpenGL ES 3.0 (ANGLE 2.1.0.57ea533f79a7)" 
  Shading language:  "OpenGL ES GLSL ES 3.00 (ANGLE 2.1.0.57ea533f79a7)" 
  Requested format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::CompatibilityProfile) 
  Current format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile) 
     Version: 3.0
     Supports deprecated functions false 
     is OpenGL ES: true 
  supportsBufferMapping: true 
  supportsBufferInvalidation: false 
  Extensions: 
     "GL_CHROMIUM_sync_query" 
     "GL_ANGLE_program_cache_control" 
     "GL_NV_pixel_buffer_object" 
     "GL_EXT_disjoint_timer_query" 
     "GL_ANGLE_request_extension" 
     "GL_ANGLE_multiview" 
     "GL_OES_surfaceless_context" 
     "GL_EXT_map_buffer_range" 
     "GL_OES_standard_derivatives" 
     "GL_OES_EGL_image" 
     "GL_ANGLE_texture_usage" 
     "GL_KHR_debug" 
     "GL_OES_packed_depth_stencil" 
     "GL_OES_rgb8_rgba8" 
     "GL_EXT_shader_texture_lod" 
     "GL_ANGLE_texture_compression_dxt5" 
     "GL_OES_texture_half_float_linear" 
     "GL_OES_mapbuffer" 
     "GL_ANGLE_instanced_arrays" 
     "GL_NV_pack_subimage" 
     "GL_OES_texture_float" 
     "GL_EXT_debug_marker" 
     "GL_CHROMIUM_bind_generates_resource" 
     "GL_OES_get_program_binary" 
     "GL_CHROMIUM_bind_uniform_location" 
     "GL_EXT_texture_rg" 
     "GL_ANGLE_client_arrays" 
     "GL_OES_EGL_image_external_essl3" 
     "GL_OES_compressed_ETC1_RGB8_texture" 
     "GL_OES_vertex_array_object" 
     "GL_ANGLE_framebuffer_multisample" 
     "GL_ANGLE_translated_shader_source" 
     "GL_CHROMIUM_copy_compressed_texture" 
     "GL_OES_depth32" 
     "GL_EXT_draw_buffers" 
     "GL_EXT_color_buffer_half_float" 
     "GL_ANGLE_robust_client_memory" 
     "GL_OES_element_index_uint" 
     "GL_ANGLE_framebuffer_blit" 
     "GL_EXT_blend_minmax" 
     "GL_ANGLE_texture_compression_dxt3" 
     "GL_EXT_texture_compression_dxt1" 
     "GL_EXT_texture_compression_s3tc_srgb" 
     "GL_EXT_texture_filter_anisotropic" 
     "GL_OES_EGL_image_external" 
     "GL_OES_texture_float_linear" 
     "GL_CHROMIUM_copy_texture" 
     "GL_EXT_discard_framebuffer" 
     "GL_OES_texture_npot" 
     "GL_EXT_frag_depth" 
     "GL_EXT_occlusion_query_boolean" 
     "GL_EXT_sRGB" 
     "GL_EXT_texture_format_BGRA8888" 
     "GL_EXT_texture_norm16" 
     "GL_EXT_color_buffer_float" 
     "GL_ANGLE_lossy_etc_decode" 
     "GL_CHROMIUM_color_buffer_float_rgb" 
     "GL_EXT_read_format_bgra" 
     "GL_NV_EGL_stream_consumer_external" 
     "GL_ANGLE_pack_reverse_row_order" 
     "" 
     "GL_EXT_unpack_subimage" 
     "GL_OES_texture_half_float" 
     "GL_ANGLE_depth_texture" 
     "GL_EXT_texture_storage" 
     "GL_EXT_robustness" 
     "GL_NV_fence" 
     "GL_CHROMIUM_color_buffer_float_rgba" 

QPA OpenGL Detection Info 
  supportsDesktopGL: true 
  supportsAngleD3D11: true 
  isQtPreferAngle: true 

Hardware Information
 Memory: 15 Gb
 Cores: 8
 Swap: C:/Users/chris/AppData/Local/Temp
--------

WARNING: The Krita usage log file doesn't exist.File name and location: C:/Users/chris/AppData/Local/krita.log------------------------------------

Krita
  Version: 5.0.2

Qt
  Version (compiled): 5.12.12
  Version (loaded): 5.12.12

OS Information
  Build ABI: x86_64-little_endian-llp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: winnt
  Kernel Version: 10.0.19044
  Pretty Productname: Windows 10 (10.0)
  Product Type: windows
  Product Version: 10


OpenGL Info
 
  Vendor:  "Google Inc." 
  Renderer:  "ANGLE (NVIDIA GeForce MX250 Direct3D11 vs_5_0 ps_5_0)" 
  Version:  "OpenGL ES 3.0 (ANGLE 2.1.0.57ea533f79a7)" 
  Shading language:  "OpenGL ES GLSL ES 3.00 (ANGLE 2.1.0.57ea533f79a7)" 
  Requested format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::CompatibilityProfile) 
  Current format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile) 
     Version: 3.0
     Supports deprecated functions false 
     is OpenGL ES: true 
  supportsBufferMapping: true 
  supportsBufferInvalidation: false 
  Extensions: 
     "GL_CHROMIUM_sync_query" 
     "GL_ANGLE_program_cache_control" 
     "GL_NV_pixel_buffer_object" 
     "GL_EXT_disjoint_timer_query" 
     "GL_ANGLE_request_extension" 
     "GL_ANGLE_multiview" 
     "GL_OES_surfaceless_context" 
     "GL_EXT_map_buffer_range" 
     "GL_OES_standard_derivatives" 
     "GL_OES_EGL_image" 
     "GL_ANGLE_texture_usage" 
     "GL_KHR_debug" 
     "GL_OES_packed_depth_stencil" 
     "GL_OES_rgb8_rgba8" 
     "GL_EXT_shader_texture_lod" 
     "GL_ANGLE_texture_compression_dxt5" 
     "GL_OES_texture_half_float_linear" 
     "GL_OES_mapbuffer" 
     "GL_ANGLE_instanced_arrays" 
     "GL_NV_pack_subimage" 
     "GL_OES_texture_float" 
     "GL_EXT_debug_marker" 
     "GL_CHROMIUM_bind_generates_resource" 
     "GL_OES_get_program_binary" 
     "GL_CHROMIUM_bind_uniform_location" 
     "GL_EXT_texture_rg" 
     "GL_ANGLE_client_arrays" 
     "GL_OES_EGL_image_external_essl3" 
     "GL_OES_compressed_ETC1_RGB8_texture" 
     "GL_OES_vertex_array_object" 
     "GL_ANGLE_framebuffer_multisample" 
     "GL_ANGLE_translated_shader_source" 
     "GL_CHROMIUM_copy_compressed_texture" 
     "GL_OES_depth32" 
     "GL_EXT_draw_buffers" 
     "GL_EXT_color_buffer_half_float" 
     "GL_ANGLE_robust_client_memory" 
     "GL_OES_element_index_uint" 
     "GL_ANGLE_framebuffer_blit" 
     "GL_EXT_blend_minmax" 
     "GL_ANGLE_texture_compression_dxt3" 
     "GL_EXT_texture_compression_dxt1" 
     "GL_EXT_texture_compression_s3tc_srgb" 
     "GL_EXT_texture_filter_anisotropic" 
     "GL_OES_EGL_image_external" 
     "GL_OES_texture_float_linear" 
     "GL_CHROMIUM_copy_texture" 
     "GL_EXT_discard_framebuffer" 
     "GL_OES_texture_npot" 
     "GL_EXT_frag_depth" 
     "GL_EXT_occlusion_query_boolean" 
     "GL_EXT_sRGB" 
     "GL_EXT_texture_format_BGRA8888" 
     "GL_EXT_texture_norm16" 
     "GL_EXT_color_buffer_float" 
     "GL_ANGLE_lossy_etc_decode" 
     "GL_CHROMIUM_color_buffer_float_rgb" 
     "GL_EXT_read_format_bgra" 
     "GL_NV_EGL_stream_consumer_external" 
     "GL_ANGLE_pack_reverse_row_order" 
     "" 
     "GL_EXT_unpack_subimage" 
     "GL_OES_texture_half_float" 
     "GL_ANGLE_depth_texture" 
     "GL_EXT_texture_storage" 
     "GL_EXT_robustness" 
     "GL_NV_fence" 
     "GL_CHROMIUM_color_buffer_float_rgba" 

QPA OpenGL Detection Info 
  supportsDesktopGL: true 
  supportsAngleD3D11: true 
  isQtPreferAngle: true 

Hardware Information
 Memory: 15 Gb
 Cores: 8
 Swap: C:/Users/chris/AppData/Local/Temp
Comment 1 Tiar 2022-01-08 13:05:44 UTC
@Chris Do you have a 4K screen?
I see a super small (1.5-2mm of length?) very thin (<0.5mm) triangle, not a rectangle (the triangle probably has the same shape as the icon says, but it's hard to tell). The size of it might be caused by the fact that I use a 4k screen with 2x scaling.

In any case, I'm marking it as a wish. It's not impossible to use, though it would be better and more accessible (for people with worse eyesight than me, for example) if it was bigger.
Comment 2 Chris 2022-01-09 04:03:33 UTC
Chris: My screen resolution is 3840 X 2160.
The rectangle of broken lines is about 6 mm X 6 mm with no point (i.e. it's not a triangle).
It is usable but not very nice to use.
Comment 3 Bug Janitor Service 2022-01-09 04:35:24 UTC
Thanks for your comment!

Automatically switching the status of this bug to REPORTED so that the KDE team
knows that the bug is ready to get confirmed.

In the future you may also do this yourself when providing needed information.
Comment 4 Chris 2022-02-05 01:54:41 UTC
This issue is a regression. The pointer shape used to be good (in version 4.6 I think).
Comment 5 Guy Bonneau 2022-03-19 15:34:22 UTC
I have the same issue with an LG 5K monitor. If I switch to an HD monitor the issue is gone.
Comment 6 Alvin Wong 2022-04-04 08:46:33 UTC
I suppose the cause is the same as bug 441232
Comment 7 Alvin Wong 2022-04-06 16:31:33 UTC
Git commit 5385d94e70c4c02d578d5df8ba92357a602b2dd1 by Alvin Wong.
Committed on 06/04/2022 at 15:42.
Pushed by alvinwong into branch 'master'.

Convert KoPathTool cursors to XPM

Now these cursors are loaded as QPixmap, which should fix the corrupted
appearance on Windows with high-DPI scaling.

M  +42   -17   libs/flake/tools/KoPathTool.cpp

https://invent.kde.org/graphics/krita/commit/5385d94e70c4c02d578d5df8ba92357a602b2dd1
Comment 8 Alvin Wong 2022-04-06 16:49:52 UTC
Git commit f7554e624be6d5025de98a8e3348ca3a19730df0 by Alvin Wong.
Committed on 06/04/2022 at 15:44.
Pushed by alvinwong into branch 'krita/5.0'.

Convert KoPathTool cursors to XPM

Now these cursors are loaded as QPixmap, which should fix the corrupted
appearance on Windows with high-DPI scaling.
(cherry picked from commit 5385d94e70c4c02d578d5df8ba92357a602b2dd1)

M  +42   -17   libs/flake/tools/KoPathTool.cpp

https://invent.kde.org/graphics/krita/commit/f7554e624be6d5025de98a8e3348ca3a19730df0