Bug 448103 - Can't select linear ramp stops other than the first
Summary: Can't select linear ramp stops other than the first
Status: RESOLVED DUPLICATE of bug 447464
Alias: None
Product: krita
Classification: Unclassified
Component: Tools/Vector (show other bugs)
Version: 5.0.2
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-08 10:53 UTC by Chris
Modified: 2022-01-08 12:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2022-01-08 10:53:30 UTC
SUMMARY

When setting or editing colors in a linear ramp fill of a vector object, only the first (shown on left) stop can be selected

STEPS TO REPRODUCE

1. Create a vector layer and then a vector object (a rectangle object for example) in the layer.
2. Choose the select tool, select the vector object just created, select the gradient fill option.
3. The left hand stop is active by default and its color can easily be edited.
4. Trying to change to the right hand stop either by pressing the > (or <) button (or the tear drop) does NOT change the current stop to the right hand stop.  (A blue outline does briefly appear around the tear drop for the other stop, but it immediately moves back to the left hand stop.)
5. The currently editable remains as the left stop. 

OBSERVED RESULT

Can not select any stop other than the left stop in a linear ramp for editing the linear ramp fill of a vector object in a vector layer.

EXPECTED RESULT

Should be able to select any stop of a linear ramp so its color can be adjusted.

SOFTWARE/OS VERSIONS
Windows: 10
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION

WARNING: The system information file doesn't exist.File name and location: C:/Users/chris/AppData/Local/krita-sysinfo.log

------------------------------------

Krita
  Version: 5.0.2

Qt
  Version (compiled): 5.12.12
  Version (loaded): 5.12.12

OS Information
  Build ABI: x86_64-little_endian-llp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: winnt
  Kernel Version: 10.0.19044
  Pretty Productname: Windows 10 (10.0)
  Product Type: windows
  Product Version: 10


OpenGL Info
 
  Vendor:  "Google Inc." 
  Renderer:  "ANGLE (NVIDIA GeForce MX250 Direct3D11 vs_5_0 ps_5_0)" 
  Version:  "OpenGL ES 3.0 (ANGLE 2.1.0.57ea533f79a7)" 
  Shading language:  "OpenGL ES GLSL ES 3.00 (ANGLE 2.1.0.57ea533f79a7)" 
  Requested format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::CompatibilityProfile) 
  Current format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile) 
     Version: 3.0
     Supports deprecated functions false 
     is OpenGL ES: true 
  supportsBufferMapping: true 
  supportsBufferInvalidation: false 
  Extensions: 
     "GL_EXT_texture_filter_anisotropic" 
     "GL_OES_EGL_image_external" 
     "GL_OES_compressed_ETC1_RGB8_texture" 
     "GL_EXT_color_buffer_float" 
     "GL_EXT_map_buffer_range" 
     "GL_OES_depth32" 
     "GL_OES_texture_half_float_linear" 
     "GL_ANGLE_client_arrays" 
     "GL_ANGLE_framebuffer_multisample" 
     "GL_ANGLE_framebuffer_blit" 
     "GL_CHROMIUM_color_buffer_float_rgba" 
     "GL_ANGLE_translated_shader_source" 
     "GL_CHROMIUM_color_buffer_float_rgb" 
     "GL_EXT_sRGB" 
     "GL_ANGLE_request_extension" 
     "GL_ANGLE_texture_compression_dxt5" 
     "GL_ANGLE_pack_reverse_row_order" 
     "GL_OES_packed_depth_stencil" 
     "GL_NV_pixel_buffer_object" 
     "GL_OES_texture_npot" 
     "GL_ANGLE_texture_compression_dxt3" 
     "" 
     "GL_EXT_texture_compression_dxt1" 
     "GL_OES_surfaceless_context" 
     "GL_OES_mapbuffer" 
     "GL_EXT_frag_depth" 
     "GL_OES_rgb8_rgba8" 
     "GL_EXT_draw_buffers" 
     "GL_EXT_texture_norm16" 
     "GL_ANGLE_texture_usage" 
     "GL_OES_texture_float" 
     "GL_ANGLE_instanced_arrays" 
     "GL_ANGLE_lossy_etc_decode" 
     "GL_OES_texture_float_linear" 
     "GL_KHR_debug" 
     "GL_EXT_unpack_subimage" 
     "GL_ANGLE_depth_texture" 
     "GL_ANGLE_robust_client_memory" 
     "GL_EXT_occlusion_query_boolean" 
     "GL_EXT_color_buffer_half_float" 
     "GL_ANGLE_multiview" 
     "GL_EXT_discard_framebuffer" 
     "GL_NV_fence" 
     "GL_EXT_texture_rg" 
     "GL_OES_vertex_array_object" 
     "GL_EXT_shader_texture_lod" 
     "GL_OES_element_index_uint" 
     "GL_EXT_disjoint_timer_query" 
     "GL_CHROMIUM_sync_query" 
     "GL_EXT_robustness" 
     "GL_EXT_debug_marker" 
     "GL_EXT_texture_storage" 
     "GL_OES_texture_half_float" 
     "GL_EXT_read_format_bgra" 
     "GL_CHROMIUM_bind_generates_resource" 
     "GL_OES_EGL_image_external_essl3" 
     "GL_OES_get_program_binary" 
     "GL_CHROMIUM_copy_texture" 
     "GL_EXT_texture_compression_s3tc_srgb" 
     "GL_NV_pack_subimage" 
     "GL_OES_standard_derivatives" 
     "GL_EXT_blend_minmax" 
     "GL_ANGLE_program_cache_control" 
     "GL_OES_EGL_image" 
     "GL_NV_EGL_stream_consumer_external" 
     "GL_CHROMIUM_copy_compressed_texture" 
     "GL_CHROMIUM_bind_uniform_location" 
     "GL_EXT_texture_format_BGRA8888" 

QPA OpenGL Detection Info 
  supportsDesktopGL: true 
  supportsAngleD3D11: true 
  isQtPreferAngle: true 

Hardware Information
 Memory: 15 Gb
 Cores: 8
 Swap: C:/Users/chris/AppData/Local/Temp

-------------------

WARNING: The Krita usage log file doesn't exist.File name and location: C:/Users/chris/AppData/Local/krita.log------------------------------------

Krita
  Version: 5.0.2

Qt
  Version (compiled): 5.12.12
  Version (loaded): 5.12.12

OS Information
  Build ABI: x86_64-little_endian-llp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: winnt
  Kernel Version: 10.0.19044
  Pretty Productname: Windows 10 (10.0)
  Product Type: windows
  Product Version: 10


OpenGL Info
 
  Vendor:  "Google Inc." 
  Renderer:  "ANGLE (NVIDIA GeForce MX250 Direct3D11 vs_5_0 ps_5_0)" 
  Version:  "OpenGL ES 3.0 (ANGLE 2.1.0.57ea533f79a7)" 
  Shading language:  "OpenGL ES GLSL ES 3.00 (ANGLE 2.1.0.57ea533f79a7)" 
  Requested format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::CompatibilityProfile) 
  Current format:  QSurfaceFormat(version 3.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 0, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile) 
     Version: 3.0
     Supports deprecated functions false 
     is OpenGL ES: true 
  supportsBufferMapping: true 
  supportsBufferInvalidation: false 
  Extensions: 
     "GL_EXT_texture_filter_anisotropic" 
     "GL_OES_EGL_image_external" 
     "GL_OES_compressed_ETC1_RGB8_texture" 
     "GL_EXT_color_buffer_float" 
     "GL_EXT_map_buffer_range" 
     "GL_OES_depth32" 
     "GL_OES_texture_half_float_linear" 
     "GL_ANGLE_client_arrays" 
     "GL_ANGLE_framebuffer_multisample" 
     "GL_ANGLE_framebuffer_blit" 
     "GL_CHROMIUM_color_buffer_float_rgba" 
     "GL_ANGLE_translated_shader_source" 
     "GL_CHROMIUM_color_buffer_float_rgb" 
     "GL_EXT_sRGB" 
     "GL_ANGLE_request_extension" 
     "GL_ANGLE_texture_compression_dxt5" 
     "GL_ANGLE_pack_reverse_row_order" 
     "GL_OES_packed_depth_stencil" 
     "GL_NV_pixel_buffer_object" 
     "GL_OES_texture_npot" 
     "GL_ANGLE_texture_compression_dxt3" 
     "" 
     "GL_EXT_texture_compression_dxt1" 
     "GL_OES_surfaceless_context" 
     "GL_OES_mapbuffer" 
     "GL_EXT_frag_depth" 
     "GL_OES_rgb8_rgba8" 
     "GL_EXT_draw_buffers" 
     "GL_EXT_texture_norm16" 
     "GL_ANGLE_texture_usage" 
     "GL_OES_texture_float" 
     "GL_ANGLE_instanced_arrays" 
     "GL_ANGLE_lossy_etc_decode" 
     "GL_OES_texture_float_linear" 
     "GL_KHR_debug" 
     "GL_EXT_unpack_subimage" 
     "GL_ANGLE_depth_texture" 
     "GL_ANGLE_robust_client_memory" 
     "GL_EXT_occlusion_query_boolean" 
     "GL_EXT_color_buffer_half_float" 
     "GL_ANGLE_multiview" 
     "GL_EXT_discard_framebuffer" 
     "GL_NV_fence" 
     "GL_EXT_texture_rg" 
     "GL_OES_vertex_array_object" 
     "GL_EXT_shader_texture_lod" 
     "GL_OES_element_index_uint" 
     "GL_EXT_disjoint_timer_query" 
     "GL_CHROMIUM_sync_query" 
     "GL_EXT_robustness" 
     "GL_EXT_debug_marker" 
     "GL_EXT_texture_storage" 
     "GL_OES_texture_half_float" 
     "GL_EXT_read_format_bgra" 
     "GL_CHROMIUM_bind_generates_resource" 
     "GL_OES_EGL_image_external_essl3" 
     "GL_OES_get_program_binary" 
     "GL_CHROMIUM_copy_texture" 
     "GL_EXT_texture_compression_s3tc_srgb" 
     "GL_NV_pack_subimage" 
     "GL_OES_standard_derivatives" 
     "GL_EXT_blend_minmax" 
     "GL_ANGLE_program_cache_control" 
     "GL_OES_EGL_image" 
     "GL_NV_EGL_stream_consumer_external" 
     "GL_CHROMIUM_copy_compressed_texture" 
     "GL_CHROMIUM_bind_uniform_location" 
     "GL_EXT_texture_format_BGRA8888" 

QPA OpenGL Detection Info 
  supportsDesktopGL: true 
  supportsAngleD3D11: true 
  isQtPreferAngle: true 

Hardware Information
 Memory: 15 Gb
 Cores: 8
 Swap: C:/Users/chris/AppData/Local/Temp
Comment 1 Tiar 2022-01-08 12:56:26 UTC

*** This bug has been marked as a duplicate of bug 447464 ***