Bug 448091 - KDE Plasma can't change Display Resolution on Wayland
Summary: KDE Plasma can't change Display Resolution on Wayland
Status: RESOLVED INTENTIONAL
Alias: None
Product: KScreen
Classification: Unclassified
Component: Plasma Applet (show other bugs)
Version: 5.23.5
Platform: Kubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: kscreen-bugs-null@kde.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-07 21:28 UTC by Caio Fratelli
Modified: 2022-01-13 19:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caio Fratelli 2022-01-07 21:28:11 UTC
SUMMARY
I can't seem to change resolution on Wayland after 5.23.5 update, it's stuck on 3840x2160 and all I can change is the scale.
However I wanted to switch to 2,880x1,800 resolution which should go easy on my GPU and then use the scale from that specific resolution, which seems not to be possible.

STEPS TO REPRODUCE
1. Open System Settings
2. Open Display Configurations
3. Try to Change the resolution from the Drop-Down List

OBSERVED RESULT
There are no other options on the drop-down menu

EXPECTED RESULT
It should have some options to the drop-down menu (at least the HiDPI ones)

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Kubuntu 21.10
(available in About System)
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Installed via recommended Kubuntu backports.
Comment 1 Nate Graham 2022-01-13 02:47:34 UTC
This is expected; on Wayland the only supported resolution are the ones advertised by the display manufacturer. The fact that you only see an option for 3840x2160 means that the display manufacturer only claims that the display supports the 3840x2160 resolution.

On X11, the X server made up its own resolutions that you could switch to, but these were never formally supported or guaranteed to work and are not supported on Wayland.

In Plasma 5.24, there's a little info box that explains all of this to you. :)
Comment 2 Caio Fratelli 2022-01-13 05:18:46 UTC
I see Nate.
So would Windows also makes its own resolutions and assumes all of 'em are going to work? Because I can switch resolution (with windows).
Also, all resolutions that I see on xrandr are actually just made up? 
You see, I'm not using an unknown hardware combination from a random manufacturer... I'm using a Dell XPS 9560, so I would expect it to have good compatibility with any protocol and any desktop environment.
But you told me this is a wayland restriction, so would it be better to be  reported there?

Thank you.
Comment 3 Nate Graham 2022-01-13 15:52:10 UTC
(In reply to Caio Fratelli from comment #2)
> I see Nate.
> So would Windows also makes its own resolutions and assumes all of 'em are
> going to work? Because I can switch resolution (with windows).
Yes.

> Also, all resolutions that I see on xrandr are actually just made up? 
Indeed.

> You see, I'm not using an unknown hardware combination from a random
> manufacturer... I'm using a Dell XPS 9560, so I would expect it to have good
> compatibility with any protocol and any desktop environment.
> But you told me this is a wayland restriction, so would it be better to be 
> reported there?
It's not a restriction; more like the lack of a feature. On X11, the X server injected these additional resolutions itself. On Wayland, there is no X server; each compositor (e.g. KWin and Mutter) is its own display server. So it would be up to each individual compositor to do this, and there's no reason why they can't. There are two ways it could be done:
1. Each display server implements the feature itself--or not--according to how its developers thinks it should be implemented
2. A standard Wayland protocol to govern such a thing is written, and then any and all compositors that care to would implement that protocol according to its spec

To my knowledge, the KWin developers have not expressed enthusiasm about implementing this feature in KWin. Feel free to flie another bug report explicitly asking for this as a feature request, but don't get your hopes up. :)
Comment 4 Caio Fratelli 2022-01-13 18:56:13 UTC
Now it's clear for me.
Thank you so much!!
Comment 5 Nate Graham 2022-01-13 19:37:28 UTC
You're welcome!