Bug 447977 - Blurry checkbox and radio buttons with certain fonts/font sizes
Summary: Blurry checkbox and radio buttons with certain fonts/font sizes
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Unclassified
Component: components (show other bugs)
Version: 5.92.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: visual-design
URL:
Keywords:
: 449864 452314 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-05 14:55 UTC by aronkvh
Modified: 2022-04-06 20:13 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.94


Attachments
screenshot (6.25 KB, image/png)
2022-01-05 14:55 UTC, aronkvh
Details
fonts (19.70 KB, image/png)
2022-01-05 20:13 UTC, aronkvh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aronkvh 2022-01-05 14:55:44 UTC
Created attachment 145132 [details]
screenshot

The bottom of the radio buttons is cut off and they look blurry.

Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-25-generic (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-3770 CPU @ 3.40GHz
Memory: 27,1 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4000
Comment 1 Nate Graham 2022-01-05 20:00:56 UTC
Are you using fractional scaling? What's your scale factor?
Comment 2 aronkvh 2022-01-05 20:01:39 UTC
(In reply to Nate Graham from comment #1)
> Are you using fractional scaling? What's your scale factor?

my global scale is the default 100%
Comment 3 Nate Graham 2022-01-05 20:03:06 UTC
Huh, that's not what I was expecting. Are you using a non-default font or font size? Does it go away if you run:

rm ~/.cache/*plasma* ; killall plasmashell ; kstart5 plasmashell

?
Comment 4 aronkvh 2022-01-05 20:05:40 UTC
(In reply to Nate Graham from comment #3)
> Huh, that's not what I was expecting. Are you using a non-default font or
> font size? Does it go away if you run:
> 
> rm ~/.cache/*plasma* ; killall plasmashell ; kstart5 plasmashell
> 
> ?

It didn't
Comment 5 Nate Graham 2022-01-05 20:06:52 UTC
How odd. No idea what could be causing this.
Comment 6 aronkvh 2022-01-05 20:07:18 UTC
(In reply to Nate Graham from comment #3)
> Huh, that's not what I was expecting. Are you using a non-default font or
> font size? 

I was using Montserrat 10p. it goes away after resetting default font settings
Comment 7 Nate Graham 2022-01-05 20:09:42 UTC
Is Montserrat 10p significantly shorter than Noto Sans 10pt?
Comment 8 aronkvh 2022-01-05 20:13:46 UTC
Created attachment 145144 [details]
fonts
Comment 9 aronkvh 2022-01-05 20:14:14 UTC
(In reply to Nate Graham from comment #7)
> Is Montserrat 10p significantly shorter than Noto Sans 10pt?

no, it's actually a bit less condensed
Comment 10 Nate Graham 2022-04-06 18:23:53 UTC
*** Bug 452314 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2022-04-06 18:27:02 UTC
*** Bug 449864 has been marked as a duplicate of this bug. ***
Comment 12 Noah Davis 2022-04-06 18:46:03 UTC
(In reply to aronkvh from comment #9)
> (In reply to Nate Graham from comment #7)
> > Is Montserrat 10p significantly shorter than Noto Sans 10pt?
> 
> no, it's actually a bit less condensed

He means height, not line length
Comment 13 Noah Davis 2022-04-06 20:11:27 UTC
Git commit bd1ba6e539a326585a24fc21d0e27ef2c59e8731 by Noah Davis.
Committed on 06/04/2022 at 19:11.
Pushed by ndavis into branch 'master'.

PC3 toggle controls: fix odd heights misaligning indicators

M  +1    -1    src/declarativeimports/plasmacomponents3/CheckBox.qml
M  +1    -1    src/declarativeimports/plasmacomponents3/CheckDelegate.qml
M  +1    -1    src/declarativeimports/plasmacomponents3/MenuItem.qml
M  +1    -1    src/declarativeimports/plasmacomponents3/RadioButton.qml
M  +1    -1    src/declarativeimports/plasmacomponents3/RadioDelegate.qml
M  +1    -1    src/declarativeimports/plasmacomponents3/Switch.qml
M  +1    -1    src/declarativeimports/plasmacomponents3/SwitchDelegate.qml

https://invent.kde.org/frameworks/plasma-framework/commit/bd1ba6e539a326585a24fc21d0e27ef2c59e8731