Bug 447876 - [Wayland] Using window rules to pin windows to specific virtual desktops causes "ghost" windows to appear on the pager
Summary: [Wayland] Using window rules to pin windows to specific virtual desktops caus...
Status: RESOLVED DUPLICATE of bug 452171
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-03 13:08 UTC by Francisco Pina Martins
Modified: 2022-06-18 09:12 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
A screenshot showing the window rules' settings that cause the issue (62.31 KB, image/png)
2022-01-03 13:08 UTC, Francisco Pina Martins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Pina Martins 2022-01-03 13:08:40 UTC
Created attachment 145076 [details]
A screenshot showing the window rules' settings that cause the issue

SUMMARY
***
I have setup "Window Rules" so that some of my apps are "restricted" to a specific virtual desktop, eg. Firefox to Virtual Desktop 3 (screenshot attached).
Under X11, if I am on Virtual Desktop 1, and launch firefox, all firefox windows are launched in Virtual Desktop 3, which is reflected on the pager panel widget. This is the expected behavior. Doing so under wayland, however, results in firefox windows launching on Virtual Desktop 3, but a "ghost" window also appearing on the virtual desktop I have launched it from. Moving the "ghost" window in the pager to a different Virtual Desktop results in moving the actual window there. A  "ghost" window remains on the pager where the actual window actually was. Moving the actual window using the pager does not remove the "ghost" window.
***


STEPS TO REPRODUCE
1. Create multiple Virtual Desktops and activate the pager widget
2. Set window rules as in the attached screenshot
3. Log in using a wayland session
4. Launch firefox from Virtual Desktop 1
5. Watch how the pager widget makes firefox show up on both Virtual Desktops, even though the window only exists on Virtual Desktop 3
6. This does not occur under X11

OBSERVED RESULT
When window rules are active under a wayland session, the pager makes copies of windows on the wrong virtual desktops

EXPECTED RESULT
The pager widget displays the windows only on the desktop they currently exist in, just like in a X11 session.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
I can reproduce the issue on two independent systems
Comment 1 Paul Worrall 2022-01-03 17:11:26 UTC
Confirmed with KDE Neon Unstable.

I also note that the task manager shows the task on both desktops despite being set to show tasks only from the current desktop.  Possibly another manifestation of the same underlying bug?

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-43-generic (64-bit)
Graphics Platform: Wayland
Processors: 2 × AMD A6-6400K APU with Radeon(tm) HD Graphics
Memory: 7.7 GiB of RAM
Graphics Processor: AMD CEDAR
Comment 2 s.h. 2022-04-23 09:25:38 UTC
Hi,
I can confirm this bug is still present:
Fedora 35
Plasma 5.24.4
Framework 5.91.0
Qt 5.15.2
Kernel Version: 5.16.20-200.fc35.x86_64
Graphics Platform: Wayland
Processor: AMD Ryzen 2700
Memory: 32 GiB of RAM
Graphics Processor: AMD RX5500XT (AMDGPU Kernel Driver)
Comment 3 Ismael Asensio 2022-06-18 09:07:49 UTC

*** This bug has been marked as a duplicate of bug 455237 ***
Comment 4 Ismael Asensio 2022-06-18 09:12:34 UTC

*** This bug has been marked as a duplicate of bug 452171 ***