Bug 447771 - “Shortcut Schemes” doesn’t change the keybindings
Summary: “Shortcut Schemes” doesn’t change the keybindings
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: 5.0.0
Platform: Compiled Sources Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords: regression
: 447716 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-01 12:02 UTC by gunpowderfans
Modified: 2022-01-02 14:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gunpowderfans 2022-01-01 12:02:21 UTC
SUMMARY
“Shortcut Schemes” doesn’t change the keybindings

STEPS TO REPRODUCE
1. Open "Configure Krita" window from "Settings" on toolbar.
2. Select "Keyboard Shortcuts" tab from the left.
3. Change "Shortcut Schemes" from "Default" to "photoshop_compatible".

OBSERVED RESULT
Shortcut keys doesn't change.

EXPECTED RESULT
Some of the shortcut keys should be changed. For example, "move" tool's shortcut key should be "v".

SOFTWARE/OS VERSIONS
Windows 10 20H2
Comment 1 Ahab Greybeard 2022-01-01 12:34:35 UTC
I can Confirm this for the Move tool with 5.0.0 and the Dec 21 5.1.0-prealpha (gitac1d8bd) appimages on Debian 10.

It was introduced in 5.0.0-beta1 and is a regression wrt 4.4.8.
Comment 2 Lynx3d 2022-01-01 21:27:09 UTC
*** Bug 447716 has been marked as a duplicate of this bug. ***
Comment 3 Lynx3d 2022-01-02 14:07:42 UTC
Git commit fb3b7be99f9866867d3d9466fb06afbc5e52915f by Mathias Wein.
Committed on 02/01/2022 at 14:05.
Pushed by mwein into branch 'krita/5.0.0'.

Fix photoshop_compatible.shortcuts

Looks like a string got pasted unintentionally.
(cherry picked from commit 79911ed638154fe9606317c9352a85f45c89e2d0)

M  +1    -1    krita/data/shortcuts/photoshop_compatible.shortcuts

https://invent.kde.org/graphics/krita/commit/fb3b7be99f9866867d3d9466fb06afbc5e52915f
Comment 4 Lynx3d 2022-01-02 14:07:51 UTC
Git commit 79911ed638154fe9606317c9352a85f45c89e2d0 by Mathias Wein.
Committed on 02/01/2022 at 14:02.
Pushed by mwein into branch 'master'.

Fix photoshop_compatible.shortcuts

Looks like a string got pasted unintentionally.

M  +1    -1    krita/data/shortcuts/photoshop_compatible.shortcuts

https://invent.kde.org/graphics/krita/commit/79911ed638154fe9606317c9352a85f45c89e2d0
Comment 5 Lynx3d 2022-01-02 14:09:49 UTC
Git commit 255f29d0438013f69086b6223c36543c2cc5ae9a by Mathias Wein.
Committed on 02/01/2022 at 14:09.
Pushed by mwein into branch 'krita/5.0'.

Fix photoshop_compatible.shortcuts

Looks like a string got pasted unintentionally.
(cherry picked from commit 79911ed638154fe9606317c9352a85f45c89e2d0)

M  +1    -1    krita/data/shortcuts/photoshop_compatible.shortcuts

https://invent.kde.org/graphics/krita/commit/255f29d0438013f69086b6223c36543c2cc5ae9a