Bug 447749 - Copied the firefox profile to USB-stick
Summary: Copied the firefox profile to USB-stick
Status: RESOLVED DUPLICATE of bug 427945
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.23.4
Platform: openSUSE RPMs Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-12-31 17:41 UTC by wodenhof
Modified: 2022-01-12 01:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wodenhof 2021-12-31 17:41:41 UTC
Application: plasmashell (5.23.4)

Qt Version: 5.15.2
Frameworks Version: 5.89.0
Operating System: Linux 5.15.8-1-default x86_64
Windowing System: X11
Distribution: openSUSE Tumbleweed
DrKonqi: 5.23.4 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
Copied the firefox profile to USB-stick, when umounting it the crash happened.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  0x00007fb68b988614 in QQmlJavaScriptExpression::~QQmlJavaScriptExpression() (this=0x5587f95bfdb0, __in_chrg=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/qml/qml/qqmljavascriptexpression.cpp:107
#7  0x00007fb68b99177f in non-virtual thunk to GenericBinding<2>::~GenericBinding() () at /lib64/libQt5Qml.so.5
#8  0x00007fb68b91e94e in QQmlData::destroyed(QObject*) (this=0x5587f7daa4b8, object=0x5587f7daa490) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/qml/qml/qqmlengine.cpp:1895
#9  0x00007fb68a36a2a1 in QObject::~QObject() (this=this@entry=0x5587f7daa490, __in_chrg=<optimized out>) at kernel/qobject.cpp:1001
#10 0x00007fb68bd24372 in QQuickAbstractAnimation::~QQuickAbstractAnimation() (this=this@entry=0x5587f7daa490, __in_chrg=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/util/qquickanimation.cpp:96
#11 0x00007fb68bd24428 in QQuickPauseAnimation::~QQuickPauseAnimation() (this=this@entry=0x5587f7daa490, __in_chrg=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/util/qquickanimation.cpp:719
#12 0x00007fb68bfd306d in QQmlPrivate::QQmlElement<QQuickPauseAnimation>::~QQmlElement() (this=0x5587f7daa490, __in_chrg=<optimized out>) at ../../include/QtQml/../../../src/qml/qml/qqmlprivate.h:144
#13 QQmlPrivate::QQmlElement<QQuickPauseAnimation>::~QQmlElement() (this=0x5587f7daa490, __in_chrg=<optimized out>) at ../../include/QtQml/../../../src/qml/qml/qqmlprivate.h:144
#14 0x00007fb68a35fa5e in QObjectPrivate::deleteChildren() (this=0x5587f8ae1a50) at kernel/qobject.cpp:2104
#15 0x00007fb68a36a5c4 in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1082
#16 0x00007fb68bd24372 in QQuickAbstractAnimation::~QQuickAbstractAnimation() (this=<optimized out>, __in_chrg=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/util/qquickanimation.cpp:96
#17 0x00007fb68bd24701 in QQuickSequentialAnimation::~QQuickSequentialAnimation() (this=this@entry=0x5587f95c4ca0, __in_chrg=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/util/qquickanimation.cpp:1831
#18 0x00007fb68bfd2eed in QQmlPrivate::QQmlElement<QQuickSequentialAnimation>::~QQmlElement() (this=0x5587f95c4ca0, __in_chrg=<optimized out>) at ../../include/QtQml/../../../src/qml/qml/qqmlprivate.h:144
#19 QQmlPrivate::QQmlElement<QQuickSequentialAnimation>::~QQmlElement() (this=0x5587f95c4ca0, __in_chrg=<optimized out>) at ../../include/QtQml/../../../src/qml/qml/qqmlprivate.h:144
#20 0x00007fb68a35fa5e in QObjectPrivate::deleteChildren() (this=0x5587f86561c0) at kernel/qobject.cpp:2104
#21 0x00007fb68a36a5c4 in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1082
#22 0x00007fb68bd24372 in QQuickAbstractAnimation::~QQuickAbstractAnimation() (this=<optimized out>, __in_chrg=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/util/qquickanimation.cpp:96
#23 0x00007fb68bd24778 in QQuickParallelAnimation::~QQuickParallelAnimation() (this=this@entry=0x5587f98ebac0, __in_chrg=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/util/qquickanimation.cpp:1920
#24 0x00007fb68bfd2d6d in QQmlPrivate::QQmlElement<QQuickParallelAnimation>::~QQmlElement() (this=0x5587f98ebac0, __in_chrg=<optimized out>) at ../../include/QtQml/../../../src/qml/qml/qqmlprivate.h:144
#25 QQmlPrivate::QQmlElement<QQuickParallelAnimation>::~QQmlElement() (this=0x5587f98ebac0, __in_chrg=<optimized out>) at ../../include/QtQml/../../../src/qml/qml/qqmlprivate.h:144
#26 0x00007fb68a35fa5e in QObjectPrivate::deleteChildren() (this=0x5587f9720740) at kernel/qobject.cpp:2104
#27 0x00007fb68a36a5c4 in QObject::~QObject() (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:1082
#28 0x00007fb68bd24372 in QQuickAbstractAnimation::~QQuickAbstractAnimation() (this=<optimized out>, __in_chrg=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/util/qquickanimation.cpp:96
#29 0x00007fb68bd24778 in QQuickParallelAnimation::~QQuickParallelAnimation() (this=this@entry=0x5587f7d93b20, __in_chrg=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/util/qquickanimation.cpp:1920
#30 0x00007fb68bfd2d6d in QQmlPrivate::QQmlElement<QQuickParallelAnimation>::~QQmlElement() (this=0x5587f7d93b20, __in_chrg=<optimized out>) at ../../include/QtQml/../../../src/qml/qml/qqmlprivate.h:144
#31 QQmlPrivate::QQmlElement<QQuickParallelAnimation>::~QQmlElement() (this=0x5587f7d93b20, __in_chrg=<optimized out>) at ../../include/QtQml/../../../src/qml/qml/qqmlprivate.h:144
#32 0x00007fb68a3620df in QObject::event(QEvent*) (this=0x5587f7d93b20, e=0x7fb680020bb0) at kernel/qobject.cpp:1301
#33 0x00007fb68b0d1a7f in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x5587f7d93b20, e=0x7fb680020bb0) at kernel/qapplication.cpp:3632
#34 0x00007fb68a335d2a in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x5587f7d93b20, event=0x7fb680020bb0) at kernel/qcoreapplication.cpp:1064
#35 0x00007fb68a338d77 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=0x0, event_type=0, data=0x5587f6d830a0) at kernel/qcoreapplication.cpp:1821
#36 0x00007fb68a38db83 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=s@entry=0x5587f6e83af0) at kernel/qeventdispatcher_glib.cpp:277
#37 0x00007fb688646d9f in g_main_dispatch (context=0x7fb680005000) at ../glib/gmain.c:3381
#38 g_main_context_dispatch (context=0x7fb680005000) at ../glib/gmain.c:4099
#39 0x00007fb688647128 in g_main_context_iterate (context=context@entry=0x7fb680005000, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#40 0x00007fb6886471df in g_main_context_iteration (context=0x7fb680005000, may_block=1) at ../glib/gmain.c:4240
#41 0x00007fb68a38d204 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x5587f6e7f2c0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#42 0x00007fb68a33472b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffde2685440, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#43 0x00007fb68a33ca10 in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#44 0x00007fb68a78619c in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1867
#45 0x00007fb68b0d19f5 in QApplication::exec() () at kernel/qapplication.cpp:2824
#46 0x00005587f637b3e6 in main(int, char**) (argc=<optimized out>, argv=0x7ffde2685600) at /usr/src/debug/plasma5-workspace-5.23.4-1.1.x86_64/shell/main.cpp:238
[Inferior 1 (process 12912) detached]

Possible duplicates by query: bug 447647, bug 447605, bug 447548, bug 447515, bug 447407.

Reported using DrKonqi
Comment 1 Nate Graham 2022-01-12 01:30:13 UTC

*** This bug has been marked as a duplicate of bug 427945 ***