Bug 447679 - KHamburgermenu doesn't respect menu transparency setting
Summary: KHamburgermenu doesn't respect menu transparency setting
Status: RESOLVED WORKSFORME
Alias: None
Product: frameworks-kconfigwidgets
Classification: Unclassified
Component: general (show other bugs)
Version: 5.89.0
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-30 07:42 UTC by deresiant
Modified: 2022-05-21 16:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Image of bugged transparency in menu (280.24 KB, image/png)
2021-12-30 07:42 UTC, deresiant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deresiant 2021-12-30 07:42:36 UTC
Created attachment 144952 [details]
Image of bugged transparency in menu

SUMMARY
I found that one specific menu doesn't have compositing. I have not yet found any other menu like, I have attached an image with what I am referring to. The second menu has transparency working just fine, the first menu however does not seem to have compositing, or at least it does not have transparency. I'm not sure if this is a dolphin or Kwin bug.

STEPS TO REPRODUCE
Not sure what caused this. It seems to be a "just me" thing
1. Enable transparency with in a theme with transparency effects, like default breeze-dark.
2. Open dolphin's menu

OBSERVED RESULT
No transparency in menu

EXPECTED RESULT
There should be transparency in the menu

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.11-arch2-1 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2

ADDITIONAL INFORMATION
I do not remember changing any settings when this happened. It was working fine before. I have been using systemd startup for a couple months but this only started happening a week or so ago. I don't think they are related
Comment 1 Nate Graham 2022-01-12 01:03:28 UTC
Cannot reproduce in the Plasma Wayland session with current git master.
Comment 2 deresiant 2022-05-21 09:42:33 UTC
Fixed itself. Not sure when
Comment 3 Felix Ernst 2022-05-21 16:41:06 UTC
Good news!