Bug 447670 - KWin Zoom effect glitches on blurry background of applets
Summary: KWin Zoom effect glitches on blurry background of applets
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-various (show other bugs)
Version: git master
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 241557 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-12-29 22:57 UTC by ratijas
Modified: 2022-05-29 11:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments
Demonstation of this zooming bug (2.99 MB, video/mp4)
2021-12-29 22:57 UTC, ratijas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ratijas 2021-12-29 22:57:19 UTC
Created attachment 144947 [details]
Demonstation of this zooming bug

SUMMARY

Blurry background is broken with Zoom KWin effect.

STEPS TO REPRODUCE
1. Open any applet from system tray (Show hidden icons works too)
2. Zoom in (Meta++), assuming the default "Zoom" variant — not a Magnifier, nor a Looking Glass.
3. Move cursor around

OBSERVED RESULT

Background is misrendered: sometimes as mis-positioned blur (as if it follows the direction opposite to the cursor's movements), in other cases it may not even be blurred at all.

EXPECTED RESULT

Should not glitch like that.

SOFTWARE/OS VERSIONS

Operating System: Arch Linux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.15.11-arch2-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 970M/PCIe/SSE2
Comment 1 Vlad Zahorodnii 2022-05-24 13:11:53 UTC
Git commit 544760469dd4fd7550fc7121250e694a485d453f by Vlad Zahorodnii.
Committed on 24/05/2022 at 13:11.
Pushed by vladz into branch 'Plasma/5.25'.

effects/zoom: Render scene in an offscreen texture

This fixes integration of the zoom effect with the blur effect and qtquick
effects such as overview or window view.

The main con of the proposed solution is that offscreen rendering can be
a bit overkill. But on the other hand, it's the most robust way to
ensure that fullscreen effects integrate correctly with the zoom effect.
For example, without it, the quick scene effect would need to figure out
what screen views to paint for the given screen. There are also more
finicky cases, e.g. the screen transform effect.
Related: bug 447002, bug 453467
Tested-by: Merge Service <https://invent.kde.org/plasma/kwin/-/merge_requests/2451>
Part-of: <https://invent.kde.org/plasma/kwin/-/merge_requests/2451>


(cherry picked from commit 221f114d8045f22eca722a4ce385367f4c3f03fc)

M  +100  -24   src/effects/zoom/zoom.cpp
M  +13   -0    src/effects/zoom/zoom.h

https://invent.kde.org/plasma/kwin/commit/544760469dd4fd7550fc7121250e694a485d453f
Comment 2 ratijas 2022-05-24 13:18:12 UTC
OMG, this is so cool! Can't wait to get home and test it out. Thanks!
Comment 3 AGui 2022-05-28 16:22:57 UTC
Is this also resolving this bug I reported in 2010 for KDE 4.5 ?
https://bugs.kde.org/show_bug.cgi?id=241557
That would be awesome!
Comment 4 ratijas 2022-05-28 22:41:54 UTC
> Is this also resolving this bug I reported in 2010 for KDE 4.5 ?
> https://bugs.kde.org/show_bug.cgi?id=241557

Looks like it. Although to be honest, I never experienced such a hard glitch as left-lover image trail on the first screenshot. Mind if we mark it as #resolved #fixed or #duplicate regardless?
Comment 5 AGui 2022-05-29 11:06:00 UTC
*** Bug 241557 has been marked as a duplicate of this bug. ***