Bug 447556 - Some wayland native games in KDE 5.23.4 crash instantly on startup
Summary: Some wayland native games in KDE 5.23.4 crash instantly on startup
Status: RESOLVED NOT A BUG
Alias: None
Product: kwin
Classification: Unclassified
Component: wayland-generic (show other bugs)
Version: 5.23.4
Platform: Flatpak Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: usability, wayland
Depends on:
Blocks:
 
Reported: 2021-12-27 00:48 UTC by p d
Modified: 2022-01-10 08:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p d 2021-12-27 00:48:00 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***

This is a continuation of https://bugs.kde.org/show_bug.cgi?id=444962 , in KDE 5.23.4 using Intel HD Graphics 620 on Wayland, some wayland native games like Xonotic flatpak crash instantly on startup. Disabling the wayland socket via flatseal solves the issue. I ran the flatpak with --socket=wayland to reproduce the issue, because I already disabled the wayland socket to workaround the issue. The xonotic flatpak ships with wayland enabled.


STEPS TO REPRODUCE
1. Be on Intel HD Graphics and use KDE 5.23.4 wayland session
2. Install Xonotic from flathub and make sure wayland support is enabled in flatseal
3. The game will crash instantly upon launch

This happens with other wayland native games such as SuperTuxKart on flathub.

The behavior was different in previous KDE versions. In KDE 5.23.3, they launched, but the windows were invisible. In KDE 5.23.2, they launched in the corner of the screen.

OBSERVED RESULT

Wayland native games (not using xwayland) crash instantly on startup

EXPECTED RESULT

For them to work.

SOFTWARE/OS VERSIONS

Operating System: Fedora Linux 35
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.11-200.fc35.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-7300U CPU @ 2.60GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 620

ADDITIONAL INFORMATION

xonotic shows this in the logs

Linked against SDL version 2.0.16
Using SDL library version 2.0.16
GL_VENDOR: Intel
GL_RENDERER: Mesa Intel(R) HD Graphics 620 (KBL GT2)
GL_VERSION: 4.6 (Compatibility Profile) Mesa 21.3.1 (git-9da08702b0)
vid.support.arb_multisample 1
vid.support.gl20shaders 1
NOTE: requested 1x AA, got 0x AA
Video Mode: fullscreen 1920x1080x32x0.00hz
xdg_surface@30: error -1: invalid window geometry size (0x0)
Comment 1 David Edmundson 2022-01-09 21:28:55 UTC
>xdg_surface@30: error -1: invalid window geometry size (0x0)


Please report to Xonotic. The message shows the client has requested something illegal and been killed for it.
Comment 2 David Edmundson 2022-01-09 21:29:13 UTC
If it's SDL this is fixed already
Comment 3 Vlad Zahorodnii 2022-01-10 08:48:10 UTC
or update to kwin 5.23.5