Bug 447488 - Window rule for an application to be on a specific monitor is not applied when opening this monitor
Summary: Window rule for an application to be on a specific monitor is not applied whe...
Status: RESOLVED DUPLICATE of bug 409979
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_kwinrules (show other bugs)
Version: 5.22.5
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-24 18:34 UTC by tata668
Modified: 2022-01-28 21:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tata668 2021-12-24 18:34:15 UTC
SUMMARY

I want an  application to stay on my main monitor. I created a Window Rule with the property "Screen", a value of "0" and the "Force" option. 

When I apply this rule manually (during creation), if the application is on my second monitor, it is properly moved to my main monitor ("0").

The problem:

When I close my main monitor, the application is moved to my second monitor, this is ok. But when I open back my main monitor, the  rule is not triggered and the application is not moved to my main monitor as I want it to be.


STEPS TO REPRODUCE
1. Have two monitors. My main monitor ("0") is a Dell external monitor and my second is the monitor of my laptop.
2. Create a Window Rule with the property "Screen", a value of "0" and the "Force" option for a specific application.
3. Close the main monitor. The application is move to the second monitor. This is ok.
4. Reopen the main monitor. The application is not moved back to the main monitor.

OBSERVED RESULT

The application specified in the rule is not moved to the main monitor.

EXPECTED RESULT

The application specified in the rule is moved to the main monitor.

SOFTWARE/OS VERSIONS

KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Comment 1 Bug Janitor Service 2022-01-04 15:06:02 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/1840
Comment 2 Ismael Asensio 2022-01-28 21:21:13 UTC

*** This bug has been marked as a duplicate of bug 409979 ***