Bug 447313 - Input goes to the wrong application launcher instance
Summary: Input goes to the wrong application launcher instance
Status: RESOLVED DUPLICATE of bug 443131
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.23.4
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-21 00:30 UTC by Mickaël Thomas
Modified: 2021-12-27 08:57 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mickaël Thomas 2021-12-21 00:30:37 UTC
SUMMARY
With multiple instances of the application launcher applet (eg one on each screen, but also happens with two instances on a single panel), it's possible for typed text to go in the search box for the other menu (while it's hidden). It seems that there is always one primary menu that always gets the input even if it isn't the one currently being shown.


STEPS TO REPRODUCE
1. Create two instances of the application menu widget (can be on the same panel or another)
2. Click the first one and type some text
3. Close the first one, open the second one, type some text again
4. Repeat 2 and 3 if the bug doesn't occur right away

OBSERVED RESULT
Sometimes the text goes in the other hidden menu instance, while the visible one doesn't react at all.
Clicking the other shows that the search box has text in it and a text cursor showing it has focus.


EXPECTED RESULT
The typed text should go into the currently visible instance of the application menu


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: ArchLinux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.12.2

ADDITIONAL INFORMATION
N/A
Comment 1 Nico Lynzaad 2021-12-27 08:57:18 UTC

*** This bug has been marked as a duplicate of bug 443131 ***