Bug 447289 - Menu metrics don't match those of the QStyle
Summary: Menu metrics don't match those of the QStyle
Status: RESOLVED FIXED
Alias: None
Product: frameworks-qqc2-desktop-style
Classification: Unclassified
Component: general (show other bugs)
Version: 5.89.0
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-20 14:41 UTC by Raghavendra kamath
Modified: 2022-01-06 15:15 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.91


Attachments
screenshot showing inconsistent spacing in hamburger (65.94 KB, image/png)
2021-12-20 14:41 UTC, Raghavendra kamath
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raghavendra kamath 2021-12-20 14:41:35 UTC
Created attachment 144717 [details]
screenshot showing inconsistent spacing in hamburger

Comparing the hamburger menu in elisa and dolphins shows that dolphins hamburger menu is tighter in spacing that elisa's. The space in elisa's hamburger menu makes it look clean while tighter menu in dolphin makes it look busy. Regardless of which spacing to use the spacing across application in KDE can be same to maintain consistency.

I am guessing this should be filed under Dolphin since I notice the spacing issue in dolphin and I think dolphin's menu need improvement. If this is not the right product please move this to correct location or let me know the correct place so that I file a bug in that product.

Attaching a screenshot comparing both hamburger menu left is dolphin and right is elisa
Comment 1 Nate Graham 2021-12-20 14:50:54 UTC
The problem is actually the opposite here: menus in QtQuick apps aren't respecting the metrics of the QWidgets menus.

If we want bigger menu items, that would ideally need to be set in the QStyle, and it would be inherited automatically in QtQuick apps like Elisa. However we did try this once before and a lot of people hated it, especially those who use apps with very large menus that became scrollable as a result of the change.
Comment 2 Bug Janitor Service 2021-12-23 19:16:34 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/qqc2-desktop-style/-/merge_requests/112
Comment 3 Nate Graham 2022-01-06 15:15:07 UTC
Git commit bc0ca29bd47ce45b30c66bd8743b6a48e20123d2 by Nate Graham.
Committed on 06/01/2022 at 15:14.
Pushed by ngraham into branch 'master'.

Use metrics from Breeze for menu items

We can't read them dynamically right now, unfortunately. So the values
are hardcoded.
FIXED-IN: 5.91

M  +3    -0    org.kde.desktop/Menu.qml
M  +3    -3    org.kde.desktop/MenuItem.qml

https://invent.kde.org/frameworks/qqc2-desktop-style/commit/bc0ca29bd47ce45b30c66bd8743b6a48e20123d2