Bug 447262 - Application Launcher on multiple screen broken search bar
Summary: Application Launcher on multiple screen broken search bar
Status: RESOLVED DUPLICATE of bug 443131
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.23.4
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-20 09:38 UTC by lesto
Modified: 2022-01-11 22:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lesto 2021-12-20 09:38:49 UTC
SUMMARY
if i i click "super" key while the mouse is on the secondary screen, the menu open on the primary screen.
If i digit anything, that should appear on the search bar, but it does not.
Interestingly, if i now open kmenu from the secondary screen, the search bar will contain the lost text!
So it seems the logic part handling the buffer understand correctly to operate on the kmenu of the secondary monitor, while the GUI display and uses the buffer of the primary monitor


STEPS TO REPRODUCE
1. add a secondary monitor
2. add a panel with Application Launcher on the secondary monitor
3. with the mouse on the secondary monitor, click "super" key (Application Launcher will open on primary monitor)
4. digit something, nothing will appear on the search bar
5. with the mouse open the Application Launcher on secondary monitor (search bar will have the text)

OBSERVED RESULT


EXPECTED RESULT
on 3., Application Launcher will open on the monitor with the mouse/last used window
on 4. no matter where the mouse/last application is, text should appear in the newly opened Application Launcher

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.10-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4710HQ CPU @ 2.50GHz
Memory: 11,6 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600
Comment 1 Nate Graham 2022-01-11 22:27:20 UTC

*** This bug has been marked as a duplicate of bug 443131 ***