Bug 447236 - Entire desktop crashes and disappears
Summary: Entire desktop crashes and disappears
Status: RESOLVED DUPLICATE of bug 445893
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-19 17:12 UTC by Rajinder Yadav
Modified: 2022-01-18 23:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rajinder Yadav 2021-12-19 17:12:49 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***

This has stated to happen randomly, in the past week for me. The entire desktop just goes back, the toolbar, background images, desktop icons disappear, leaving a black background, remain windows remain open and function with not error.

I can still open new windows using open the command prompt and typing the application to open.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20211215
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.7-1-default (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 2700X Eight-Core Processor
Memory: 62.7 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3080/PCIe/SSE2
Comment 1 Rajinder Yadav 2021-12-19 17:20:04 UTC
Anyone else coming across this bug, here is a temp workaround:

https://askubuntu.com/questions/481329/can-i-restart-the-kde-plasma-desktop-without-logging-out

I used the following to restart  the plasma shell

kquitapp5 plasmashell || killall plasmashell && kstart5 plasmashell
Comment 2 Nicolas Fella 2021-12-19 21:39:06 UTC
Please try to obtain a backtrace for plasmashell. See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports#Retrieving_a_backtrace_using_coredumpctl for instructions
Comment 3 Rajinder Yadav 2021-12-20 03:52:57 UTC
Hi I searched for coredumpctl and systemd-coredumpctl for opensuse tw, package not found.

I was able to install valgrind, but you will need to provide the command syntax I should use with the name of the process.

Also I believe I need to enable coredump to be saved? Please provide the steps needs to provide a crash log.
Comment 4 Nicolas Fella 2021-12-20 09:00:49 UTC
For OpenSUSE you want to install systemd-coredump
Comment 5 Rajinder Yadav 2021-12-21 02:01:16 UTC
Suggestion helped, but no crash logs founds. I believe coredump needs to be enabled?

$ coredumpctl
Hint: You are currently not seeing messages from other users and the system.
      Users in the 'systemd-journal' group can see all messages. Pass -q to
      turn off this notice.
No coredumps found.

$ sudo coredumpctl
[sudo] password for root: 
No coredumps found.
Comment 6 Rajinder Yadav 2022-01-01 19:32:17 UTC
(gdb) bt
#0  QSGAreaAllocatorNode::isLeaf (this=0x18) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgareaallocator.cpp:93
#1  QSGAreaAllocator::deallocateInNode (this=this@entry=0x7f4668139020, pos=..., node=0x18) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgareaallocator.cpp:170
#2  0x00007f4703029fb6 in QSGAreaAllocator::deallocate (this=this@entry=0x7f4668139020, rect=...)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgareaallocator.cpp:116
#3  0x00007f47030304df in QSGOpenGLAtlasTexture::AtlasBase::remove (this=0x7f4668139010, t=t@entry=0x7f4668a7e460)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgopenglatlastexture.cpp:286
#4  0x00007f470303062d in QSGOpenGLAtlasTexture::TextureBase::~TextureBase (this=0x7f4668a7e460, __in_chrg=<optimized out>)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgopenglatlastexture.cpp:516
#5  QSGOpenGLAtlasTexture::Texture::~Texture (this=0x7f4668a7e460, __in_chrg=<optimized out>)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgopenglatlastexture.cpp:543
#6  0x00007f4703030649 in QSGOpenGLAtlasTexture::Texture::~Texture (this=0x7f4668a7e460, __in_chrg=<optimized out>)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgopenglatlastexture.cpp:543
#7  0x00007f46ee7442bd in QScopedPointerDeleter<QSGTexture>::cleanup (pointer=<optimized out>) at /usr/include/qt5/QtCore/qscopedpointer.h:60
#8  QScopedPointer<QSGTexture, QScopedPointerDeleter<QSGTexture> >::~QScopedPointer (this=<optimized out>, this=<optimized out>) at /usr/include/qt5/QtCore/qscopedpointer.h:107
#9  Plasma::WindowTextureProvider::~WindowTextureProvider (this=<optimized out>, this=<optimized out>)
    at /usr/src/debug/plasma-framework-5.89.0-1.1.x86_64/build/src/declarativeimports/core/corebindingsplugin_autogen/EWIEGA46WW/../../../../../../src/declarativeimports/core/windowthumbnail.h:149
#10 Plasma::WindowTextureProvider::~WindowTextureProvider (this=<optimized out>, this=<optimized out>)
    at /usr/src/debug/plasma-framework-5.89.0-1.1.x86_64/build/src/declarativeimports/core/corebindingsplugin_autogen/EWIEGA46WW/../../../../../../src/declarativeimports/core/windowthumbnail.h:149
#11 0x00007f470307a152 in QSGRenderThread::event (this=0x7f46f800d820, e=0x557ad0b12de0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/qsgthreadedrenderloop.cpp:493
#12 0x00007f4703073b3f in QSGRenderThread::processEventsAndWaitForMore (this=this@entry=0x7f46f800d820)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/qsgthreadedrenderloop.cpp:937
#13 0x00007f4703075fd9 in QSGRenderThread::run (this=0x7f46f800d820) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/qsgthreadedrenderloop.cpp:1053
#14 0x00007f47013bddf1 in QThreadPrivate::start (arg=0x7f46f800d820) at thread/qthread_unix.cpp:329
#15 0x00007f4700f22427 in start_thread (arg=<optimized out>) at pthread_create.c:435
#16 0x00007f4700fab810 in clone3 () at ../sysdeps/unix/sysv/linux/x86_64/clone3.S:81
Comment 7 Rajinder Yadav 2022-01-02 20:42:05 UTC
Here is another bt.

#0  QSGAreaAllocatorNode::isLeaf (this=0x200000001)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgareaallocator.cpp:93
#1  QSGAreaAllocator::deallocateInNode (this=this@entry=0x7f1e2c1394c0, pos=..., node=0x200000001)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgareaallocator.cpp:170
#2  0x00007f1ec4b10fb6 in QSGAreaAllocator::deallocate (this=this@entry=0x7f1e2c1394c0, rect=...)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgareaallocator.cpp:116
#3  0x00007f1ec4b174df in QSGOpenGLAtlasTexture::AtlasBase::remove (this=0x7f1e2c1394b0, t=t@entry=0x7f1e2cc7beb0)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgopenglatlastexture.cpp:286
#4  0x00007f1ec4b1762d in QSGOpenGLAtlasTexture::TextureBase::~TextureBase (this=0x7f1e2cc7beb0, __in_chrg=<optimized out>)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgopenglatlastexture.cpp:516
#5  QSGOpenGLAtlasTexture::Texture::~Texture (this=0x7f1e2cc7beb0, __in_chrg=<optimized out>)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgopenglatlastexture.cpp:543
#6  0x00007f1ec4b17649 in QSGOpenGLAtlasTexture::Texture::~Texture (this=0x7f1e2cc7beb0, __in_chrg=<optimized out>)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/util/qsgopenglatlastexture.cpp:543
#7  0x00007f1eb42492bd in QScopedPointerDeleter<QSGTexture>::cleanup (pointer=<optimized out>) at /usr/include/qt5/QtCore/qscopedpointer.h:60
#8  QScopedPointer<QSGTexture, QScopedPointerDeleter<QSGTexture> >::~QScopedPointer (this=<optimized out>, this=<optimized out>)
    at /usr/include/qt5/QtCore/qscopedpointer.h:107
#9  Plasma::WindowTextureProvider::~WindowTextureProvider (this=<optimized out>, this=<optimized out>)
    at /usr/src/debug/plasma-framework-5.89.0-1.1.x86_64/build/src/declarativeimports/core/corebindingsplugin_autogen/EWIEGA46WW/../../../../../../src/declarativeimports/core/windowthumbnail.h:149
#10 Plasma::WindowTextureProvider::~WindowTextureProvider (this=<optimized out>, this=<optimized out>)
    at /usr/src/debug/plasma-framework-5.89.0-1.1.x86_64/build/src/declarativeimports/core/corebindingsplugin_autogen/EWIEGA46WW/../../../../../../src/declarativeimports/core/windowthumbnail.h:149
#11 0x00007f1ec4b61152 in QSGRenderThread::event (this=0x7f1eb800f510, e=0x55582e852c10)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/qsgthreadedrenderloop.cpp:493
#12 0x00007f1ec4b5ab3f in QSGRenderThread::processEventsAndWaitForMore (this=this@entry=0x7f1eb800f510)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/qsgthreadedrenderloop.cpp:937
#13 0x00007f1ec4b5cfd9 in QSGRenderThread::run (this=0x7f1eb800f510)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.3.x86_64/src/quick/scenegraph/qsgthreadedrenderloop.cpp:1053
#14 0x00007f1ec2ea4df1 in QThreadPrivate::start (arg=0x7f1eb800f510) at thread/qthread_unix.cpp:329
#15 0x00007f1ec2a09427 in start_thread (arg=<optimized out>) at pthread_create.c:435
#16 0x00007f1ec2a92810 in clone3 () at ../sysdeps/unix/sysv/linux/x86_64/clone3.S:81
Comment 8 Rajinder Yadav 2022-01-03 02:00:57 UTC
This crash is happening more frequently, and I raise the severity to high, if not critical.
Comment 9 Bug Janitor Service 2022-01-18 04:36:26 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 10 Nicolas Fella 2022-01-18 23:51:09 UTC

*** This bug has been marked as a duplicate of bug 445893 ***