Bug 447105 - Missing two-finger click options on X11
Summary: Missing two-finger click options on X11
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_touchpad (show other bugs)
Version: 5.23.4
Platform: Manjaro iOS
: VHI normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-12-17 02:42 UTC by Anthony Ettinger
Modified: 2022-01-20 15:29 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Ettinger 2021-12-17 02:42:13 UTC
Noticed on brand new manjaro kde install:

Two finger click (not tap) options are missing. 

If I open mouse settings and then go back to touch PD settings they magically appear. 

This is on surface laptop go


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-12-17 04:15:22 UTC
Can confirm on X11 in KDE Neon, but not with the Wayland session.
Comment 2 Anthony Ettinger 2021-12-17 04:27:04 UTC
I believe manjaro kde uses wayland with x11org libinput wrapper.
Comment 3 Nicolas Fella 2022-01-19 20:02:29 UTC
Do you mean the "Press left and right buttons for middle click" option?
Comment 4 indecisiveautomator 2022-01-19 20:51:21 UTC
I'm not sure what setting this is referring to, but I have options for both what a "Two-finger tap" should do, as well as what should trigger a "Right-Click". This is pretty confusing on its own.

Checked on a Dell Inspiron laptop with Plasma 5.23.90.
Comment 5 Nate Graham 2022-01-19 21:35:23 UTC
What's missing/broken is:

> right-click: (o) press bottom right corner
>              ( ) Press anywhere with two fingers
Comment 6 Bug Janitor Service 2022-01-20 11:56:59 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/811
Comment 7 Nate Graham 2022-01-20 15:28:10 UTC
Git commit 86838b3c072f0596056c91a1754ba8cdb12d7a24 by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 20/01/2022 at 15:27.
Pushed by ngraham into branch 'master'.

Update click method items in load()

This makes sure we re-read the values from the backend. While these
properties are marked as constant, they apparently change after
LibinputTouchpad::getConfig is called, causing issues because the
changed values aren't re-read.

While I would love to fix the root cause (the properties changing while
being marked constant) it would be a massively larger undertaking as in
my opinion the entire code of this should be completely overhauled,
right now it is fraught with races due to all the manual state
management and lack of proper bindable properties.

M  +3    -2    kcms/touchpad/kcm/libinput/touchpad.qml

https://invent.kde.org/plasma/plasma-desktop/commit/86838b3c072f0596056c91a1754ba8cdb12d7a24
Comment 8 Nate Graham 2022-01-20 15:29:12 UTC
Git commit d753c8b44a3474b414edef920de0d8f16be5be75 by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 20/01/2022 at 15:29.
Pushed by ngraham into branch 'Plasma/5.24'.

Update click method items in load()

This makes sure we re-read the values from the backend. While these
properties are marked as constant, they apparently change after
LibinputTouchpad::getConfig is called, causing issues because the
changed values aren't re-read.

While I would love to fix the root cause (the properties changing while
being marked constant) it would be a massively larger undertaking as in
my opinion the entire code of this should be completely overhauled,
right now it is fraught with races due to all the manual state
management and lack of proper bindable properties.


(cherry picked from commit 86838b3c072f0596056c91a1754ba8cdb12d7a24)

M  +3    -2    kcms/touchpad/kcm/libinput/touchpad.qml

https://invent.kde.org/plasma/plasma-desktop/commit/d753c8b44a3474b414edef920de0d8f16be5be75