Bug 447092 - Google chrome application icons are shown as Google Chrome icon after upgrading frameworks
Summary: Google chrome application icons are shown as Google Chrome icon after upgradi...
Status: RESOLVED DUPLICATE of bug 445804
Alias: None
Product: frameworks-plasma
Classification: Unclassified
Component: components (show other bugs)
Version: 5.89.0
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-16 20:59 UTC by Komorebi
Modified: 2022-02-26 16:20 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
KDE Menu Editor (119.04 KB, image/png)
2021-12-16 20:59 UTC, Komorebi
Details
App menu (186.75 KB, image/png)
2021-12-16 21:02 UTC, Komorebi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Komorebi 2021-12-16 20:59:52 UTC
Created attachment 144611 [details]
KDE Menu Editor

SUMMARY
After upgrading to 5.89 my Google Chrome application icons are shown as Google Chrome icon. I've checked .desktop files, and they remain the same, icons are set correctly, KDE Menu Editor icon selector is able to display them in icon change dialog, so they exist in system, however in the app tree they still displayed as Google Chrome. (see screenshot).
This issue affects application menus and taskbar. Updating icons manually with menu editor does nothing. 


STEPS TO REPRODUCE
1. Upgrade frameworks to 5.89
2. See google chrome app icons are disappeared

Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.3
Kernel Version: 5.13.0-22-generic (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Xeon® CPU E3-1225 V2 @ 3.20GHz
Memory: 23,4 GiB of RAM
Graphics Processor: Radeon RX550/550 Series
Comment 1 Komorebi 2021-12-16 21:02:25 UTC
Created attachment 144612 [details]
App menu
Comment 2 Nate Graham 2021-12-17 19:33:12 UTC
So it's working in the Kickoff menu, but broken in the KMenuEdit app? Do I have that right?
Comment 3 Komorebi 2021-12-18 13:17:01 UTC
No, it's broken everywhere except one place in KMenuEdit app. Please see the app menu screenshot.
Comment 4 Bug Janitor Service 2022-01-02 04:34:54 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Komorebi 2022-01-03 15:39:28 UTC
I've found that the issue persists only if I use some icon theme. With breeze icon theme everything looks good.
Comment 6 Nate Graham 2022-01-08 16:16:41 UTC

*** This bug has been marked as a duplicate of bug 445804 ***
Comment 7 Dave 2022-02-26 16:20:26 UTC
I have to second this bug report as of KDE Frameworks version 5.90.0 in Debian Unstable after an upgrade from version 5.88.0
Vivaldi Webapplication icons have all reverted to the generic Vivaldi icon in the launcher. The icon picker (not the icon picker button) from the application launcher editor, however, still shows the correct icon.