Bug 447066 - Ark doesn't compress dir to 7z, and sometimes crashes Dolphin.
Summary: Ark doesn't compress dir to 7z, and sometimes crashes Dolphin.
Status: RESOLVED DUPLICATE of bug 443540
Alias: None
Product: ark
Classification: Unclassified
Component: general (show other bugs)
Version: 21.12.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Elvis Angelaccio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-16 10:21 UTC by Derek
Modified: 2021-12-16 12:59 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Derek 2021-12-16 10:21:16 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***

STEPS TO REPRODUCE
1. Within Dolphin, elect to compress with 7zip via right-click. 
2. Accept defaults (no changes to compression or name or anything).
3. Compression begins, but doesn't finish. Progress keeps going...

Using ZIP works fine.

OBSERVED RESULT
- Ark seems to run forever - progress indicator doesn't finish.
- Resultant 7zip file SEEMS ok, but i don't trust it.
- Ark didn't crash, but Dolphin did when i clicked 'stop' in the notification area. I don't think this was every time, but it happened several times. I submitted a bug and saved the file (below).
- When i had two instances of Dolphin open, the 2nd instance would open a tab in the directory i'm working in (odd!)
- Notification area error box showed:
Dolphin
Compressing 26 files (Failed)
Application closed unexpectedly.


EXPECTED RESULT
Compression to show as finished.


SOFTWARE/OS VERSIONS
Application: dolphin (21.12.0)

Qt Version: 5.15.2
Frameworks Version: 5.89.0
Operating System: Linux 5.15.7-arch1-1 x86_64
Windowing System: X11
Distribution: "Arch Linux"
DrKonqi: 5.23.4 [KCrashBackend]

-- Information about the crash:
See above.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007ff6f028e5c1 in ?? () from /usr/lib/libQt5Core.so.5
#5  0x00007ff6f14aa38d in KJob::result(KJob*, KJob::QPrivateSignal) () from /usr/lib/libKF5CoreAddons.so.5
#6  0x00007ff6f14ab87c in KJob::finishJob(bool) () from /usr/lib/libKF5CoreAddons.so.5
#7  0x00007ff6f028e7cb in ?? () from /usr/lib/libQt5Core.so.5
#8  0x00007ff6d027f9e3 in Kerfuffle::ReadOnlyArchiveInterface::finished(bool) () from /usr/lib/libkerfuffle.so.21
#9  0x00007ff6f028e7cb in ?? () from /usr/lib/libQt5Core.so.5
#10 0x00007ff6f01c0719 in QProcess::finished(int, QProcess::ExitStatus) () from /usr/lib/libQt5Core.so.5
#11 0x00007ff6f01c6226 in ?? () from /usr/lib/libQt5Core.so.5
#12 0x00007ff6f01c635e in ?? () from /usr/lib/libQt5Core.so.5
#13 0x00007ff6f028e800 in ?? () from /usr/lib/libQt5Core.so.5
#14 0x00007ff6f0291c90 in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () from /usr/lib/libQt5Core.so.5
#15 0x00007ff6f029249d in QSocketNotifier::event(QEvent*) () from /usr/lib/libQt5Core.so.5
#16 0x00007ff6f0d2ed62 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQt5Widgets.so.5
#17 0x00007ff6f025741a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/libQt5Core.so.5
#18 0x00007ff6f02b0c5e in ?? () from /usr/lib/libQt5Core.so.5
#19 0x00007ff6edd8952c in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#20 0x00007ff6edddd7b9 in ?? () from /usr/lib/libglib-2.0.so.0
#21 0x00007ff6edd86c11 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#22 0x00007ff6f02b0046 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#23 0x00007ff6f0255d8c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#24 0x00007ff6f025e2f4 in QCoreApplication::exec() () from /usr/lib/libQt5Core.so.5
#25 0x0000558a9041d54e in ?? ()
#26 0x00007ff6efbe3b25 in __libc_start_main () from /usr/lib/libc.so.6
#27 0x0000558a9041d93e in ?? ()
[Inferior 1 (process 20252) detached]

Report to https://bugs.kde.org/
Comment 1 Nicolas Fella 2021-12-16 12:59:11 UTC

*** This bug has been marked as a duplicate of bug 443540 ***