Bug 447035 - waking up (each time)
Summary: waking up (each time)
Status: RESOLVED DUPLICATE of bug 450217
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.19.0
Platform: Other Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-15 17:11 UTC by cma63
Modified: 2022-04-07 09:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cma63 2021-12-15 17:11:48 UTC
Application: akonadiserver (5.19.0 (21.12.0))

Qt Version: 5.15.2
Frameworks Version: 5.89.0
Operating System: Linux 5.15.7-1-default x86_64
Windowing System: Wayland
Distribution: openSUSE Tumbleweed
DrKonqi: 5.23.4 [KCrashBackend]

-- Information about the crash: waking up (each time)

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Server (akonadiserver), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  std::default_delete<Akonadi::Server::Connection>::operator() (__ptr=0x111, this=<optimized out>) at /usr/include/c++/11/bits/unique_ptr.h:79
#7  std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> >::~unique_ptr (this=<optimized out>, this=<optimized out>) at /usr/include/c++/11/bits/unique_ptr.h:361
#8  __gnu_cxx::new_allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > >::destroy<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > (__p=<optimized out>, this=<optimized out>) at /usr/include/c++/11/ext/new_allocator.h:168
#9  std::allocator_traits<std::allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > >::destroy<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > (__p=<optimized out>, __a=...) at /usr/include/c++/11/bits/alloc_traits.h:531
#10 std::vector<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> >, std::allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > >::_M_erase (__position=std::unique_ptr<Akonadi::Server::Connection> = {get() = 0x56489db66b00}, this=<optimized out>) at /usr/include/c++/11/bits/vector.tcc:177
#11 std::vector<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> >, std::allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > >::erase (__position=std::unique_ptr<Akonadi::Server::Connection> = {get() = 0x56489db66b00}, this=<optimized out>) at /usr/include/c++/11/bits/stl_vector.h:1431
#12 Akonadi::Server::AkonadiServer::connectionDisconnected (this=<optimized out>) at /usr/src/debug/akonadi-server-21.12.0-1.1.x86_64/src/server/akonadi.cpp:234
#13 0x00007f6033296fee in QObject::event (this=0x7ffc9636c950, e=0x7f5fac005e10) at kernel/qobject.cpp:1314
#14 0x00007f603326a9cf in doNotify (event=0x7f5fac005e10, receiver=0x7ffc9636c950) at kernel/qcoreapplication.cpp:1154
#15 QCoreApplication::notify (event=<optimized out>, receiver=<optimized out>, this=<optimized out>) at kernel/qcoreapplication.cpp:1140
#16 QCoreApplication::notifyInternal2 (receiver=0x7ffc9636c950, event=0x7f5fac005e10) at kernel/qcoreapplication.cpp:1064
#17 0x00007f603326da47 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x56489db60e00) at kernel/qcoreapplication.cpp:1821
#18 0x00007f60332c2853 in postEventSourceDispatch (s=s@entry=0x56489db68e70) at kernel/qeventdispatcher_glib.cpp:277
#19 0x00007f603141ed9f in g_main_dispatch (context=0x56489db66be0) at ../glib/gmain.c:3381
#20 g_main_context_dispatch (context=0x56489db66be0) at ../glib/gmain.c:4099
#21 0x00007f603141f128 in g_main_context_iterate (context=context@entry=0x56489db66be0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#22 0x00007f603141f1df in g_main_context_iteration (context=0x56489db66be0, may_block=1) at ../glib/gmain.c:4240
#23 0x00007f60332c1ed4 in QEventDispatcherGlib::processEvents (this=0x56489db66300, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#24 0x00007f60332693fb in QEventLoop::exec (this=this@entry=0x7ffc9636c7b0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#25 0x00007f60332716e0 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#26 0x000056489cdea6e6 in AkApplicationBase::exec (this=0x7ffc9636c920) at /usr/src/debug/akonadi-server-21.12.0-1.1.x86_64/src/shared/akapplication.cpp:107
#27 main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/akonadi-server-21.12.0-1.1.x86_64/src/server/main.cpp:65
[Inferior 1 (process 15389) detached]

Possible duplicates by query: bug 446850, bug 446770, bug 446692, bug 446579, bug 446412.
Comment 1 postix 2022-04-07 09:05:14 UTC

*** This bug has been marked as a duplicate of bug 450217 ***