Bug 446983 - Wrong kRunner Search if two Application Launcher (Kickoff) are active
Summary: Wrong kRunner Search if two Application Launcher (Kickoff) are active
Status: RESOLVED DUPLICATE of bug 443131
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.23.4
Platform: Manjaro Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-14 14:58 UTC by Joshua Nestler
Modified: 2021-12-14 20:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joshua Nestler 2021-12-14 14:58:29 UTC
SUMMARY
If two Kickoff Application Launchers are used, the wrong search bar may be used.
This appears only to be the case if both Launchers have been open at least once.
Here is a video to show the bug on my system:
https://youtu.be/LSFXqbJU4jM

STEPS TO REPRODUCE
1. Have two different Application Launcher Applets
2. Open both at least once
3. Try to search for an app on one or the other of these two

OBSERVED RESULT
The selected search field is in the hidden launcher.

EXPECTED RESULT
The selected search field should be in the shown launcher.

SOFTWARE/OS VERSIONS
Linux Kernel Version: 5.15.7-1-MANJARO (64-bit) 
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
%
Comment 1 Nate Graham 2021-12-14 20:45:00 UTC

*** This bug has been marked as a duplicate of bug 443131 ***