Bug 446709 - "Keep window thumbnails" setting missing on Wayland, no window thumbnails available in task manager
Summary: "Keep window thumbnails" setting missing on Wayland, no window thumbnails ava...
Status: RESOLVED DUPLICATE of bug 446061
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: 5.23.4
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-09 03:35 UTC by AlexDeLorenzo.dev
Modified: 2021-12-09 19:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Settings panel with missing option (15.46 KB, image/png)
2021-12-09 03:35 UTC, AlexDeLorenzo.dev
Details
Settings panel with option present (different system with old Plasma) (45.85 KB, image/png)
2021-12-09 03:36 UTC, AlexDeLorenzo.dev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AlexDeLorenzo.dev 2021-12-09 03:35:36 UTC
Created attachment 144374 [details]
Settings panel with missing option

SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. Open System Settings > Display and Monitor > Compositor
2. Hover mouse over running apps in task manager, no thumbnails are shown

OBSERVED RESULT
There's no "Keep window thumbnails" option available. No thumbnails are shown in task manager previews.

EXPECTED RESULT
There should be a "Keep window thumbnails" option. Thumbnails should be shown in task manager previews.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Manjaro testing and stable/Plasma 5.23.4
(available in About System)
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Under `System Settings > Display and Monitor > Compositor` I have these settings:
 - Scale method: Smooth
 - Rendering backend: OpenGL 3.1
 - Latency: Balance of latency and smoothness
 - Tearing prevention ("vsync"): Automatic

I'm using an integrated AMD Cezenne GPU and 5.15.x kernel. The "Keep window thumbnails" was available on this system on Wayland for a while and it worked well, but it seems to have disappeared after an update.
Comment 1 AlexDeLorenzo.dev 2021-12-09 03:36:58 UTC
Created attachment 144375 [details]
Settings panel with option present (different system with old Plasma)
Comment 2 AlexDeLorenzo.dev 2021-12-09 03:46:52 UTC
Should also mention that I'm using PireWire 0.3.40 and WirePlumber 0.4.5.
Comment 3 Nate Graham 2021-12-09 19:29:40 UTC
Thumbnails are automatically kept on Wayland. However a bug sometimes prevents this from working. See Bug 446061.

*** This bug has been marked as a duplicate of bug 446061 ***