Bug 446375 - No animation when hovering over different apps in the taskbar when using wayland.
Summary: No animation when hovering over different apps in the taskbar when using wayl...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.23.4
Platform: Manjaro Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-02 14:21 UTC by juri26
Modified: 2021-12-14 21:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description juri26 2021-12-02 14:21:23 UTC
SUMMARY
No animation when hovering over different apps in the taskbar when using wayland.


STEPS TO REPRODUCE
1. Start plasma wayland session
2. Use the mouse pointer to hover over apps in the taskbar
3. Small information bubbles appear but when moving the mouse to another app in the taskbar, it just jumps over without any animation.

OBSERVED RESULT
No animation when hovering over apps in the taskbar in wayland

EXPECTED RESULT
Smooth animations like in X11

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Comment 1 Nate Graham 2021-12-02 21:20:20 UTC
Ooh this was fixed recently in Plasma 5.24!
Comment 2 Nate Graham 2021-12-02 21:21:48 UTC
Oh actually it was fixed in a framework, so it should be in Frameworks 5.89!
Comment 3 juri26 2021-12-14 19:25:11 UTC
I just updated to Frameworks 5.89 but the issue is still there for some reason. Other bugs like bug 442375 are fixed but not this one.
Comment 4 Nate Graham 2021-12-14 21:26:58 UTC
Oh silly me, it required some KWin changes too. So you'll have to wait until 5.24. Sorry about that.
Comment 5 juri26 2021-12-14 21:49:25 UTC
All right, thank you and have a nice day ;)