Bug 446339 - The bookmarks button in the toolbar unnecessarily requires a click-and-hold
Summary: The bookmarks button in the toolbar unnecessarily requires a click-and-hold
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: bookmark (show other bugs)
Version: 21.08.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-12-01 20:19 UTC by Taha
Modified: 2021-12-01 23:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 21.12


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Taha 2021-12-01 20:19:57 UTC
SUMMARY
The bookmarks button in the toolbar does not work.


STEPS TO REPRODUCE
1. Add a new bookmark
2. Add the bookmark option to the toolbar
3. Click on the newly added bookmark button

OBSERVED RESULT
Nothing happened

EXPECTED RESULT
A list of my bookmarks being shown

SOFTWARE/OS VERSIONS
Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-41-generic (64-bit)
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-8750H CPU @ 2.20GHz
Memory: 7,6 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-12-01 22:57:02 UTC
Looks like you need to press-and-hold it. It needs to be changed around to show the pop-up on click. I'll look into it.
Comment 2 Taha 2021-12-01 22:58:30 UTC
(In reply to Nate Graham from comment #1)
> Looks like you need to press-and-hold it. It needs to be changed around to
> show the pop-up on click. I'll look into it.

You're right. Pressing and holding it, does bring the menu up.
Comment 3 Nate Graham 2021-12-01 23:22:31 UTC
Git commit 4a3d0ce4eb7e30cdb8b427b326fff71183efd4bd by Nate Graham.
Committed on 01/12/2021 at 23:21.
Pushed by ngraham into branch 'release/21.12'.

Open bookmarks toolbar button on click; don't require press-and-hold
FIXED-IN: 21.12

M  +1    -0    src/MainWindow.cpp

https://invent.kde.org/utilities/konsole/commit/4a3d0ce4eb7e30cdb8b427b326fff71183efd4bd
Comment 4 Nate Graham 2021-12-01 23:23:43 UTC
The fix will be released on December 9th. Thanks for reporting this! It was a nice easy fix.
Comment 5 Taha 2021-12-01 23:25:19 UTC
(In reply to Nate Graham from comment #4)
> The fix will be released on December 9th. Thanks for reporting this! It was
> a nice easy fix.

Thank you for the quick fix :)