Bug 446334 - Plasma suddenly crashed
Summary: Plasma suddenly crashed
Status: RESOLVED DUPLICATE of bug 431334
Alias: None
Product: plasmashell
Classification: Unclassified
Component: generic-crash (show other bugs)
Version: 5.18.7
Platform: openSUSE RPMs Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-01 18:39 UTC by Krystof Jelinek
Modified: 2021-12-01 20:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Krystof Jelinek 2021-12-01 18:39:44 UTC
SUMMARY
Application: plasmashell (5.18.6)

Qt Version: 5.12.7
Frameworks Version: 5.76.0
Operating System: Linux 5.3.18-59.34-default x86_64
Windowing system: X11
Distribution: "openSUSE Leap 15.3"

-- Information about the crash:
Plasma suddenly crashed, then restarted itself.

- What I was doing when the application crashed:
Yast, Chromium and Konsole were opened.

- Unusual behavior I noticed:
Before the crash, a kernel panic occured. The system however restarted normally, and then the crash occured.

- Custom settings of the application:
Customized plasma settings, which should not have any impact on the system (theme: breeze dark)

The crash does not seem to be reproducible.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
[KCrash Handler]
#4  std::__atomic_base<int>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=0x660066006f0053) at /usr/include/c++/7/bits/atomic_base.h:396
#5  QAtomicOps<int>::load<int>(std::atomic<int> const&) (_q_value=...) at /usr/include/qt5/QtCore/qatomic_cxx11.h:227
#6  QBasicAtomicInteger<int>::load() const (this=0x660066006f0053) at /usr/include/qt5/QtCore/qbasicatomic.h:103
#7  QtPrivate::RefCount::ref() (this=0x660066006f0053) at /usr/include/qt5/QtCore/qrefcount.h:55
#8  QString::QString(QString const&) (other=..., this=0x7ffffa4a8590) at /usr/include/qt5/QtCore/qstring.h:958
#9  (anonymous namespace)::getProcessInfo(QString const&, KProcessList::KProcessInfo&) (procId=..., processInfo=...) at /usr/src/debug/kcoreaddons-5.76.0-bp153.2.2.1.x86_64/src/lib/util/kprocesslist_unix.cpp:91
#10 0x00007f2f7735ca81 in KProcessList::processInfo(long long) (pid=pid@entry=6612) at /usr/src/debug/kcoreaddons-5.76.0-bp153.2.2.1.x86_64/src/lib/util/kprocesslist_unix.cpp:150
#11 0x00007f2f57dd31e8 in TaskManager::servicesFromPid(unsigned int, QExplicitlySharedDataPointer<KSharedConfig>) (pid=pid@entry=6612, rulesConfig=...) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/libtaskmanager/tasktools.cpp:531
#12 0x00007f2f57dd3db4 in TaskManager::windowUrlFromMetadata(QString const&, unsigned int, QExplicitlySharedDataPointer<KSharedConfig>, QString const&) (appId=..., pid=pid@entry=6612, rulesConfig=..., xWindowsWMClassName=...) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/libtaskmanager/tasktools.cpp:433
#13 0x00007f2f57de25b0 in TaskManager::XWindowTasksModel::Private::windowUrl(unsigned long long) (this=this@entry=0x564168e5bfa0, window=<optimized out>) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/libtaskmanager/xwindowtasksmodel.cpp:531
#14 0x00007f2f57de2b2b in TaskManager::XWindowTasksModel::Private::appData(unsigned long long) (this=0x564168e5bfa0, window=<optimized out>) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/libtaskmanager/xwindowtasksmodel.cpp:447
#15 0x00007f2f57de7005 in TaskManager::XWindowTasksModel::data(QModelIndex const&, int) const (this=0x564168e5c5a0, index=<optimized out>, role=<optimized out>) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/libtaskmanager/xwindowtasksmodel.cpp:682
#16 0x00007f2f758ba028 in QAbstractProxyModel::data(QModelIndex const&, int) const (this=<optimized out>, proxyIndex=<optimized out>, role=293) at itemmodels/qabstractproxymodel.cpp:245
#17 0x00007f2f57db9544 in QModelIndex::data(int) const (arole=293, this=0x7ffffa4a8c80) at /usr/include/qt5/QtCore/qabstractitemmodel.h:458
#18 TaskManager::TaskFilterProxyModel::acceptsRow(int) const (this=0x564168eb9d70, sourceRow=2) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/libtaskmanager/taskfilterproxymodel.cpp:251
#19 0x00007f2f758c8612 in QSortFilterProxyModelPrivate::_q_sourceDataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=<optimized out>, source_top_left=<optimized out>, source_bottom_right=<optimized out>, roles=...) at itemmodels/qsortfilterproxymodel.cpp:1403
#20 0x00007f2f758cad38 in QSortFilterProxyModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qsortfilterproxymodel.cpp:224
#21 0x00007f2f75923eb5 in QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0x564168e5c430, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffffa4a8fd0) at kernel/qobject.cpp:3804
#22 0x00007f2f759245c7 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x564168e5c430, m=m@entry=0x7f2f75da1520 <QAbstractItemModel::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffffa4a8fd0) at kernel/qobject.cpp:3657
#23 0x00007f2f7589b4ec in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=this@entry=0x564168e5c430, _t1=..., _t2=..., _t3=<optimized out>) at .moc/moc_qabstractitemmodel.cpp:556
#24 0x00007f2f758bd351 in QIdentityProxyModelPrivate::_q_sourceDataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=<optimized out>, topLeft=..., bottomRight=<optimized out>, roles=<optimized out>) at itemmodels/qidentityproxymodel.cpp:483
#25 0x00007f2f758bf028 in QIdentityProxyModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qidentityproxymodel.cpp:163
#26 0x00007f2f75923eb5 in QMetaObject::activate(QObject*, int, int, void**) (sender=0x564168e5c5a0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffffa4a91f0) at kernel/qobject.cpp:3804
#27 0x00007f2f759245c7 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=<optimized out>, m=m@entry=0x7f2f75da1520 <QAbstractItemModel::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffffa4a91f0) at kernel/qobject.cpp:3657
#28 0x00007f2f7589b4ec in QAbstractItemModel::dataChanged(QModelIndex const&, QModelIndex const&, QVector<int> const&) (this=<optimized out>, _t1=..., _t2=..., _t3=...) at .moc/moc_qabstractitemmodel.cpp:556
#29 0x00007f2f57de1db6 in TaskManager::XWindowTasksModel::Private::dataChanged(unsigned long long, QVector<int> const&) (this=this@entry=0x564168e5bfa0, window=<optimized out>, roles=...) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/libtaskmanager/xwindowtasksmodel.cpp:422
#30 0x00007f2f57de4602 in TaskManager::XWindowTasksModel::Private::windowChanged(unsigned long long, QFlags<NET::Property>, QFlags<NET::Property2>) (this=0x564168e5bfa0, window=<optimized out>, properties=..., properties2=...) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/libtaskmanager/xwindowtasksmodel.cpp:409
#31 0x00007f2f75923fcf in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7ffffa4a9450, r=0x564168e5c5a0, this=0x564168718c10) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#32 QMetaObject::activate(QObject*, int, int, void**) (sender=0x564168eb74f0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7ffffa4a9450) at kernel/qobject.cpp:3784
#33 0x00007f2f759245c7 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=<optimized out>, m=m@entry=0x7f2f57ffdd60 <XWindowSystemEventBatcher::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7ffffa4a9450) at kernel/qobject.cpp:3657
#34 0x00007f2f57da746b in XWindowSystemEventBatcher::windowChanged(unsigned long long, QFlags<NET::Property>, QFlags<NET::Property2>) (this=<optimized out>, _t1=<optimized out>, _t2=..., _t3=...) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/build/libtaskmanager/taskmanager_autogen/EWIEGA46WW/moc_xwindowsystemeventbatcher.cpp:175
#35 0x00007f2f57de0bf1 in XWindowSystemEventBatcher::<lambda(WId, NET::Properties, NET::Properties2)>::operator() (properties2=..., properties=..., window=<optimized out>, __closure=0x564168e17360) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/libtaskmanager/xwindowsystemeventbatcher.cpp:63
#36 QtPrivate::FunctorCall<QtPrivate::IndexesList<0, 1, 2>, QtPrivate::List<long long unsigned int, QFlags<NET::Property>, QFlags<NET::Property2> >, void, XWindowSystemEventBatcher::XWindowSystemEventBatcher(QObject*)::<lambda(WId, NET::Properties, NET::Properties2)> >::call (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:146
#37 QtPrivate::Functor<XWindowSystemEventBatcher::XWindowSystemEventBatcher(QObject*)::<lambda(WId, NET::Properties, NET::Properties2)>, 3>::call<QtPrivate::List<unsigned long long, QFlags<NET::Property>, QFlags<NET::Property2> >, void> (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:256
#38 QtPrivate::QFunctorSlotObject<XWindowSystemEventBatcher::XWindowSystemEventBatcher(QObject*)::<lambda(WId, NET::Properties, NET::Properties2)>, 3, QtPrivate::List<long long unsigned int, QFlags<NET::Property>, QFlags<NET::Property2> >, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=0x564168e17350, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:439
#39 0x00007f2f75923fcf in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7ffffa4a9620, r=0x564168eb74f0, this=0x564168e17350) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#40 QMetaObject::activate(QObject*, int, int, void**) (sender=sender@entry=0x7f2f77eebc40 <(anonymous namespace)::Q_QGS_g_kwmInstanceContainer::innerFunction()::holder>, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=9, argv=argv@entry=0x7ffffa4a9620) at kernel/qobject.cpp:3784
#41 0x00007f2f759245c7 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x7f2f77eebc40 <(anonymous namespace)::Q_QGS_g_kwmInstanceContainer::innerFunction()::holder>, m=m@entry=0x7f2f77eea060 <KWindowSystem::staticMetaObject>, local_signal_index=local_signal_index@entry=9, argv=argv@entry=0x7ffffa4a9620) at kernel/qobject.cpp:3657
#42 0x00007f2f77cb1eeb in KWindowSystem::windowChanged(unsigned long long, QFlags<NET::Property>, QFlags<NET::Property2>) (this=this@entry=0x7f2f77eebc40 <(anonymous namespace)::Q_QGS_g_kwmInstanceContainer::innerFunction()::holder>, _t1=<optimized out>, _t1@entry=62914566, _t2=..., _t3=...) at /usr/src/debug/kwindowsystem-5.76.0-bp153.2.2.1.x86_64/build/src/KF5WindowSystem_autogen/EWIEGA46WW/moc_kwindowsystem.cpp:361
#43 0x00007f2f5e34df26 in NETEventFilter::nativeEventFilter(xcb_generic_event_t*) (this=0x5641665d80d0, ev=0x7f2f60009780) at /usr/src/debug/kwindowsystem-5.76.0-bp153.2.2.1.x86_64/src/platforms/xcb/kwindowsystem.cpp:289
#44 0x00007f2f758f0caf in QAbstractEventDispatcher::filterNativeEvent(QByteArray const&, void*, long*) (this=<optimized out>, eventType=..., message=message@entry=0x7f2f60009780, result=result@entry=0x7ffffa4a9738) at kernel/qabstracteventdispatcher.cpp:484
#45 0x00007f2f68570f0c in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) (this=this@entry=0x564165dc8eb0, event=event@entry=0x7f2f60009780) at qxcbconnection.cpp:534
#46 0x00007f2f68571c85 in QXcbConnection::processXcbEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x564165dc8eb0, flags=flags@entry=...) at qxcbconnection.cpp:1027
#47 0x00007f2f68598253 in xcbSourceDispatch(GSource*, GSourceFunc, gpointer) (source=<optimized out>) at qxcbeventdispatcher.cpp:103
#48 0x00007f2f6f140694 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#49 0x00007f2f6f140a30 in  () at /usr/lib64/libglib-2.0.so.0
#50 0x00007f2f6f140abc in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#51 0x00007f2f7595142f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x564165efcd40, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#52 0x00007f2f758f25fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffffa4a9a10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#53 0x00007f2f758fb800 in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1389
#54 0x000056416411fad4 in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/plasma5-workspace-5.18.6-bp153.4.2.3.x86_64/shell/main.cpp:228
[Inferior 1 (process 3042) detached]

Possible duplicates by query: bug 445417, bug 443784, bug 443352, bug 443059, bug 440840.




SOFTWARE/OS VERSIONS
Operating System: openSUSE Leap 15.3
KDE Plasma Version: 5.18.6
KDE Frameworks Version: 5.76.0
Qt Version: 5.12.7
Kernel Version: 5.3.18-59.34-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 11,1 GiB
Comment 1 Nate Graham 2021-12-01 20:58:03 UTC

*** This bug has been marked as a duplicate of bug 431334 ***